Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Issues Connecting to new 5500 WLC

I have an existing 4400 that is connected to the network and it is managing a single old Cisco AP.  It has been installed for about 6 years.

I've just added a new 5500 (intending to replace the 4400) to the environment along with new 2602 WAP's.  The 5500 uses port 1 with a

1000BASE-T SFP connection into a 2960 switch.  On both ends of the connection I am using StarTech.com Cisco Compatible Gigabit RJ45 Copper SFP Transceiver Module Mini-GBIC's - 10/100/1000Base-T Copper SFP Module .

The 5500 is configured with an IP address, 255.255.0.0 mask and has the gateway address in it. 

I have no problems accessing the 5500 via the service port and viewing/changing the configuration.

But I cannot cannot ping the 5500 from the network,

nor can the 5500 ping any devices, including the switch that it is connected to.

I could be suspicious of the GBIC's but there are no obvious errors showing in the statistics and some data seems to be passing between the 2960 and the 5500.

I've tried setting the VLAN to 0 and to 100 after reading some posts.

The port on the switch #23 shows that it is trunked.  I enabled fastport for it.

Any troubleshooting ideas?

Thanks in advance.

Everyone's tags (2)
24 REPLIES
VIP Purple

Re: Issues Connecting to new 5500 WLC

Hi Rob,

It is looks like trunking between switch port & WLC is not correct. configure it like below & try it again

G1/0/23

sw mode trunk

sw trunk native vlan   If htere is no specific native vlan leave it to default 1

sw trunk allowed vlan 100,x,y  where x, y are normal user vlans intend to configure on this WLC

spanning-tree portfast trunk

in WLC

config  interface address management   255.255.0.0

config  interface vlan management 100

config  interface port management 1

You need to be given WLC management IP in vlan 100 & SVI for vlan 100 to be defined on your L3 switch. That SVI IP should be the gateway address in the above WLC config line.

Still if this does not work post your "show interface detail management" output

HTH

Rasika

New Member

Issues Connecting to new 5500 WLC

I did the commands but I am not seeing any success with ping.

Interface Name................................... management

MAC Address...................................... e8:b7:48:a1:e8:80

IP Address....................................... 10.29.1.242

IP Netmask....................................... 255.255.0.0

IP Gateway....................................... 10.29.1.245

External NAT IP State............................ Disabled

External NAT IP Address.......................... 0.0.0.0

VLAN............................................. 100

Quarantine-vlan.................................. 0

Active Physical Port............................. 1

Primary Physical Port............................ 1

Backup Physical Port............................. Unconfigured

Primary DHCP Server.............................. 10.29.1.201

Secondary DHCP Server............................ 10.95.9.1

DHCP Option 82................................... Disabled

ACL.............................................. Unconfigured

AP Manager....................................... Yes

Guest Interface.................................. No

L2 Multicast..................................... Disabled

VIP Purple

Issues Connecting to new 5500 WLC

On the switch side give this output where x/x is the WLC connected switch port

show run int x/x

show interface x/x

show interface trunk

show span vlan 100

I hope physical link is up

New Member

Issues Connecting to new 5500 WLC

Here is the switch port information:

I

FastEthernet0/23 is up, line protocol is up (connected)

  Hardware is Fast Ethernet, address is 0cd9.9654.0017 (bia 0cd9.9654.0017)

  Description: WLC 5550 242

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, media type is 10/100BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:00:07, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 235 bytes, 0 no buffer

     Received 0 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     1 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     1420055 packets output, 310035787 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

VIP Purple

Issues Connecting to new 5500 WLC

Your switchport is Fast Ethernet, WLC expect this to be a Gig port

Change trunk to G0/1 or G0/2 if that available in this 2960 switch. This may be the problem

New Member

Issues Connecting to new 5500 WLC

Here are the other items.

Building configuration...

Current configuration : 305 bytes

!

interface FastEthernet0/13

switchport mode access

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

macro description cisco-desktop

spanning-tree portfast

spanning-tree bpduguard enable

end

APWNOGSW102#show interface trunk

Port        Mode             Encapsulation  Status        Native vlan

Fa0/23      on               802.1q         trunking      1

Fa0/27      on               802.1q         trunking      1

Fa0/31      on               802.1q         trunking      1

Fa0/46      on               802.1q         trunking      1

Fa0/47      on               802.1q         trunking      1

Fa0/48      on               802.1q         trunking      1

Gi0/1       on               802.1q         trunking      1

Gi0/2       on               802.1q         trunking      1

Port        Vlans allowed on trunk

Fa0/23      100

Fa0/27      1-4094

Fa0/31      1-4094

Fa0/46      1

Fa0/47      1-4094

Fa0/48      1-4094

Gi0/1       1

Gi0/2       1

Port        Vlans allowed and active in management domain

Fa0/23      none

Fa0/27      1

Port        Vlans allowed and active in management domain

Fa0/31      1

Fa0/46      1

Fa0/47      1

Fa0/48      1

Gi0/1       1

Gi0/2       1

Port        Vlans in spanning tree forwarding state and not pruned

Fa0/23      none

Fa0/27      1

Fa0/31      1

Fa0/46      1

Fa0/47      1

Fa0/48      1

Gi0/1       1

Gi0/2       1

APWNOGSW102# show span vlan 100

Spanning tree instance(s) for vlan 100 does not exist.

APWNOGSW102#

VIP Purple

Issues Connecting to new 5500 WLC

Also you did not define vlan 100 on this 2960. Define this layer 2 vlan first

New Member

Issues Connecting to new 5500 WLC

I did have it defined but then deleted it.  I will re-add it now.

VIP Purple

Re: Issues Connecting to new 5500 WLC

Also changed WLC trunk to a Gig port in the switch

New Member

Issues Connecting to new 5500 WLC

I moved the WLC5500 connection to gi0/1.

APWNOGSW102#show run int gi0/1

Building configuration...

Current configuration : 258 bytes

!

interface GigabitEthernet0/1

switchport trunk allowed vlan 1

switchport mode trunk

srr-queue bandwidth share 1 30 35 5

priority-queue out

mls qos trust cos

macro description cisco-switch

auto qos trust

spanning-tree link-type point-to-point

end

I also recreated the VLAN 100 on the switch. 

APWNOGSW102# show span vlan 100

VLAN0100

  Spanning tree enabled protocol rstp

  Root ID    Priority    32868

             Address     0cd9.9654.0000

             This bridge is the root

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)

             Address     0cd9.9654.0000

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- ----------------------------

Fa0/27              Desg FWD 19        128.27   P2p

Fa0/31              Desg FWD 19        128.31   P2p

Fa0/47              Desg FWD 19        128.47   P2p

Fa0/48              Desg FWD 19        128.48   P2p

New Member

Issues Connecting to new 5500 WLC

I noticed that the gi0/1 port wasn't showing for vlan 100, so I changed that.  Still not seeing any response to pings from the switch side or the WLC500 yet.... ;-(

APWNOGSW102#show span vlan 100

VLAN0100

  Spanning tree enabled protocol rstp

  Root ID    Priority    32868

             Address     0cd9.9654.0000

             This bridge is the root

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)

             Address     0cd9.9654.0000

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- ----------------------------

Fa0/27              Desg FWD 19        128.27   P2p

Fa0/31              Desg FWD 19        128.31   P2p

Fa0/47              Desg FWD 19        128.47   P2p

Fa0/48              Desg FWD 19        128.48   P2p

Gi0/1               Desg BKN*4         128.49   P2p *PVID_Inc

New Member

Issues Connecting to new 5500 WLC

Here is what it looks like now.

APWNOGSW102#show interfaces gi0/1

GigabitEthernet0/1 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 0cd9.9654.0031 (bia 0cd9.9654.0031)

  Description: WLC5500

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not set

  Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:01, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     35726281 packets input, 7607357050 bytes, 0 no buffer

     Received 2138152 broadcasts (1203919 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 1203919 multicast, 0 pause input

     0 input packets with dribble condition detected

     36863144 packets output, 21929997593 bytes, 0 underruns

APWNOGSW102#show interfaces gi0/1 trunk

Port        Mode             Encapsulation  Status        Native vlan

Gi0/1       on               802.1q         trunking      100

Port        Vlans allowed on trunk

Gi0/1       100

Port        Vlans allowed and active in management domain

Gi0/1       100

Port        Vlans in spanning tree forwarding state and not pruned

Gi0/1       none

VIP Purple

Re: Issues Connecting to new 5500 WLC

Allow vlan 100 in ur trunk

Sent from Cisco Technical Support iPhone App

VIP Purple

Re: Issues Connecting to new 5500 WLC

I noticed ur 2960 switch is root for vlan 100. Root shoul be the switch where gateway defined for vlan 100. Make sure vlan 100 exist in all switches and allow it across trunk links upto root. I think that is the only missing part

Sent from Cisco Technical Support iPhone App

New Member

Issues Connecting to new 5500 WLC

Let me verify what you are saying:

1. The switch that is connected to the WLC has VLAN100 defined on it.

2. All other switches need VLAN100 defined on them separately.

3. All Trunk Links should allow "ALL" (in my case that is ok since I'm replacing VLAN1 with VLAN100).

Is that sound correct?

VIP Purple

Issues Connecting to new 5500 WLC

Hi Rob,

1. Go to the switch where you defined SVI for vlan 100 (ie 10.29.1.245). Make sure vlan 100 defined on that switch & that switch become the root for vlan 100. If you haven't configure spanning priority for that vlan in that switch then following command will ensure this switch become root always for vlan 100

"spanning-tree vlan 100 priority 0"

2. Then see how your 2960 switch connected to this SVI defined switch. If it is directly connected then you should be fine. If not, you have to define vlan 100 in transit switches till you go back to 2960.

3. If turnk ports allow all vlan for inter-switch trunk links at the moment leave as it is, you do not want to manually add vlan 100 in that case

once you do this & then go to 2960 switch & run "show span vlan 100". If everything correct you should see your SVI defined switch mac address as root.

Hope this clear, if not let me know

Regards

Rasika

New Member

Issues Connecting to new 5500 WLC

The 10.29.1.245 is our gateway to the WAN (Cisco 2800).  I cannot make changes to it because it is owned by ATT.  What do you suggest in this case?

VIP Purple

Issues Connecting to new 5500 WLC

Ok,if that is the case how 2800 connected to your switches ? Is it directly connected to 2960 or not. Please let us know..

then will help you

New Member

Issues Connecting to new 5500 WLC

10.29.1.245 is directly connected to 10.29.100.100 which is the same switch that the WLC5500 (and WLC4400) are connected to.

VIP Purple

Issues Connecting to new 5500 WLC

Ok then it would be easy.

Check in your 2800 "show ip int brief | ex un" output & post it here.

also show run int g0.100 (or correct subinterface) config where you defined this gateway address

New Member

Issues Connecting to new 5500 WLC

I cannot login to 10.29.1.245 to run any commands.  I do have a copy of the configuration from it.  Here is a subset of the interface settings. Is this what you wanted to see?

interface FastEthernet0/0

description $$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$

ip address 10.29.1.249 255.255.0.0

ip policy route-map INTERNETDSL4

speed auto

full-duplex

vrrp 1 description primary active GRP 1

vrrp 1 ip 10.29.1.245

vrrp 1 preempt delay minimum 20

vrrp 1 priority 110

vrrp 1 track 1 decrement 15

no cdp enable

no mop enabled

service-policy output voice

I am not sure I understand the second request.  Here is the information from the 10.29.100.100 switch for the port that connects to the WLC5500, gi0/1.

APWNOGSW100#show run int gi0/1

Building configuration...

Current configuration : 300 bytes

!

interface GigabitEthernet0/1

description WLC5500

switchport trunk native vlan 100

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

macro description cisco-switch

auto qos voip trust

spanning-tree link-type point-to-point

end

VIP Purple

Re: Issues Connecting to new 5500 WLC

Hi Rob,

I still see a mistake in G0/1 of your 2960 as you made vlan 100 as native. Remove that config line

Int g0/1

no switchport trunk native vlan 100

switchport trunk allowed vlan 100

From your 2960 switch can you ping 10.29.1.245 ? If not we need to fix that first.

let me know

New Member

Issues Connecting to new 5500 WLC

Ok, I remove vlan100 as native.  In the GUI, it made me enter 1 as the native Lan.  Is that ok?

The 2950 switch at 10.29.100.100 can always ping 10.29.1.245.  It just can't ping the WLC5500 at 10.29.1.242 (which is connected to its the gi0/1 port.  Nor can the WLC5500 ping anything.

I will be traveling tomorrow for part of the day, but feel free to reply.  Thanks for all of the suggestions so far!

VIP Purple

Re: Issues Connecting to new 5500 WLC

wait, you said change it via GUI ?  You should only change the 2960 G0/1 configuration & not WLC end

See wether it make any difference

545
Views
0
Helpful
24
Replies