Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Macbook drops wireless connection while working with Autonomous 1142AG Access Point and roaming from one 1142 AP to another.

 

Hi everyone. We have 29 autonomous 1142 APs (serial number: AIR-AP1142N-C-K9) installed in a 4 Floors high school building.  Several of our Macbooks will suddenly drop wireless connection while working,  They will have full signal when the wireless icon go grey and lost the connection ,teachers and student need manually reconnect to the AccessPoint ,the macbook will not automatically reconnect to the same SSID. and when people hold the macbook and walking between library and classroom , the wireless connection will also drop and can't roaming automaticly. we have total 30 AP installed in the 4 floor high school building and the coverage is good. there should be overlapping area between the AP's coverage. 

Windows laptops have no problem staying connected, even when roaming between APs.
 
I see the following 3 logs when macbook drops connection:
-------------------------------------------------------------------
"Interface Dot11Radio0, Station [MAC ADDRESS] Reassociated KEY_MGMT[WPAv2 PSK]
followed 4-8 seconds later by:
“Interface Dot11Radio0, Deauthenticating Station [MAC ADDRESS] Reason: Sending station has left the BSS”
followed immediately by:
“Station [MAC ADDRESS] Authentication failed”
--------------------------------------------------------------------

 


We have research in the macbook's console app , when the macbook drop wireless connection ,the system log is show as following:
-----------------------------------------------------------------------------------------------
"Feb 20 14:14:54 PD-US-T02.local airportd[568]: _processSystemPSKAssoc: No password for network <CWNetwork: 0x7fb440c29210> [ssid=Staff, bssid=e8:40:40:b3:96:12, security=WPA2 Personal, rssi=-74, channel=<CWChannel: 0x7fb440c56860> [channelNumber=157(5GHz), channelWidth={40MHz(+1)}], ibss=0] in the system keychain"
--------------------------------------------------------------------------------------------------

 


All the Autonomous AP has the same IOS file--c1140-k9w7-mx.152-2.JA1. before we had upgrade all the AP
to this same IOS , there is also wireless drop problem and roaming problems.

 


And another even more strange thing is that , the radio of the AP, will go to physical up and protocol down status, just like the following shows:
-------------------------------------------------------------
PD2-1142-R212#sh ip int brie
Interface                  IP-Address      OK? Method Status                Protocol
BVI1                       172.24.6.34     YES NVRAM  up                    up      
Dot11Radio0                unassigned      YES NVRAM  up                    up      
Dot11Radio0.8              unassigned      YES unset  up                    up      
Dot11Radio0.30             unassigned      YES unset  up                    up      
Dot11Radio0.48             unassigned      YES unset  up                    up      
Dot11Radio0.104            unassigned      YES unset  up                    up      
Dot11Radio0.108            unassigned      YES unset  up                    up      
Dot11Radio0.188            unassigned      YES unset  up                    up      
Dot11Radio0.192            unassigned      YES unset  up                    up      
Dot11Radio1                unassigned      YES NVRAM  up                    down    
Dot11Radio1.1              unassigned      YES unset  up                    down    
Dot11Radio1.8              unassigned      YES unset  up                    down    
Dot11Radio1.30             unassigned      YES unset  up                    down    
Dot11Radio1.48             unassigned      YES unset  up                    down    
Dot11Radio1.104            unassigned      YES unset  up                    down    
Dot11Radio1.108            unassigned      YES unset  up                    down    
Dot11Radio1.188            unassigned      YES unset  up                    down    
Dot11Radio1.192            unassigned      YES unset  up                    down 
-----------------------------------------------------------------------------------

 


and after the radio go to protocol down status ,there will be crash dump file in the flash, just like following shows:

-----------------------------------------------------------------------------------
PD2-1142-R212#sh flash: 

Directory of flash:/

    2  -rwx      331252  Jan 29 2014 11:31:57 +08:00  crashinfo_20140129-113152-CHN
    3  -rwx      380053  Jan 30 2014 10:39:03 +08:00  crashinfo_20140130-103858-CHN
    4  -rwx      255027  Jan 19 2014 20:32:02 +08:00  ap_log_r0_0.log
    5  -rwx         661   Mar 1 1993 08:00:15 +08:00  env_vars
    6  -rwx      107121  Jan 26 2014 05:16:21 +08:00  event.log
   18  drwx         384  Jan 26 2014 05:14:42 +08:00  c1140-k9w7-mx.152-2.JA1
  155  -rwx      146253  Feb 10 2014 21:17:15 +08:00  event.r0
  156  -rwx      255027  Jan 19 2014 20:32:14 +08:00  ap_log_r0_1.log
  157  -rwx      255027  Jan 19 2014 20:32:17 +08:00  ap_log_r0_2.log
  159  -rwx         238  Jan 19 2014 20:33:50 +08:00  r0.rcore.info
  160  -rwx      255027  Mar 21 1993 02:04:09 +08:00  ap_log_r1_0.log
  161  -rwx      152224  Mar 15 1993 02:27:54 +08:00  event.r1
  162  -rwx      255027  Mar 15 1993 02:27:57 +08:00  ap_log_r1_1.log
  163  -rwx      255027  Mar 15 1993 02:28:00 +08:00  ap_log_r1_2.log
    7  -rwx     7110824  Mar 15 1993 02:29:32 +08:00  r1.rcore
  165  -rwx         239  Mar 15 1993 02:29:32 +08:00  r1.rcore.info
    9  -rwx      340985   Feb 1 2014 07:37:24 +08:00  crashinfo_20140201-073720-CHN
   10  -rwx      377683   Feb 2 2014 11:26:46 +08:00  crashinfo_20140202-112641-CHN
   11  -rwx      338943   Feb 1 2014 08:17:33 +08:00  crashinfo_20140201-081729-CHN
   12  -rwx      337487   Feb 7 2014 15:58:35 +08:00  crashinfo_20140207-155830-CHN
   13  -rwx      342077   Feb 8 2014 13:04:22 +08:00  crashinfo_20140208-130417-CHN
   14  -rwx      352638  Jan 24 2014 00:10:28 +08:00  crashinfo_20140124-001023-CHN
   15  -rwx      387559  Feb 14 2014 17:30:22 +08:00  crashinfo_20140214-173017-CHN
   16  -rwx           5  Mar 20 1993 04:15:12 +08:00  private-config
   17  -rwx        2072  Mar 20 1993 04:15:12 +08:00  private-multiple-fs
  164  -rwx        8907  Mar 20 1993 04:15:12 +08:00  config.txt

-------------------------------------------------------------------------------------------


here is the running config, all the AP had the same configuration:

--------------------------------------------------------------------------------------
------------------ show running-config ------------------


Building configuration...

Current configuration : 8330 bytes
!
! No configuration change since last restart
version 15.2
no service pad
service timestamps debug datetime msec localtime show-timezone year
service timestamps log datetime msec localtime show-timezone year
service password-encryption
!
hostname HQ-1142-A204
!
logging buffered 40960
logging rate-limit console 9
enable secret 5 <removed>
!
no aaa new-model
clock timezone CHN 8 0
no ip routing
no ip domain lookup
!
!
dot11 syslog
!
dot11 ssid Guest
   vlan 128
   authentication open 
   mbssid guest-mode
!
dot11 ssid HQ-MGMT
   vlan 188
   authentication open 
   authentication key-management wpa
   wpa-psk ascii 7 050F140E2643404348544143
!
dot11 ssid Staff
   vlan 104
   authentication open 
   authentication key-management wpa version 2
   mbssid guest-mode
   wpa-psk ascii 7 130105130C030A393F252E35647B4A51
!
dot11 ssid Student
   vlan 8
   authentication open 
   authentication key-management wpa version 2
   mbssid guest-mode
   wpa-psk ascii 7 050F140E26434058405C41
!
crypto pki token default removal timeout 0
!
!
username Cisco password 7 <removed>
!
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption vlan 8 mode ciphers aes-ccm 
 !
 encryption vlan 9 mode ciphers aes-ccm 
 !
 encryption vlan 88 mode ciphers tkip 
 !
 encryption vlan 111 mode ciphers aes-ccm 
 !
 encryption vlan 150 mode ciphers tkip 
 !
 encryption vlan 188 mode ciphers tkip 
 !
 encryption vlan 104 mode ciphers aes-ccm 
 !
 encryption vlan 108 mode ciphers aes-ccm 
 !
 ssid Guest
 !
 ssid HQ-MGMT
 !
 ssid Staff
 !
 ssid Student
 !
 antenna gain 0
 mbssid
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.8
 encapsulation dot1Q 8
 no ip route-cache
 bridge-group 8
 bridge-group 8 subscriber-loop-control
 bridge-group 8 spanning-disabled
 bridge-group 8 block-unknown-source
 no bridge-group 8 source-learning
 no bridge-group 8 unicast-flooding
!
interface Dot11Radio0.9
 encapsulation dot1Q 9
 no ip route-cache
 bridge-group 9
 bridge-group 9 subscriber-loop-control
 bridge-group 9 spanning-disabled
 bridge-group 9 block-unknown-source
 no bridge-group 9 source-learning
 no bridge-group 9 unicast-flooding
!
interface Dot11Radio0.104
 encapsulation dot1Q 104
 no ip route-cache
 bridge-group 104
 bridge-group 104 subscriber-loop-control
 bridge-group 104 spanning-disabled
 bridge-group 104 block-unknown-source
 no bridge-group 104 source-learning
 no bridge-group 104 unicast-flooding
!
interface Dot11Radio0.108
 encapsulation dot1Q 108
 no ip route-cache
 bridge-group 108
 bridge-group 108 subscriber-loop-control
 bridge-group 108 spanning-disabled
 bridge-group 108 block-unknown-source
 no bridge-group 108 source-learning
 no bridge-group 108 unicast-flooding
!
interface Dot11Radio0.111
 encapsulation dot1Q 111
 no ip route-cache
 bridge-group 111
 bridge-group 111 subscriber-loop-control
 bridge-group 111 spanning-disabled
 bridge-group 111 block-unknown-source
 no bridge-group 111 source-learning
 no bridge-group 111 unicast-flooding
!
interface Dot11Radio0.128
 encapsulation dot1Q 128
 no ip route-cache
 bridge-group 128
 bridge-group 128 subscriber-loop-control
 bridge-group 128 spanning-disabled
 bridge-group 128 block-unknown-source
 no bridge-group 128 source-learning
 no bridge-group 128 unicast-flooding
!
interface Dot11Radio0.188
 encapsulation dot1Q 188
 no ip route-cache
 bridge-group 188
 bridge-group 188 subscriber-loop-control
 bridge-group 188 spanning-disabled
 bridge-group 188 block-unknown-source
 no bridge-group 188 source-learning
 no bridge-group 188 unicast-flooding
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 !
 encryption vlan 8 mode ciphers aes-ccm 
 !
 encryption vlan 9 mode ciphers aes-ccm 
 !
 encryption vlan 88 mode ciphers tkip 
 !
 encryption vlan 111 mode ciphers aes-ccm 
 !
 encryption vlan 150 mode ciphers tkip 
 !
 encryption vlan 188 mode ciphers tkip 
 !
 encryption vlan 104 mode ciphers aes-ccm 
 !
 encryption vlan 108 mode ciphers aes-ccm 
 !
 ssid Guest
 !
 ssid HQ-MGMT
 !
 ssid Staff
 !
 ssid Student
 !
 antenna gain 0
 mbssid
 channel width 40-above
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio1.8
 encapsulation dot1Q 8
 no ip route-cache
 bridge-group 8
 bridge-group 8 subscriber-loop-control
 bridge-group 8 spanning-disabled
 bridge-group 8 block-unknown-source
 no bridge-group 8 source-learning
 no bridge-group 8 unicast-flooding
!
interface Dot11Radio1.9
 encapsulation dot1Q 9
 no ip route-cache
 bridge-group 9
 bridge-group 9 subscriber-loop-control
 bridge-group 9 spanning-disabled
 bridge-group 9 block-unknown-source
 no bridge-group 9 source-learning
 no bridge-group 9 unicast-flooding
!
interface Dot11Radio1.104
 encapsulation dot1Q 104
 no ip route-cache
 bridge-group 104
 bridge-group 104 subscriber-loop-control
 bridge-group 104 spanning-disabled
 bridge-group 104 block-unknown-source
 no bridge-group 104 source-learning
 no bridge-group 104 unicast-flooding
!
interface Dot11Radio1.108
 encapsulation dot1Q 108
 no ip route-cache
 bridge-group 108
 bridge-group 108 subscriber-loop-control
 bridge-group 108 spanning-disabled
 bridge-group 108 block-unknown-source
 no bridge-group 108 source-learning
 no bridge-group 108 unicast-flooding
!
interface Dot11Radio1.111
 encapsulation dot1Q 111
 no ip route-cache
 bridge-group 111
 bridge-group 111 subscriber-loop-control
 bridge-group 111 spanning-disabled
 bridge-group 111 block-unknown-source
 no bridge-group 111 source-learning
 no bridge-group 111 unicast-flooding
!
interface Dot11Radio1.128
 encapsulation dot1Q 128
 no ip route-cache
 bridge-group 128
 bridge-group 128 subscriber-loop-control
 bridge-group 128 spanning-disabled
 bridge-group 128 block-unknown-source
 no bridge-group 128 source-learning
 no bridge-group 128 unicast-flooding
!
interface Dot11Radio1.188
 encapsulation dot1Q 188
 no ip route-cache
 bridge-group 188
 bridge-group 188 subscriber-loop-control
 bridge-group 188 spanning-disabled
 bridge-group 188 block-unknown-source
 no bridge-group 188 source-learning
 no bridge-group 188 unicast-flooding
!
interface GigabitEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 no keepalive
 bridge-group 1
 bridge-group 1 spanning-disabled
 no bridge-group 1 source-learning
!
interface GigabitEthernet0.8
 encapsulation dot1Q 8
 no ip route-cache
 bridge-group 8
 bridge-group 8 spanning-disabled
 no bridge-group 8 source-learning
!
interface GigabitEthernet0.9
 encapsulation dot1Q 9
 no ip route-cache
 bridge-group 9
 bridge-group 9 spanning-disabled
 no bridge-group 9 source-learning
!
interface GigabitEthernet0.104
 encapsulation dot1Q 104
 no ip route-cache
 bridge-group 104
 bridge-group 104 spanning-disabled
 no bridge-group 104 source-learning
!
interface GigabitEthernet0.108
 encapsulation dot1Q 108
 no ip route-cache
 bridge-group 108
 bridge-group 108 spanning-disabled
 no bridge-group 108 source-learning
!
interface GigabitEthernet0.111
 encapsulation dot1Q 111
 no ip route-cache
 bridge-group 111
 bridge-group 111 spanning-disabled
 no bridge-group 111 source-learning
!
interface GigabitEthernet0.128
 encapsulation dot1Q 128
 no ip route-cache
 bridge-group 128
 bridge-group 128 spanning-disabled
 no bridge-group 128 source-learning
!
interface GigabitEthernet0.188
 encapsulation dot1Q 188
 no ip route-cache
 bridge-group 188
 bridge-group 188 spanning-disabled
 no bridge-group 188 source-learning
!
interface BVI1
 ip address 172.22.50.43 255.255.255.0
 no ip route-cache
!
ip default-gateway 172.22.50.254
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
logging trap warnings
logging 172.21.1.14
snmp-server community <removed> RW
snmp-server community <removed> RO
bridge 1 route ip
!
!
wlccp ap username Cisco password 7 095F4D000A2545425B5E
!
line con 0
line vty 0 4
 login local
 length 0
 transport input all
!
sntp server 172.22.2.254
sntp server 202.120.2.101
end

---------------------------------------------------------------------------------------------

 

 

Everyone's tags (1)
3 REPLIES
Hall of Fame Super Gold

Duplicate posts.  Go here:

Duplicate posts.  

Go here: http://supportforums.cisco.com/discussion/12142951/macbook-drops-wireless-connection-while-working-autonomous-1142ag-access-point

New Member

Hi, Leo :I don't think it is

Hi, Leo :

I don't think it is a duplicate posts ,because my configruration is different , mine is WPA2 with AES-CCM.  still has the drop issue.

and I provide more infomation .  

 

thank you .

 

 

Hall of Fame Super Gold

OMFG!  The flash of your AP

OMFG!  The flash of your AP is filled with crashinfo file(s).  

 

Downgrade the IOS to 12.2 and try again.

161
Views
0
Helpful
3
Replies
CreatePlease to create content