Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

NCS Prime lost license's after application restore

The  NCS Prime from a client was being very weird.

8 out of 10 controllers where suddenly not reachable according to the Prime.

The WLC's themselfs where working OK.

In the maps of the Prime the AP's and associated clients where visible for these WLC's which where "unreachable".

After a restart of the service and reboot the problem was still there.

We also couldnt change the SNMP or SSH parameters which the Prime uses to reach the WLC's.

The Prime came up with an error saying it was not able to change the settings.

Since i already rebooted the physical appliance a choose to restore the application database from a week ago.

This seemed to have gone well.

After the restore however the NCS seems to have lost the licenses ..

The licenses are still present in the /opt/CSCOlumos/licenses directory

 

ade # ls
20130813055128189.lic  20130813082632415.lic  20140210072424293.lic  restored.cfg                wcs3001474658955738325.lic
20130813055128191.lic  20130814041814472.lic  20140724014323638.lic  wcs169014776390726887.lic   wcs452551912822655664.lic
20130813055129193.lic  20130814041815474.lic  license-scratch.cfg    wcs2080731898091867360.lic  wcs6871734268331641485.lic
20130813055130195.lic  20140123223314119.lic  licenseDT.log          wcs2487758611915656756.lic  wcs8638269602758874311.lic

 

Any ideas ?

 

 

 

 

4 REPLIES
New Member

Im thinking about downloading

Im thinking about downloading the *.lic files from the /opt/CSCOlumos/licenses directory and re-upload them using the GUI anyone know if that will work or will break more ?

 

Update:

 

Re-uploading the licenses doesn't work.

The Prime accepts the license and says the license will be activated when you logout and login again.

Unfortunately this also doesn't work.

New Member

Problem was solved after

Problem was solved after creating SR number (633054719)

 

With a clean install remove the *.lic files from the /opt/CSCOlumos/licenses directory and then you should be able to add them using the GUI

Hi.

Hi.

how did you manage to download .lic files from from the /opt/CSCOlumos/licenses directory ?

New Member

You can enable root access to

You can enable root access to the linux kernel by entering the root_enable command.

The first time you will have to create and confirm the password after you have done this you can enter root_enable again followed by the password.

Now you will have root access to the kernel then you can cd to /opt/CSCOlumos/licenses and scp the files to some server.

138
Views
0
Helpful
4
Replies
CreatePlease to create content