Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PEAP or EAP-FAST, associating but no IP assigned

All -->

I have a number of AP's using both PEAP and EAP-FAST...the clients are associating with the SSID's, but are not receiving an IP address via DHCP.

I've checked VLAN configuration on the AP's, and also the logs on both the AP's and ACS server. Both logs are reporting successful authentication...

Any suggestions?

3 REPLIES
Green

Re: PEAP or EAP-FAST, associating but no IP assigned

What version of IOS are you using, and which APs are you using?

Some of the earlier versions had problems with DHCP responses being dropped into the default VLAN (even though the request came from another valid VLAN).

The request makes it to the server, the server's response makes it all the way back to the AP, where it loses its tag and is put into the Native VLAN.

Let us know

Scott

New Member

Re: PEAP or EAP-FAST, associating but no IP assigned

It's an 1150 running 12.3(7)JA2...

Any suggestions?

-->astroman

Green

Re: PEAP or EAP-FAST, associating but no IP assigned

If the DHCP server is on the AP, then it will only serve the native VLAN (or the administrative VLAN ..... usually the same thing) unless you are directing the DHCP requests through a layer 3 device and something like IP Helper.

Even though the AP is common to all VLANS, (like a switch would be), the native resources are only available to the devices associated with the native / administrative VLAN serving the AP.

Good Luck

Scott

189
Views
0
Helpful
3
Replies
CreatePlease to create content