Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Question about Wireless Controller and LAG.

I have a Wireless Controller 4400.

When I configure the controller with LAG, I have to connect the controller to a L3 switch?

If I connect the controller to a L2 switch the LAG works?

Some one can tell me something about this?

Thanks in advance,

Rui

18 REPLIES

Re: Question about Wireless Controller and LAG.

It doesn't matter if the switch is l2 or l3, the etherchannel port & physical port members of the etherchannel port on the switch will need to be in layer 2 802.1q trunking mode

check out http://www.cisco.com/en/US/tech/tk389/tk213/tsd_technology_support_protocol_home.html

Community Member

Re: Question about Wireless Controller and LAG.

That's OK. I agree with you. I think that's correct thinking like that.

But I did what Cisco says about configuring Etherchannel between a switch 2960 and a wireless controller… and what I have is this:

bastack3#sh lacp 1 internal det

Channel group 1 is not participating in LACP

bastack3#

bastack3#

bastack3#

and in the switch I have:

!

interface Port-channel1

switchport trunk allowed vlan 8,9,99

switchport mode trunk

!

!

interface GigabitEthernet0/21

switchport trunk allowed vlan 8,9,99

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet0/22

switchport trunk allowed vlan 8,9,99

switchport mode trunk

channel-group 1 mode on

!

I have too:

port-channel load-balance src-dst-ip

But nothing seems to be working.

Do you know why? There is something missing?

Can any one help me?

Thanks in advance,

Rui

Re: Question about Wireless Controller and LAG.

Have you tried using pagp instead of lacp?

Also, what if you used auto instead of on?

I do not run lag on my 4402 controllers, as it was not up to snuff early on (3.x per TAC) and I can achieve the same with mulitple ap-management interfaces and differing port priority.

I will be replacing the 4402 units with wism blades soon, so all that will change a bit

Community Member

Re: Question about Wireless Controller and LAG.

I tried to config PagP, but don't worked.

If I tried with auto I will being configuring in PagP, and I which to configure LACP.

If you will have a WiSM it as LAG enabled by default…

Can you help me?

Can some one help me?

Thanks,

Rui

Re: Question about Wireless Controller and LAG.

What 2960 model and what image is on it?

Also, how are you connecting the 4402 to the 2960, copper or fiber?

Community Member

Re: Question about Wireless Controller and LAG.

Connecting by cooper and the IOS is: c2960-lanbase-mz.122-35.SE5.bin.

Thanks,

Rui

Re: Question about Wireless Controller and LAG.

Copper? so you are using rj-45 Gb SFPs on the controller. If that is the case, what is the speed of the switchports on the 2960?

I use the rj-45 Gb SFPs on our 4402s and they work fine connected to Gb rj-45 ports on the switches.

Also, check out the following:

http://www.cisco.com/en/US/docs/wireless/controller/4.2/configuration/guide/c42mint.html#wp1116136

"Using the CLI to Verify Link Aggregation Settings

To verify your LAG settings, enter this command:

show lag summary

Information similar to the following appears:

LAG Enabled

Configuring Neighbor Devices to Support LAG

The controller's neighbor devices must also be properly configured to support LAG.

•Each neighbor port to which the controller is connected should be configured as follows:

interface GigabitEthernet

switchport

channel-group mode on

no shutdown

•The port channel on the neighbor switch should be configured as follows:

interface port-channel

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan

switchport trunk allowed vlan

switchport mode trunk

no shutdown

"

Hall of Fame Super Silver

Re: Question about Wireless Controller and LAG.

You have to set channel-group to 'on'. LAG will not work with lacp or pagp. When set to on, you aren't using any negotiation. Also the etherchannel load balancing has to be scr-dst-ip.

http://www.cisco.com/warp/public/102/wlc-config-best-practice.pdf

-Scott
*** Please rate helpful posts ***
Community Member

Re: Question about Wireless Controller and LAG.

I have a sw2960G.

The controller is connected with the switch by cooper in 2 interfaces in 1Gb.

The 2960 as 4 interfaces that could be connected by cooper or fibber, it depend what you need.

The configuration that I did put in the switch is:

!

port-channel load-balance src-dst-ip

!

interface Port-channel1

switchport trunk allowed vlan 8,9,99

switchport mode trunk

!

!

interface GigabitEthernet0/21

switchport trunk allowed vlan 8,9,99

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet0/22

switchport trunk allowed vlan 8,9,99

switchport mode trunk

channel-group 1 mode on

!

I did this a couple days ago.

But that don't worked the LAG is not negotiated between the switch and the Controller.

Reading all the documentation that Cisco as for LAG, Cisco says it work… but in reality it don't work.

Can you help me?

Can any one help me?

Thanks,

Rui Capao

Hall of Fame Super Silver

Re: Question about Wireless Controller and LAG.

Post the sow run-config from the WLC cli and also post the show etherchannel on the switch.

-Scott
*** Please rate helpful posts ***
Community Member

Re: Question about Wireless Controller and LAG.

OK!

Hall of Fame Super Silver

Re: Question about Wireless Controller and LAG.

I was looking for the show run-config not the show running-config.

But looking at the sw2960_1, it looks like you do have etherchannel running on both ports.

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SU) - Gi0/21(P) Gi0/22(P)

Po1(SU) means Port Channel 1 is in layer 2 and in use

Gi0/21 (P) & Gi0/22 (P) shows that both ports are in port channel.

-Scott
*** Please rate helpful posts ***
Community Member

Re: Question about Wireless Controller and LAG.

Yes saw that, but the problem is that LACP is not working, I mean, the load balancing is not working…

When a unplug one of the cables in the WLC. The connectivity between the switch and the WLC stops.

That is the problem…

There is something that I have to do?

There is something I forgot?

Can some one help me?

Thanks,

Rui

Hall of Fame Super Silver

Re: Question about Wireless Controller and LAG.

Well for one, when channel mode is set to on, it doesn't use either lacp or pagp. you can configure udld on the switch and see if that helps. Even when a wlc fails, its not a clean failover. the ap's will reboot and have to join the other wlc.

-Scott
*** Please rate helpful posts ***
Community Member

Re: Question about Wireless Controller and LAG.

udld...?

Can you specify?

I know that I can configure the switch as LACP or PagP, but I tried the tow of them and I did not succeed…

Thanks,

Rui

Hall of Fame Super Silver

Re: Question about Wireless Controller and LAG.

Here is a doc on UDLD

http://cio.cisco.com/univercd/cc/td/doc/product/lan/cat4000/12_18a/command/u1.htm

How are you testing this. Are you just unplugging one of the links?

The WLC does not understand lacp nor pagp. So channel mode has to be set to on. On a switch to switch, disconnecting one of the links fails over within msec. The WLC isn't a swtch and might need time to fully converge. I will test it out tommorrow and let you know if if it is distruptive or not. I think it also depends on how many ap's.

-Scott
*** Please rate helpful posts ***
Community Member

Re: Question about Wireless Controller and LAG.

I am not using fiber... I am using cooper.

I think udld is only for fiber...isn't right?

But I'm using an uplink port… can I use udld?

Thanks,

Rui

Community Member

Re: Question about Wireless Controller and LAG.

The contoller ports are trunks and must be connected to a layer 2 interface.

To change the ports on your layer 3 switch to layer 2 mode, use the switchport command in the interface config.

580
Views
0
Helpful
18
Replies
CreatePlease to create content