Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

RADIUS works with E2500 but not EA2700

I have 2 E2500 wireless routers that work fine with WPA2-Enterprise configured.  Our 3rd wireless router is an EA2700 and it does not work even though it is configured correctly for WPA2-Enterprise.  For our RADIUS server, we use the Network Policy Server feature in Windows Server 2012.

 

When I connect my laptop to either of the E2500's, it connects successfully in about 1 second.  When I try to connect it to the EA2700, it takes several seconds and says it fails.  The laptop is on the domain.  The same thing happens to a different laptop that I tested with.

 

In the Event Viewer, I get an event about the failure that says:

"Network Policy Server discarded the request for a user."

"Reason Code: 1"

"Reason: An internal error occurred. Check the system event log for additional information."

 

When I look at the actual log file (c:\windows\system32\logfiles\), the only thing that seems odd is that the successful connections to the E2500 include a few lines with Authentication Type 5 and then a few lines with Authentication Type 11.  But the failed connection attempts to the EA2700 only have the Authentication Type 5 lines and no 11 lines.  I wonder if the EA2700 router has a firmware bug that prevents it from using Authentication Type 11?  I tried using EA2700 firmware that is about a year old and it has the same symptoms as the latest firmware.

 

Here is the config in Network Policy Server:
RADIUS Clients:

Friendly name: Wifi1

Address: 10.20.1.2

Shared secret: (random stuff here, copied to the router's config page)

Vendor name: Cisco (I tried "RADIUS Standard" too)

  

Connection Request Policy:

Type of network access server: unspecified

Conditions: NAS Port Type = WirelessIEEE802.11 or Wireless-Other

Everything on the "Settings" tab is default

 

Network Policy:

Type of network access server: unspecified

Conditions: Windows Groups = Domain Users OR Domain Computers

Authentication Methods: PEAP and EAP-MSCHAPv2. Everything else unselected.

Everything on the "Settings" tab is default

 

240
Views
0
Helpful
0
Replies
CreatePlease to create content