Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

User Role empty - Cannot connect to DB2

Hello,

I'm having trouble with a WLSE 2.13 that we have installed. It doesn't let us access via web to the software; the error that appears when trying to do so is "User role is empty". There also appears a moving banner saying "Database failed to respond correctly" after trying to authenticate the user.

however, when trying t oaccess through SSH, it works OK.

This is what I get with a diag all command:

<<< Executing ALL Diagnostics (except SmartMonTools) >>>

DIAG: IMAGE -- [Mon Oct 9 08:27:07 UTC 2006]

(please wait) ... DONE.

*** PASS: Software image verification passed. ***

DIAG: BIOS -- [Mon Oct 9 08:28:03 UTC 2006]

*** Drive model ST340014A, FwRev does not require BIOS patch. ***

DIAG: DMA -- [Mon Oct 9 08:28:03 UTC 2006]

Checking disk for DMA errors (please wait) ...

*** PASS: NO DMA IO errors found. ***

Checking disk sectors for errors (please wait) ...

*** PASS: NO disk sector errors found. ***

DIAG: DB2CLEAN -- [Mon Oct 9 08:32:48 UTC 2006]

*** PASS: No dump files found. ***

DIAG: DB2VERIFY -- [Mon Oct 9 08:32:48 UTC 2006]

*** FAIL: Cannot connect to DB2. Integrity verification failed. ***

DIAG: SERIALNO -- [Mon Oct 9 08:32:49 UTC 2006]

*** No Serial Number obtained for this appliance. ***

So it looks like the DB is corrupt for some reason. We have executed the initdb but no change in the error has been detected.

This is the result of the show version command:

(C) Copyright 2006 by Cisco Systems Inc.

WLSE 1130 Release 2.13.1FCS Mon Aug 14 12:16:20 UTC 2006

(build number 54)

Device Limit = 2550

Build Version (79) Fri Jan 6 23:20:15 UTC 2006

Uptime: 0 days 0 hours 34 mins

Linux version 2.4.32-8_WLSEsmp (root@app20.cisco.com) (gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-113

)) #1 SMP Wed Jan 25 13:16:55 PST 2006

I do think that there may be a sector in the hard drive that is not working (you can see why in the bootlog.txt file that I'm also attaching), but it looks a bit strange that it has only affected the access through the web...

Any ideas?

2 REPLIES
Community Member

Re: User Role empty - Cannot connect to DB2

Hello,

Just in case anybody is interested, the issue was related to a faulty sector in the HDD. I asked for am RMA of the equipment and just got it two days ago.

Best regards,

Fernando

Cisco Employee

Re: User Role empty - Cannot connect to DB2

Hi Fernando,

This might be related to few things:

- file anisnmp.conf corrupted preventing TomCat to start properly (# reset device-snmp would fix it)

- database corrupted and not accessible at all

(... reiniting the db might be the only solution)

- user roles corrupted

(would need to delete the user roles to reconstruct them)

Opening a shell and hit "#show tomcatlog" would give you a more accurate idea.

In case of broken anisnmp.conf, the error message is pretty explicit.

In case of other problems, that would need more investigation by TAC.

Before doing anything, remind to perform backups!

Pierre

210
Views
0
Helpful
2
Replies
CreatePlease to create content