Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VPN not working over Wireless NIC

I have a Sony Vaio with a built in Wireless NIC which is referred to in the device manager as Lan-Express (I believe it is an Ornioco product). When I use this to connect to my home AP (SMC 7004AWBR wireless router w/3 hardwire ports) it connects to the internet and my other systems w/o problem, yet when I use my Cisco VPN client to establish a connection to my company's firewall (Pix506) it sees the firewall and seems to create the VPN, yet when I try to ping any of my servers behind the firewall they time out.

The bizarre thing is that if I use the built in hardwire NIC in my Sony I can VPN into work fine, if I use a SMC wireless PCMIA NIC card (2632W) it works, it’s only when I use Sony's internal wireless NIC.

SMC says its not their problem since the SMC card works. Cisco says it isn't their problem since the VPN client works when I hardwire the Sony and they have seen some wireless NICs establish a VPN circuit but not pass traffic, and Sony says they don't provide Network support since their Wireless NIC does establish a connection to the AP. They can't/won't even provide me the documentation on the configuration parameters on their built in wireless modem. I've escalated it to Tier 3 support and management and they just say Sorry!

I'm lost on where to go next. I suspect it is a hardware/driver issue although maybe it is a configuration parameter setting that is impacting the VPN traffic connection.

The Wireless enviroment is set up as infrastructure w/o WEP and works well.

Here are the device driver configuration settings/options on the Sony Wireless NIC:

Adhoc Demo: Disable/Enable

Authentication algorithm : Auto based on WEP/Must use shared with WEP/WECA compliant

Firmware Download: Disable/Enable

Fragmentation Threshold: 256-2432

Listen Interval: 0-77...

Power: Disable, Auto Enable, Always Enable

Preamble: Auto Tx Preamble, Long Tx Preamble, Short Tx Preamble

RTS Threshold: 0-2432

Any ideas would be deeply appreciated.

1 REPLY
Cisco Employee

Re: VPN not working over Wireless NIC

Hi ,

a) Try different Ap and see if it works ( just to rule out Ap issue )

( only if possible )

b) Make sure there is no personal firewall blocking any ipsec traffic

c) Go to interface properties , go to TCP/IP properties , click on advance .

there is interface metric . if you have multiple cards you can give priority

to particular interface via this metric . Make sure when you are using sony

wireless you give higher priority to it .

When you are using sony DISABLE all other interfaces .

d) You can more troubleshooting on PIX by running debug command .

IPSEC VPN has 3 phase , ISAKMP and IPSEC . we need to see what state

it is getting block so we can troubleshoot further .

e) Make sure you are running latest firmware on all AP , client andVPN software .

f) have you tried removing WEP and see ifit makes difference ?

Have you tried removing VPN software and reinstalling it ?

g) To me it sounds Sony wirless NIC is blocking the ipsec packets .

Normally I have seen MTU issue with VPN but in this we are not seeing tunnel coming up ....so it is different problem ...

Make sure layer 3 is UP .

can you ping vpn gateway with ip and name of the vpn gateway ( to rule out dns issue ? )

Can you browse the net with sony wireless NIC ? Have you seen any other issue with sony internal NIC ?

Nilesh

310
Views
0
Helpful
1
Replies
CreatePlease login to create content