Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

WCS 6.0.132.0 Database

Hello,

I've been having some problems with the linux version of WCS. Sometimes, and I still don't know why the Database server stops. To activate it again I need to restart the service using the WCSStart script. Is anyone having similar problems? The service can work for two weeks or a month... then it just stops.

Best regards

20 REPLIES

Re: WCS 6.0.132.0 Database

It may have something to do with the underlying OS that you are running WCS on.

Are you running linux or windows?

Community Member

Re: WCS 6.0.132.0 Database

hi,

I am having the same problem. WCS 6.0.132.0 on RedHat 5.x 32 bit and a fast machine. everything works fine for quite some time, until the DB stops.

This happens in the middle of the night; right when some background tasks are scheduled. i splitted them up now some minutes to see which one causes this. Maybe this will bring some light into that matter.

But nice to see that I am not the only one with that problem...

Re: WCS 6.0.132.0 Database

A few questions:

Is selinux enabled?

Anything in /var/log/messages?

The fact that it happens in the middle of the night makes me suspect a cronjob that is kicking off which may cause a conflict.

check the following dirs & files:

/etc/cron.daily

/etc/cron.weekly

/etc/cron.monthly

/etc/crontab

under root login: crontab -l

If I were to venture a guess, it dies @ 4am

Community Member

Re: WCS 6.0.132.0 Database

I'm using RedHat Linux. The server stops randomly. Never realized it was during the night. I just found out because I stoped getting the email alerts.

Issuing the command "crontab -l" results in "no crontab for root".

I have Selinux enable and it's actually blocking write access to a file:

/opt/WCS6.0.132.0/webnms/ifconfig.txt

I checked this file and it's an empty file.

No other problem found so far.

Re: WCS 6.0.132.0 Database

Perhaps it is empty because selinux does not allow it to be written to.

You want want to alter your selinux policies or disable it and use other means for securing your server

Community Member

Re: WCS 6.0.132.0 Database

I don't have the expertise to do this. I wouldn't disable SeLinux but I would add a policy to allow the writing... I don't even know if the file needs to be written, since everithing works just fine for several days, even with lots of data arriving to the WCS...

Best regards,

Re: WCS 6.0.132.0 Database

I dont recommend you messing with this at this point

Re: WCS 6.0.132.0 Database

Tiago, let's run a database check to fix any corrupted tables in your WCS database.

That should help you.

Here is how:

1./opt/WCSX.X/bin/StopWCS

2. ./opt/WCSx.x/bin/DBAdmin checkschema

3. /opt/WCSX.X/bin/StartWCS

Community Member

Re: WCS 6.0.132.0 Database

Ok, I did like you posted. Aparently everithing went well:

"[root@XXXXX ~]# /opt/WCS6.0.132.0/bin/StopWCS

Stopping WCS

Stopping Health Monitor...

Waiting for shutdown to complete.

/opt/WCS6.0.132.0/bin/Health Monitor successfully shutdown.

WCS is stopped.

The database server is stopped.

Apache server is stopped.

WCS successfully shutdown.

[root@XXXXX ~]# /opt/WCS6.0.132.0/bin/DBAdmin checkschema

This may modify your database. Do you wish to continue? (y/n) y

Starting database server ...

Database server is running.

Updating schema. This may take a while.

Loading schema. This may take a minute.

Schema is loaded.

Shutting down database server ...

Database server successfully shutdown.

[root@XXXXX ~]# /opt/WCS6.0.132.0/bin/StartWCS

Starting WCS

WCS started successfully."

I'll have to wait to see if this solved the issues...

Thanks

Re: WCS 6.0.132.0 Database

Great.

I think that should resolve your issue.

Community Member

Re: WCS 6.0.132.0 Database

i have selinux disabled, nothing in /var/log/messages, no cronjob at the time it dies, only the wcs background tasks.

i tried now the dbadmin command - maybe this will help, we'll know in some weeks :)

Community Member

Re: WCS 6.0.132.0 Database

Well it's been a week since I issued the DBadmin command, and so far, it hasn't stoped. I'll wait another week to be sure it solved the problem.

Thank you.

Community Member

Re: WCS 6.0.132.0 Database

Hello,

my database stoped working again... It happened last night.

I got this output from the WCSStatus script.

"Health Monitor is running.

WCS is initialized, but is not serving web pages.

*********************************

The Server seems to be unavailable. The possible reasons are

1. The server is not running yet.

2. The server is hanging.

3 The server has crashed.

If the server has crashed or is hanging

Please report the issue and follow the instructions to restart it.

1. Run StopWCS to stop all WCS processes.

2. Run StartWCS to start the WCS server.

3. If the server still fails to start, or you still get this

message, then reboot the machine.

*********************************

Database server is stopped

Apache server is running"

So I think the DBAdmin didn't solve the problem. Any next steps?

Thanks for your help.

Tiago

Re: WCS 6.0.132.0 Database

Pull the logs from WCS. set the WCS logging to the highest level and try to see if something triggers within WCS.

Question to Cisco: are there any debug flags that can be set on the CLI and/or called from the init script?

I still think this is an underlying config issue with the OS. the solid db may not like it if another backup job tries to backup open files.

979
Views
8
Helpful
20
Replies
CreatePlease to create content