Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

WCS no longer recognises the location server

WCS no longer recognises the location server. The location appliance was upgraded from version 2.1.39.0 to 3.0.42.0 (for csharp API support).The compatibility matrix shows that the WCS and Location appliance versions are compatible.

But after the upgrade, I am unable to add the location appliance in WCS despite providing the correct IP and default username and password.

The earlier location server was first deleted and then when I try to add the same location server the

error message "Unable to connect to the location appliance. Either the location appliance is unreachable or the login credentials are incorrect" is displayed. However, it is still possible to connect to location appliance using the Csharp API.

Details:

WCS version : 3.2.51.0

Loc Server ver: 3.0.42.0

User Name: admin

Password: admin

Port#: 8001

Any help please.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Silver

Re: WCS no longer recognises the location server

On first reading your question, I wondered why are you running such an old version of WCS software when you are currently using the latest Location Appliance software?

If you have a service contract with Cisco and opened a case with TAC they would no doubt instruct you to upgrade to 4.1.91

I saw the compatibility matrix and you are correct that they are supposed to work together. Though from my experience it's usually better to upgrade and fix the bugs you haven't encountered yet, than it is to troubleshoot a problem that may well be fixed by an upgrade. What's more, if you do upgrade you will at least be able to rule this out as an issue and you will be able to take advantage of the added features that were added to 4.x software. Please take a look at the release notes for details.

Hope this helps.

Please post a response if it does or if it doesn't.

Silver

Re: WCS no longer recognises the location server

We have had problems with the WLA no longer being seen by the WCS. We have found that removing it from the WCS and re-adding it usually does the trick.

As I recall, we ran into some password issues as well. You may want to check and/or change the username/password on the WLA and then delete and re-add the WLA to the WCS using the new username/password and see if that works any better. If that does not work, I seem to recall that we may have had to resort to the default username/password.... I'm sorry, but it has been a while and I am no longer at that particular customer site.

In terms of upgrading, I agree with the earlier post that you may be better off with the current 4.1.185 and 4.1.91 releases as well as the latest/greatest version of the WLA.

Version 4.2 "D-Cubed" is *supposed* to fix a large number of issues and you may find it worth the effort.

- John

2 REPLIES
Silver

Re: WCS no longer recognises the location server

On first reading your question, I wondered why are you running such an old version of WCS software when you are currently using the latest Location Appliance software?

If you have a service contract with Cisco and opened a case with TAC they would no doubt instruct you to upgrade to 4.1.91

I saw the compatibility matrix and you are correct that they are supposed to work together. Though from my experience it's usually better to upgrade and fix the bugs you haven't encountered yet, than it is to troubleshoot a problem that may well be fixed by an upgrade. What's more, if you do upgrade you will at least be able to rule this out as an issue and you will be able to take advantage of the added features that were added to 4.x software. Please take a look at the release notes for details.

Hope this helps.

Please post a response if it does or if it doesn't.

Silver

Re: WCS no longer recognises the location server

We have had problems with the WLA no longer being seen by the WCS. We have found that removing it from the WCS and re-adding it usually does the trick.

As I recall, we ran into some password issues as well. You may want to check and/or change the username/password on the WLA and then delete and re-add the WLA to the WCS using the new username/password and see if that works any better. If that does not work, I seem to recall that we may have had to resort to the default username/password.... I'm sorry, but it has been a while and I am no longer at that particular customer site.

In terms of upgrading, I agree with the earlier post that you may be better off with the current 4.1.185 and 4.1.91 releases as well as the latest/greatest version of the WLA.

Version 4.2 "D-Cubed" is *supposed* to fix a large number of issues and you may find it worth the effort.

- John

157
Views
0
Helpful
2
Replies
CreatePlease to create content