Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Web authentication Issue with redirection

Hi All

I am having some issues with guest web redirection.  when Typing in a URL i am not recieving a web redirect page.  I can type the virtual IP of the WLC and i get the redirection page. 

The odd thing is if i authenticate on the virtual IP address successfully i can type the same URL and get to the bage with no issues.  I know DNS can be a common issue with redirection so this was one of the first issues i looked in to.  As mentioned it is not connecting to the URL before authentication but will go the the page after authentication to the Virtual IP.

I hope some one can help,

Thanks,

John

17 REPLIES
Hall of Fame Super Silver

Re: Web authentication Issue with redirection

That is a test for DNA issues. You also have to make sure your initial page is http not s a secure page https.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
Hall of Fame Super Silver

Re: Web authentication Issue with redirection

Here is a link that also can help.

http://www.cisco.com/en/US/products/ps10315/products_tech_note09186a0080a38c11.shtml

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***

Re: Web authentication Issue with redirection

PFA for a Tshoot doc, it may help you

New Member

Re: Web authentication Issue with redirection

Hi All -

I thought i would update on the issue.  It seems to be a bug in the version i am using for the 2504 controller.  I have been using the 7.5.102 firmware and i downgraded this to 7.0 firmware and this worked without any other further changes. thanks for the help on the above as ther was an issue with DNS also.

if anyone is able to get this working on this code i would be happy to take advise.

thanks,

John

Cisco Employee

Re: Web authentication Issue with redirection

Hi John,

One question.  Are you utilizing Flexconnect local switching in your wireless environment?  If so there are the following concerns:

CSCui25551

CSCug98625

Cheers,
Erwin

______________________________________

How helpful was I? Don't forget to rate me when you have the chance!

Cheers, Erwin ______________________________________ How helpful was I? Don't forget to rate me when you have the chance!
Hall of Fame Super Silver

Re: Web authentication Issue with redirection

Well when you say it's a bug, did you open a TAC case and they gave you the bug id? I'm running v7.5 and can test it later today.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: Web authentication Issue with redirection

Hi Erwin -

Flex connect is not being used as this is a lab enviroment for cisco training which we have a lab guide to follow too. I thought i would post as the best people to really ask are the people that use it every day.

Thanks for the reply.

John

New Member

Re: Web authentication Issue with redirection

Hi Scott -

If you have any luck with the configuration i would love to hear from you.  I havent raised it yet due to wanting to te all the support infomation and as its a lab enviroment not completely critical.  Just to confirm i did get one of our CCSIs to have a look and the result was the same. I also didnt see any infomation in the release notes about changes to setup web authentcation in 7.5 so please let me know if you have any joy.

Thanks

John

Hall of Fame Super Silver

Web authentication Issue with redirection

Well just tested it on a 2504 running v7.5.102.0 and had no issues getting the webauth page and then redirecting to a URL I specified on the webauth configuration page.

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
New Member

Web authentication Issue with redirection

Hi Scott -

Thanks for the update.  I tried on 2 diffrerent controllers and got the same problem.  when reverting the backup code 7.0 it works no problem?.  i ruled out our internal DNS by using public DNS (8.8.8.8) any ideas on why it would work on one code but not the other?

Thanks,

john

Hall of Fame Super Silver

Re: Web authentication Issue with redirection

If your using v7.2 or later, make sure you also upload the new FUS image. This takes 35-40 minutes to finish and should be monitored via the console.

Make sure you don't have a DNS name in the VIP interface also unless you have a 3rd party cert installed.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: Web authentication Issue with redirection

Hi scott -

We are not using the DNS name on the virtual adapter however we have only put the 7.5.102.0 firmware on.

I will attempt to install the FUS image and will let you know if this is the possible cause as it sounds positive.

Thanks,

john

New Member

Re: Web authentication Issue with redirection

Hi Scott -

The FUS image has been updated to 7.4.1.30 Primary image is 7.5.102.0.  No DNS name in the VI, web auth tab set to (internal default) and redirect URL to page http://www.google.com

Redirect still works if i type the VI http://1.1.1.1 but not http://www.google.com If i authenticate on http://1.1.1.1 i get redirected to google.com and i can surf the internet as normal.

Changing the primary image back to 7.0 enable me to get the redirect page when typing http://www.google.com.

I hope you can shed some light :-)

Thanks again.

john

Hall of Fame Super Silver

Re: Web authentication Issue with redirection

You might have something corrupted with the configuration. What I would try is to upgrade to v7.4.110.0 which is MR1. See if that works and then upgrade to v7.5.102.0 and let me know.

If the configuration is corrupt somehow, I usually would factory reset and build it from scratch. Again, I have no issues with this at all.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
Hall of Fame Super Silver

Re: Web authentication Issue with redirection

Try to choose custom page and hit apply then internal and hit apply again.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: Web authentication Issue with redirection

Hi Scott -

Thanks - i havent tried that i will attempt now and update.

Thanks,

John

Re: Web authentication Issue with redirection

You might test that you are able to resolve DNS. There was a behavior change between 7.0 and 7.5 where in 7.0 DNS traffic is always allowed even if it is not allowed in the pre auth ACL, where that is not the case in later code. If you can't resolve DNS, you won't generate a http request to trigger the redirect.

You can also test to see if you can hit a website via IP and see if that triggers the redirect.

Sent from Cisco Technical Support iPhone App

812
Views
0
Helpful
17
Replies
CreatePlease to create content