Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Wireless AP native vlan and switch trunk

Hi,

I am unable to ping my ap, i think it is due to the multiple vlan issues, can provide some advise, my config for the ap and switch is as below

AP Config

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname hostname

!

!

logging rate-limit console 9

enable secret 5 $1$ZxN/$eYOf/ngj7vVixlj.wjG2G0

!

no aaa new-model

ip cef

!

!

!

dot11 syslog

!

dot11 ssid Personal

   vlan 2

   authentication open

   authentication key-management wpa version 2

   guest-mode

   wpa-psk ascii 7 070E26451F5A17113741595D

!

!

crypto pki token default removal timeout 0

!

!

username Cisco password 7 1531021F0725

!

!

bridge irb

!

!

!

interface Dot11Radio0

no ip address

!

encryption vlan 2 mode ciphers aes-ccm tkip

!

!

ssid Personal

!

antenna gain 0

stbc

beamform ofdm

station-role root

no dot11 extension aironet

!

interface Dot11Radio0.2

encapsulation dot1Q 2

bridge-group 2

bridge-group 2 subscriber-loop-control

bridge-group 2 spanning-disabled

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

!

interface Dot11Radio0.100

encapsulation dot1Q 100 native

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio1

no ip address

!

encryption vlan 2 mode ciphers aes-ccm tkip

!

!

ssid Personal

!

antenna gain 0

no dfs band block

stbc

beamform ofdm

channel dfs

station-role root

!

interface Dot11Radio1.2

encapsulation dot1Q 2

bridge-group 2

bridge-group 2 subscriber-loop-control

bridge-group 2 spanning-disabled

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

!

interface Dot11Radio1.100

encapsulation dot1Q 100 native

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface GigabitEthernet0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0.2

encapsulation dot1Q 2

bridge-group 2

bridge-group 2 spanning-disabled

no bridge-group 2 source-learning

!

interface GigabitEthernet0.100

encapsulation dot1Q 100 native

bridge-group 1

bridge-group 1 spanning-disabled

no bridge-group 1 source-learning

!

interface BVI1

ip address 192.168.1.100 255.255.255.0

!

ip default-gateway 192.168.1.1

ip forward-protocol nd

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

password 7 01181101521F

login

transport input all

!

end

Switch Port config

interface FastEthernet1/0/10

switchport trunk native vlan 100

switchport mode trunk

7 REPLIES
Hall of Fame Super Silver

Re: Wireless AP native vlan and switch trunk

That looks fine. Is vlan 100 being passed all the way to the core? If you connect a laptop to the same switch but on vlan 100, can you ping the AP.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: Wireless AP native vlan and switch trunk

Thanks for the reply, if I am on vlan 100 i can ping the AP but if I am on another vlan i am unable to do so, the vlan routing is fine, not sure why, any clue ?

Hall of Fame Super Silver

Re: Wireless AP native vlan and switch trunk

If your on vlan 100 it works but if your not on vlan 100 it doesn't? Then routing is not working. From the AP or the laptop on vlan 100, you can ping vlan 100 gateway correct but nothing else. If so, check your routing.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: Wireless AP native vlan and switch trunk

I will re-check the routing again but could it be some bridging issues ?

interface GigabitEthernet0

no ip address

duplex auto

speed auto

**** unable to put up this command on the giga port

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

I try to put this command on the gigaethernet port but it does not allow me, could this be the bridging  issue ?

Hall of Fame Super Silver

Re: Wireless AP native vlan and switch trunk

The BVI interface is what needs an IP address. If a laptop in an access port vlan 100 on the same switch can't ping the gateway or other gateways, then you have a routing issue or vlan 100 is not being passed to the core.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: Wireless AP native vlan and switch trunk

how can i check if vlan 100 is pass to the core or not ? I think i did a test before by puting a laptop on vlan 100 and another laptop on another vlan 200, the laptop on vlan 200 is able to ping the laptop on vlan 100 but not the access point (need to re-confirm)

thanks for the help

Hall of Fame Super Silver

Re: Wireless AP native vlan and switch trunk

Need to makes sure vlan 100 is defined on all the switches that lead back to the core. If you can ping the AP from a laptop on vlan 100 on the same switch then nothing is wrong with the AP since that is layer 2. Layer 3 seems to be broke.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
300
Views
0
Helpful
7
Replies
CreatePlease login to create content