Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

WLC and NGS WebAuth Certificates

We have a WISM in our Cat6509 switch. We created a CSR and then downloaded the device certificate and intermediate certificate and root certificates from GoDaddy. Then following the Cisco documentation we chained the certificates together and then used TFTP to "download" them to the controllers. That worked great, but for some reascon we are still getting prompted on the client about the certificates.

2 REPLIES

Re: WLC and NGS WebAuth Certificates

My first guess would be 1 of 2 things, #1 - The certificates weren't compiled together correctly; since you have to go thru a funky sequence to create the certificate package that is uploaded to the controller. #2 - The root certificate you used is not present in either the machine or user store of the machines.

Community Member

Re: WLC and NGS WebAuth Certificates

Thank you very much for you suggestions. We were thinking along the same lines. To give an update it looks like it was related to how the redirection was working. The engineer I am working with stayed late and figured some things out which I am not positive on, but we are now having sporatic issues. With an iPhone we are not prompted at all about certificates and it is working great. If I use a laptop then I am redirected to the WLC (no cert popup) and then redirected to the NGS which does prompt me about the cert. We purchased two certificates from GoDaddy so this is a bit confusing. Looks like we are making progress but still not quite completely working. I will update this thread with any new info.

716
Views
0
Helpful
2
Replies
CreatePlease to create content