Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

WLC is not responding to SNMP requests.

Customer is using a 4400 WLC.

He has a management tool that works using the SNMP logs from the controller, he can ping the
controller using this management tool, but when he sends SNMP requests from the management tool the
WLC doesn't reply.

The SNMP server IP address is 192.168.122.11 and the WLC's IP address is  10.20.1.31.

I have the following debug taken from the switchport where the WLC is connected.
'debug snmp agent' shows some interesting messages that confirms that the WLC is not sending a packet back.

Cisco Controller) >debug  snmp agent enable

(Cisco Controller) >*SNMPTask: Feb 06 14:38:44.616: SNMPD: Packet from: 192.168.122.11:2509, in_packet_len = 59

*SNMPTask: Feb 06 14:38:44.616: SNMPD: Failed to build in SnmpMessage.

1145 Debug Messages have been dropped*SNMPTask: Feb 06 14:38:44.616: SNMPD: *NOT* sending out packet, out_packet_len = 0

*SNMPTask: Feb 06 14:38:47.621: SNMPD: Packet from: 192.168.122.11:2509, in_packet_len = 59

*SNMPTask: Feb 06 14:38:47.621: SNMPD: Failed to build in SnmpMessage.

*SNMPTask: Feb 06 14:38:47.621: SNMPD: *NOT* sending out packet, out_packet_len = 0

*SNMPTask: Feb 06 14:38:50.652: SNMPD: Packet from: 192.168.122.11:2509, in_packet_len = 59

*SNMPTask: Feb 06 14:38:50.652: SNMPD: Failed to build in SnmpMessage.

*SNMPTask: Feb 06 14:38:50.652: SNMPD: *NOT* sending out packet, out_packet_len = 0

*SNMPTask: Feb 06 14:38:53.684: SNMPD: Packet from: 192.168.122.11:2509, in_packet_len = 50

*SNMPTask: Feb 06 14:38:53.684: SNMPD: Failed to build in SnmpMessage.

*SNMPTask: Feb 06 14:38:53.684: SNMPD: *NOT* sending out packet, out_packet_len = 0

*SNMPTask: Feb 06 14:38:56.715: SNMPD: Packet from: 192.168.122.11:2509, in_packet_len = 50

*SNMPTask: Feb 06 14:38:56.715: SNMPD: Failed to build in SnmpMessage.

*SNMPTask: Feb 06 14:38:56.715: SNMPD: *NOT* sending out packet, out_packet_len = 0

*SNMPTask: Feb 06 14:38:59.747: SNMPD: Packet from: 192.168.122.11:2509, in_packet_len = 50

*SNMPTask: Feb 06 14:38:59.747: SNMPD: Failed to build in SnmpMessage.

*SNMPTask: Feb 06 14:38:59.747: SNMPD: *NOT* sending out packet, out_packet_len = 0


I have also a packet capture taken from the same switchport, I attach it here.

What could be the reason for not responding?



1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

WLC is not responding to SNMP requests.

You need to add the management tool in the WLC as a trap reciever.

2-18-2014 9-43-06 AM.jpg

Thanks,

Scott

*****Help out other by using the rating system and marking answered questions as "Answered"*****

-Scott
*** Please rate helpful posts ***
6 REPLIES
Hall of Fame Super Silver

WLC is not responding to SNMP requests.

You need to add the management tool in the WLC as a trap reciever.

2-18-2014 9-43-06 AM.jpg

Thanks,

Scott

*****Help out other by using the rating system and marking answered questions as "Answered"*****

-Scott
*** Please rate helpful posts ***
Community Member

WLC is not responding to SNMP requests.

Hi Scott,

Thank you for the steps, I will implement it and then let you know if it solved the issue.

Have a nice day!

Hall of Fame Super Silver

WLC is not responding to SNMP requests.

No problem...

Thanks,

Scott

*****Help out other by using the rating system and marking answered questions as "Answered"*****

-Scott
*** Please rate helpful posts ***
Community Member

Hi Scott,It worked, but we

Hi Scott,

It worked, but we needed to use SNMP v2 to make it!

Thank you so much.

Community Member

I disagree that this is a

I disagree that this is a solution. It is a workaround to a bug or issue, but I have another WLC of the same model that can use SNMPv3 to connect to Prime Infrastructure and one that is having exactly this same issue.

Hall of Fame Super Silver

Re: WLC is not responding to SNMP requests.

Robin,

Just to note.... This is the same setting when your adding WCS/NCS or Prime to WLC. Without this being set, snmp will not work. Take a look at other installs that use WCS/NCS or Prime.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
2601
Views
5
Helpful
6
Replies
CreatePlease to create content