Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

WLSE doesn't show AP serial numbers

Dears,

My WLSE (1130 Release 2.11FCS) doesn't show APs' serial numbers in the reports. My APs are 1220 (upgraded from VxWorks) and 1231, IOS 12.2(15)JA and 12.3(7)JA. WDS is not configured. Other reports are OK. What's the problem?

Thank you in advance,

Roman.

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: WLSE doesn't show AP serial numbers

The OID that will at some point contain the Top Assembly Serial Number:

ceAssetSerialNumber

1.3.6.1.4.1.9.9.92.1.1.1.2 from the

CISCO-ENTITY-ASSET-MIB

unfortunately it is only included in these 2 images currently:

c1200-k9w7-tar.12.3-2.JA

c1200-k9w7-tar.12.3-2.JA2

Here is a list of issues at the moment with returning the serial number with APs:

1) MIB OID 1.3.6.1.4.1.9.3.6.3 (chassisID of OLD-CISCO-CHASSIS-MIB) always returns PCB serial number. Customer expect this MIB variable to return "Top assembly Number". They have to literally configure "snmp-server chassis id" to make the OID 1.3.6.1.4.1.9.3.6.3 returning the "top assembly number".

2) In case of Vxworks to IOS converted APs, top assembly number is blank and the PCB serial number displayed in show version is the serial number listed in the sticker of the chassis. So when they query with the OID 1.3.6.1.4.1.9.3.6.3 , they correctly get the serial number but not consistent with non converted IOS APs.

3) It has been adviced to use ceAssetSerialNumber(1.3.6.1.4.1.9.9.92.1.1.1.2) which always returns the top assembly number, but customer report this OID returns NULL. This may be the issue with the running image version. Need to

check on that.

4 REPLIES
Bronze

Re: WLSE doesn't show AP serial numbers

The WLSE uses entPhysicalSerialNum to pull the serial number if it exists. Unfortunately the serial number is not burned into the device on many of cisco's products. The 1200 upgrade from VXworks also have a problem because the prom was not designed to handle the serial number.

New Member

Re: WLSE doesn't show AP serial numbers

Yes, entPhysicalSerialNum doesn't contain :

entPhysicalSerialNum.1=

entPhysicalSerialNum.2=

entPhysicalSerialNum.3 is empty

Do someone know SNMP OID which contains Top Assembly Serial Number of access point?

New Member

Re: WLSE doesn't show AP serial numbers

Oops, APs which are upgraded from VxWorks to IOS:

entPhysicalSerialNum.1==

But for APs which are supplied with IOS it isn't so...

Bronze

Re: WLSE doesn't show AP serial numbers

The OID that will at some point contain the Top Assembly Serial Number:

ceAssetSerialNumber

1.3.6.1.4.1.9.9.92.1.1.1.2 from the

CISCO-ENTITY-ASSET-MIB

unfortunately it is only included in these 2 images currently:

c1200-k9w7-tar.12.3-2.JA

c1200-k9w7-tar.12.3-2.JA2

Here is a list of issues at the moment with returning the serial number with APs:

1) MIB OID 1.3.6.1.4.1.9.3.6.3 (chassisID of OLD-CISCO-CHASSIS-MIB) always returns PCB serial number. Customer expect this MIB variable to return "Top assembly Number". They have to literally configure "snmp-server chassis id" to make the OID 1.3.6.1.4.1.9.3.6.3 returning the "top assembly number".

2) In case of Vxworks to IOS converted APs, top assembly number is blank and the PCB serial number displayed in show version is the serial number listed in the sticker of the chassis. So when they query with the OID 1.3.6.1.4.1.9.3.6.3 , they correctly get the serial number but not consistent with non converted IOS APs.

3) It has been adviced to use ceAssetSerialNumber(1.3.6.1.4.1.9.9.92.1.1.1.2) which always returns the top assembly number, but customer report this OID returns NULL. This may be the issue with the running image version. Need to

check on that.

429
Views
0
Helpful
4
Replies
CreatePlease to create content