Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

CSC Module updates failing - The error code is 62

As of February 15th, 2014, Trend Micro changed the signing certificate used to digitally sign the pattern updates used by the Trend Micro Content Security and Control Module (CSC-SSM). This causes the CSC module to fail to 'verify' the downloaded patterns and results in updates failing. Administrator would be presented with an email notification along the line of:

 

AntiVirusPattern : Pattern Update: The download file was unsuccessful for ActiveUpdate was unable to verify security information. The local trusted info database is corrupted. Please contact Trend Micro technical support.. The error code is 62.

 

This issue is addressed by CSC Module patch 1145 (or later) for version 6.6.1125.0 of the CSC Module code.

 

You can obtain Patch 1146 from Trend Micro's Safe Sync server at the following URL:

https://dc1.safesync.com/LMcmmxjs/csc_66_en_hfb1146.zip?a=LkkaMTwupGE

The zip file contains two files, the MD5 sums of the files are listed here for reference:

 

MD5 (Readme.txt) = 5c6127c0abffa4634fc2908b775eec30

MD5 (csc_66_en_hfb1146.pkg) = bfc98940f19eb7e6d2177615d553fb74

The above patches have been superseded by patch versions x.1169. More information here: https://supportforums.cisco.com/document/13102616/csc-module-updates-failing-after-late-july-2016-error-code-28

The included readme.txt file contains the release notes for this Hotfix.

 

Application of the Hotfix patch is done through the CSC Module GUI in the 'Product Upgrade' section of 'Administration':

 

Screen Shot 2014-02-17 at 2.07.06 PM.png

If you continue to have pattern update failures, please contact Cisco TAC.

Version history
Revision #:
1 of 1
Last update:
‎02-17-2014 11:10 AM
Updated by:
 
Labels (1)
Everyone's tags (3)
Comments
New Member

works excellent

New Member

please hotfix for ver. 6.3.1172.0

New Member

Hello Joseph,

The hotfix is currently available for 6.6.1125.0 only. It will be required to upgrade to 6.6.1125.0 first before applying the hotfix.

New Member

just received the hotfix... - it indicates a reboot is required - is that our entire firewall that gets the reboot - or just the CSC module itself that is rebooted?

Cisco Employee

Only the CSC reloads. If you have a failover pair, it will cause a failover.

New Member

Are there any updates on this issue?

New Member

I am having a problem with it.  I already have a case open, and I will follow up there.  Right now my CSC SSM is allowing all internet traffic and will not bring up the GUI and the ASDM is down as well.

New Member

Hello to all,

I have 1140 installed.

When trying to upload 1144, I get an HTTP Staus 500 page with the following (amongst other):

type Exception report

description The server encountered an internal error () that prevented it from fulfilling this request.

root cause java.io.IOException: No space left on device

Is there a workaround available please?

New Member

Hi,

Did you disabled Scheduled Update?

There is a tip in readme.

Note: Disable Scheduled Update before installing this hot fix, if

         hot fix 1144 is installed.

Or maybe you will have to backup your config, then reimage the module with a fresh 6.6.1125.0.bin, restore config, next install fix 1144.

Hope this will solve your issue.

Cisco Employee

Error Code 500 on the Product Upgrade page is usually due to there being nearly 0 free space available. In this case, you may need to open an SR.

New Member

Hi, thank you both for your replies.

Yes arekhapon, I did disabled Scheduled Updates before anything else.

Cisco Employee

Steps summarized:

1. Upgrade the CSC module to version 6.3.1172.4 /If you have version 6.3.1172.0, 6.3.1172.1,  6.3.1172.2, 6.3.1172.3.

2. Upgrade the CSC module to version 6.6.1125.0 (takes like 10 minutes, the browser session might expire, just refresh)

3. Disable the Scheduled updates

3. Apply the hotfix 1144

5. Enable scheduled updates

6. Go to Administration>Licensing and check for license online.

7. Create a Manual update. It should be successfull

In every upgrade module the CSC may need to reboot.

New Member

Thanks for the steps, works fine!, updated from 6.3.1172.0

New Member

Hi there ... I followed steps and installed patdh 1140 and then 1144 ... now, I was able to update everything through a manual update (I was getting error 62 after 1140 patch installed)

Even though, when I tried an scheduled one, got a different error now, referring to Anti-Spam pattern (before , error was related to anti-virus pattern)

Anti-spam pattern 20532 was successfully downloaded and installed.

Unable to copy file . You must manually copy file /opt/trend/isvw/temp/AU/piranhacache/* to path /opt/trend/isvw/lib/mail/cache.

anyone having same issue?

Thanks for the help

New Member

Requirements for 6.6.1125.0? Whats the req for ASA sw level?

New Member

Hi Gustavo,

installation of 6.6.1144 is supported on 6.6.1125 only - as shown at installation.

please uninstall 6.6.1140 and install 6.6.1144 again - as I did.

Please read the answer of Juan, 21.2.2014.

Cisco Employee

Patch 1144 can be installed on top of 1140. You DO NOT need to uninstall 1140 first.

New Member

Patch 1144 seems to be working for me now, but I am still receiving this alert:

Anti-spam pattern 20534 was successfully downloaded and installed.

Unable to copy file . You must manually copy file /opt/trend/isvw/temp/AU/piranhacache/* to path /opt/trend/isvw/lib/mail/cache.

How can I make this work correctly?

Cisco Employee
New Member

Help, I was able to update it but now my websites with javascripts wont load properly. Any ideas?

New Member
Good info folks thanks, great instructions. I was at 6.3.x.x. I was also having problems with the CPU on the CSM spiking at 100% at those times our internet would go down. updating to 6.6.1125 then applying the patch not only fixed the update issue but also corrected the spiking CPU issue. I only ran patch 1144 and all is working good. Should I still run the 11145 patch? Again Thanks to all for the info
New Member

hi ... after latest updates, all sites with Javascripts have issues. They don't load properly or require several tries until it happens.

 

Could this be related?

New Member

hello i installed 1145 and but i have this problem

AntiVirusEngine : Virus scan engine 9.75.1005 was successfully downloaded and installed.

Unable to backup file /opt/trend/isvw/lib/libvsapi.so. You need to manually copy file /opt/trend/isvw/temp/AU/libvsapi.so to path /opt/trend/isvw/lib.

 

 

Product version:Trend Micro InterScan for Cisco CSC SSM 6.6.1125.0.1145
Serial Numb 
License:Base License expires on 07/14/2014
  Plus License expires on 07/14/2014
ComponentCurrent VersionLast Update
Virus Pattern File10.661.0003/13/2014 10:11:07
<td width="27" align="center" class="data2b" "="" style="font-size: xx-small; color: rgb(0, 0, 0); padding: 1px 3px; background-color: rgb(236, 236, 219); border-right-width: 1px; border-right-style: solid; border-right-color: rgb(204, 204, 204); height: 22px; vertical-align: middle;">Virus Scan Engine9.12.1004 
Spyware/Grayware pattern1.489.0003/06/2014 15:41:17
Anti-spam rules and engine  
  Anti-spam rules2056203/12/2014 19:41:44
  Anti-spam engine7.5.101703/04/2014 17:02:14
IntelliTrap Pattern0.173.0003/05/2014 22:10:15
IntelliTrap Exception Pattern0.963.0003/11/2014 23:10:16
New Member

Hello,

any idea with regards to this problem? My customer is hitting the same issue. Succesfully applied 1145 and it fixed some issues. But one problem still remains:

===

AntiVirusEngine : Virus scan engine 9.75.1005 was successfully downloaded and installed.
Unable to backup file /opt/trend/isvw/lib/libvsapi.so. You need to manually copy file /opt/trend/isvw/temp/AU/libvsapi.so to path /opt/trend/isvw/lib.

===

Any ideas?

Tomas

New Member

Patch 1146 work excelent
Virus Scan Engine updates fixed
thank you

New Member

Hi Magnus,

 

I recived same error with CSC App. version:       6.3.1172.0 

i need to upgrade to 6.6.1125 ? ant then patch ?

Can someone send me 6.3.1172.4 , and 6.6.1125.0 ??

 

Thanks 

New Member

Hi All ,

 

I Have a big delay for emails after upgrade to 6.6.1125.0.1146,

 

email from gmail are not comming ,

 

Help please, it is urgent.

 

KR

VZ

 

 

New Member

Could finally download patch 1146 and install it.

Updates finally installed. This works!

New Member

Hello,

The lastest hotfix 1146 works fine, scheduled updates are working fine, however I am experiencing issues while sending mails from local domain to gmail hotmail etc... anyone of you guys noticed conflict of CSC SSM with Microsoft exchange 2003 unable to send mails to hotmail, yahoo, gmail etc (outgoing mails stuck in Queue)?

Please advise.

Cisco Employee

That issue has not been reported (nor anything like it). Please open a TAC case so we can triage your issue.

 

New Member

Hi Magnus,

I think I resolved the issue, I read on another CISCO thread that the issue could be coming from esmtp. I disabled it as follows:

policy-map global_policy

class inspection_default

   no inspect esmtp

 

I'm using Software  8.2(2)

And suddenly, all blocked mails to Gmail, hotmail, yahoo, and previously blocked mails to different domains just went out very quickly and received delivered notifications :)

BR,

Chadi

 

New Member

Magnus

I am having a slightly different issue with the updates but the latest date visible of 14th Feb 2014 seems to line up with your initial post.  My issue is the Network Timeout version.  I am running latest the 6.6 code and I have applied the 1146 hotfix but the Network Timeout remains.  I am not inspecting the update traffic.  I gather from another post that there is a hotfix later than 1146 available which may address this issue.  

https://supportforums.cisco.com/discussion/12294056/what-latest-hotfix-asa-csc-ssm-20-66-code

This post suggests 1155 has been released.  Are you able to post a link to it please?

New Member

Hello Magnus,

I am having a small issue with my CSC SSM after installing the series of patches up to 1146, from time to time the device becomes unresponsive, the ping to IP is successful but the services seem to be down, http etc...and I have to re-initialize the module. Updates are running fine though.

 

I am doubting about flash free space remaining after last upgrade, which is now at 96 % 8 MB left free, to be the cause of the issue making the OS unresponsive.

 

Can I just delete the old patches still existing in this directory, till 1145?

-bash-3.00# pwd
/mnt/rw/opt/trend/isvw/patch/backup

-bash-3.00# du -sh *
3.4M    6.6.1125.0.1140
5.3M    6.6.1125.0.1144
5.9M    6.6.1125.0.1145
7.0M    6.6.1125.0.1146

 

/dev/hda2               217.8M    198.6M      8.0M  96% /mnt/rw

Is it safe to delete them and what is the proper method pls?

BR,

Chadi

 

New Member

Magnus,

  Unable to find the patch anywhere...can you maybe repost please?

Regards,

 

Eugenio

New Member

Goodbye CSC modules :-) !!!

New Member

Why Goodbye?

 

  There are under support until Sept. 2018. But I can´t find the patch anywhere, neither Cisco or TrendMicro web sites. Will have to open a case for this and I doub´t they will help...

 

http://www.cisco.com/c/en/us/products/collateral/security/asa-5500-series-next-generation-firewalls/eol_C51-727284.html

 

New Member

We never had a decent performance after this 1146 Patch, so we moved on :-) so its only a goodbye from us, and a good luck to you :-)

New Member

Hi

We  have issue with  updating CSC InterScan virus scan engine, pattern, adn etc

I have made many times reimagin but it does'nt help

Our version 6.6.1125 with patch applied 1157

nothing changed with firewall configuration everything worked fine month ago, the license for update also ok it has expiration date until 2017

Can U help pls

I'm receiving the error code 28

New Member

Hi knamikhazehaqq,

We are actually experiencing the same issue as well with same error code 28:

AntiVirusEngine : Pattern Update: The download file was unsuccessful for ActiveUpdate was unable to connect to the network. Please verify that the network connection is functional, and then try again.. The error code is 28.

Same message for all the remaining patterns.

I know it is not a network connection issue from our side as I tried different internet connections.

Our license is till the end of 2016 and unfortunately the updates stopped working on 25-07-2016:

Virus Pattern File 12.673.00 07/25/2016

Anti-spam rules 22472 07/25/2016

I think it might be related to the flash size on the CSC module, since I am on 256 MB.

I noticed on this link that Trend Micro has large size on the definition pattern files, the same are used in the CSC module, I am not sure though if it is relevant to our issue, since the existing pattern files on our module are much smaller in size:

http://downloadcenter.trendmicro.com/index.php?clk=left_nav&clkval=pattern_file&regs=NABU

Latest virus pattern is actually at: 12.721.50

Can you confirm please you are using 256 MB flash size as well? (from root access, fdisk -l)

BR,

Chadi

New Member

Hi

Yes we also have 256MB on /dev/hda

Cisco Employee

The current issue has nothing to do with file space limitations. There was a change on the TrendMicro update servers that requires an upgrade on all CSC modules to support that change.

Please check https://supportforums.cisco.com/document/13102616/csc-module-updates-failing-after-late-july-2016-error-code-28 for more info on what is breaking the updates at this time.

Cisco Employee
The current issue is due to a security change on the updates servers hosted by TrendMicro. Please refer to https://supportforums.cisco.com/document/13102616/csc-module-updates-failing-after-late-july-2016-error-code-28 for more information.
New Member

Patch installed, updates seem working fine now.

Thanks Magnus.

New Member

Hi

Is there any new changes at server side of TrendMicro?

We receiving error code 16 and cannot update AntiVirusPattern