Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

IP Phone SSL VPN to ASA using AnyConnect




Starting in CUCM 8.0.1 and IP Phone Firmware 9.X, IP Phones are now able to directly connect to an ASA using the AnyConnect VPN. This  document will help address some common issues encountered during intial configuration. This guide will act as a supplement to the Official IP Phone VPN Documentation.


Functional Overview

Before we get into versions and model numbers let's look at how the feature works.

CUCM Places ASA Certificate Hash and VPN URL in Phone Config

Before the phone is ready for VPN, it must first be provisioned using the internal network. This requires direct access to the CUCM TFTP server.




The first step after the ASA is fully configured is to take the ASA HTTPS Certificate and upload it to the CUCM server. This allows the CUCM server to build an IP phone config file that tells the phone how to get to the ASA. The CUCM requires some additional configuration to associate the uploaded certificate with a VPN Profile that can be assigned to the phone.


Here is an example of the IP Phone VPN section of a phone's config file after performing the required configuration:


jasburns@jasburns-gentoo /home/jasburns $ tftp
tftp> get SEP0011215A1AE3.cnf.xml.sgn
Received XXXX bytes in 0.0 seconds
jasburns@jasburns-gentoo /home/jasburns $ cat SEP0011215A1AE3.cnf.xml.sgn
[Some Lines Omitted]















Note that the URL is printed exactly as entered on the VPN Gateway Configuration page in CUCM. Make sure the IP Phone can resolve this address.


Even more interesting is the Cert Hash. The IP phone configuration does not contain the entire certificate, merely a SHA1 Base64 encoded hash of the certificate.


You can compare the certificate hash in the IP phone configuration file to the cert hash of the actual file on the ASA or CUCM if you copy it to a computer running OpenSSL (either Windows, Linux, or Mac)


$ cat


<Base64 value of the cert omitted>



openssl x509 -in -noout -fingerprint

SHA1 Fingerprint=D5:E0:FD:97:75:44:23:D0:C6:59:01:8A:94:D0:46:13:56:D1:85:48


This is the SHA1 Fingerprint in Hexadecimal form. In the configuration file this value is instead printed as the Base64 value. I used the following website to convert from Hex to Base64:



This method can be used to verify the certificate loaded onto and presented by the ASA matches the certificate hash loaded into the phone.

Phone Downloads Configuration

This part is extremely important. The phone must download the configuration (including the certificate hash in Base64) while it is inside the network and has direct access to the CUCM TFTP server.


The phone has to be provisioned inside the network before it can be moved outside the network and use the VPN feature.

Phone Connects to ASA

After internal provisioning has been completed, the phone can be moved to the external network for VPN access. Here the Corporate Phone has been moved to a Home location.





Depending on the phone's configuration it will either automatically attempt to connect to the VPN gateway, or will connect once manually initiated. If auto network detect is enabled, the phone will try to ping the TFTP server. If there is no response to this ping request the phone will automatically bring up the VPN process on the phone.


The phone connects on TCP port 443 over HTTPS to the ASA. The ASA responds back with the configured certificate, hopefully the same certificate uploaded to CUCM. In additional TCP 443 (Transport Layer Security, or TLS), the phone will also connect on UDP 443 for DTLS (Datagram Transport Layer Security).

Phone Verifies Presented Certificate

The phone console logs show us the hash of the certificate that the ASA presents in Hex form:


3943: INF 18:10:22.354209 VPNC: vpnc_save_to_file: wrote: </tmp/leaf.crt>, 479 bytes

3944: NOT 18:10:22.355351 VPNC: cert_vfy_cb: peer cert saved: /tmp/leaf.crt

3945: NOT 18:10:22.361892 SECD: Leaf cert hash = D5E0FD97754423D0C659018A94D0461356D18548

3946: NOT 18:10:22.362574 SECD: Hash was found in the trust list

3947: NOT 18:10:22.400294 VPNC: VPN cert chain trusted


These messages show us that the phone was able to validate the certificate that the ASA presented. The cert presented matched the hash in the configuration file.


At this point the phone will establish an SSL session with the ASA and continue setting up the VPN tunnel.


All communication will now flow between the phone and the ASA in an encrypted tunnel. Once the traffic reaches the ASA it will be decrypted and forwarded along to any location in the network that the phone would like to connect to.


The beauty of this solution is that the phone obtains an address on the Internal network that is typically not filtered. The phone can connect using SCCP, SIP, HTTP, HTTPS to any server inside the Corporate Network. This allows advanced phone services and features to function that might not work through ASA Phone Proxy.

Software Versions


IP Phone >= 9.0(2)SR1S - SCCP

ASA >= 8.0.4

Anyconnect VPN Pkg >= 2.4.1012


Note: A "Premium" license and an "AnyConnect for Cisco VPN Phone" license is required.  The part number for the "AnyConnect for Cisco VPN Phone" is L-ASA-AC-PH-55XX= where XX = 05,10,20,40,50,80.


Phone Models

7942 / 7962 / 7945 / 7965 / 7975 / 8961 / 9951 / 9971. For a complete list of supported phones in your CUCM version go to:


https://<CUCM Server IP Address>:8443/cucreports/

Unified CM Phone Feature List

Generate a new report

Feature: Virtual Private Network

CUCM Configuration

The following document provides a complete set of configuration  tasks required to configure CUCM for this feature:


Note: Please make sure the URL for the VPN Gateway contains the full and correct address to reach the IP Phone VPN tunnel-group on the ASA.


Phone Configuration

  1. Use a supported phone model per the CUCM Supported Models / Features report.
  2. Register the phone to the CUCM server on the Internal network
  3. Configure the IP phone with a TFTP server manually.
  4. Move the phone to the external network.


ASA Configuration

Configure Anyconnect VPN access on ASA to provide network access.

See  for example configuration.


The lateset CUCM Security Guide also provides sample ASA configuration.


Additional Requirements:

  1. The ASA must have the AnyConnect for Cisco VPN Phone Licensed feature enabled.  Licensing info can be found using show version command.
  2. Group-policy must not be configured with split tunnel or split exclude.  Only tunnel all is the supported tunneling policy
  3. The tunnel-group used can not be the DefaultWEBVPNGroup.   Create another tunnel-group and use "group-url https://x.x.x.x/phonevpn enable to map to the correct tunnel-group.
  4. DTLS must be enabled and negotiated for operation.  This  requires both tcp/443 and udp/443 to be open and allowed on all devices between the ASA and the phone.


Troubleshooting Steps

  1. Plug the phone into the internal network.  This will test whether the phone's configuration works prior to adding VPN.
  2. Connect with AnyConnect on a PC from the outside to the ASA.  This will confirm that the ASA is configured correctly for Anyconnect
  3. From the connected PC try to ping the TFTP server and CUCM server.  This will test basic ip connectivity to the two servers.
  4. From the PC try to download the TFTP config file for the phone in question "tftp -i <TFTP Server> GET  SEP<Mac Address>.cnf.xml"  This will test that the tftp service is reachable and serving files.
  5. From the PC try to telnet to TCP Port 2000 on the CUCM server "telnet <CUCM IP> 2000". This should immediately come back with a new line and a blank cursor.  This will test connectivity to the CUCM SCCP port, for SIP registrations use port 5060 instead.


Common Issues

  1. One-way or no voice.  The phone registers and makes calls but no audio is heard.  Confirm routing between the two phone/rtp stream endpoints.
  2. Auto Network Detect does not reliably work in IP Phone Firmware 9.0(2), but does work as expected in 9.2(1).
    1. Auto Network Detect allows the phone to detect whether it is inside or outside the network. If outside it will bring up the VPN, if inside, it will connect directly.
    2. The phone uses a series of pings to the TFTP server to determine whether it is outside the network. If pings to the TFTP server fail, the VPN GUI will be brought up on the phone and the phone will attempt to access the VPN URL.
  3. Username and Password authentication from the phone does NOT support the SPACE character in either the username or the password.
Version history
Revision #:
2 of 2
Last update:
‎08-28-2017 10:14 PM
Updated by:
Labels (1)


Thanks alot for this detailed mail

Only I need to confirm something,,

With CUCM 8, Do I need only premium license to have ip phone vpn feature on ASA, or also I need this license L-ASA-AC-PH-55XX= beside the premium

That I hear that with CUCM 8 we need only the premium license [Any connect include it] , and this license L-ASA-AC-PH-55XX= may be needed only with CUCME8 ?

If, I'll need this license L-ASA-AC-PH-55XX=

Will I order it per users or per session or per device ??

Thanks a lot and waiting for your reply

Best Regards


You need both the Premium license and the Phone license applied to the ASA.  The Premium license is a number of concurrent sessions license whereas the Phone license is a enable/disable feature license.

You can order the licenses separately but whether or not they are included with the purchase of CUCM 8 I do not know.  Perhaps you can contact your local sales rep to see if they can perform a bundle.

Dear Jay,

Thank you very much for your concern and fast reply

Only one other question:

Is this required license L-ASA-AC-PH-55XX= is not included in this license: ASA-ANYCONN-CSD-K9

ASA-ANYCONN-CSD-K9 : is AnyConnect  client license and I read that there is a new license for ASA called AnyConnect and it include most of the needed features ?

Kindly correct my sentense above that I'm a voice engineer and have low level expertise in Security and tell me what is the AnyConnect license exactly

Thanks for your help and patience

Best Regards


The ASA-ANYCONN-CSD-K9 only allows anyconnect and csd.  You will want to order the both the premium license and the L-ASA-AC-PH-55XX=

Hi Jay

Thanks a lot for your follow up

New Member

Since the application is for a phone versus a workstation, is there any settings that should be tweaked?  e.g. Keepalive timers, dead peer detection timers, avoiding AES-256 encryption, etc


ssl encryption aes128-sha1

group-policy <phone/UC> attributes

banner none

dns-server value <DNS1> <DNS2>

vpn-idle-timeout none

vpn-session-timeout none

vpn-tunnel-protocol svc

default-domain value <company>.com

address-pools value <DHCP/RAS POOL>


  svc dtls enable

  svc keep-installer installed

  svc keepalive 120

  svc rekey time 4

  svc rekey method new-tunnel

  svc dpd-interval client none

  svc dpd-interval gateway 300

  svc compression deflate



I have a couple of questions:

If I'm using user and password authentication do I need to get the ASA cert to the phones?

After installing the ASA certificate in CUCM and applying it to the phone will I see it in the phone CTL?

If I am using certificates for authentication which one gets picked - MIC or LSC?



Cisco Employee

Even with username nad password authentication you do need the ASA certificate uploaded to call manager as a phone-vpn-trust, so that the phone can "get" the certificate from call manager and has it to verify the SSL handshake when connecting to the ASA.  There is no way currently to see the certificate on the phone ( like you can with the CTL.  Either the MIC or LSC when using certificates for authentication too.

New Member

Just a follow-up.  ASA code 8.2(4) was providing the unexpected result of random midcall failures using the configuration above.  ASA code 8.3(2)4 does seem to have corrected the issue.

New Member

What happens when we need to replace the ASA's certificate?  e..g. The certificate on the ASA is revoked or ages out and simply needs to be replaced.  If I follow the procedure and "replace" the old certificate, won't my remote phones who were brought up using the legacy certifictate no longer be able to VPN in?

Cisco Employee

If you have to replace your ASA certificate if possible put the ASA certificate on call manager before applying it to the ASA, so that CUCM has a new phone-vpn-trust cert, apply that new certificate to the VPN gateway profile and then reset the phone, that way the phone gets the new certificate while still being connected to the VPN.  Alternatively, if the ASA cert expires the phone will not be able to connect to the VPN, what must be done in that case is an external TFTP has to be setup that has the phone's new config file with the new certificate that can be downloaded from call manager and then the phone has to be pointed to the external TFTP.  Otherwise you're correct the phone would have to be brought back inside the internal network again.

New Member

Thank you for this usefull topic!

Got one question

What if I dont have this feature mentioned in my sh run

AnyConnect for Cisco VPN Phone : Disabled 


That feature won't be mentioned if you are running an older version of the ASA code.  You will need to upgrade to the minimum version as referenced about.

New Member

Thank you for the Wonderfull Post.

I have congigured the CUCM/ASA as per the guidence given here and provioned the 7945 phone in the Inside network.

Now am trying to connect the phone from Public  network its prompts me for VPN username/password as soon as i give the creadentials it gives me "Authentication failed" and there is no logs in the orresponding time in ASA(Its not hitting the ASA?).I have tested by connecting PC to SSL VPN and accessing CUCM it works fine.

Any suggestiones here is very much appriciated

Thanks in Advance

Cisco Employee

If it's not hitting the ASA I would look at the phone console logs which can be accessed from putting in the phone's IP address into a browser.  Just to check something basic, is the URL configured as a hostname or IP address?  If it's a hostname does the phone have a DNS server that can resolve it?

New Member

The VPN GW url is configured as a IP address.I have checked the phone status messages for that time it says "All concentrators failed"

I think there is some thing basic is missing not able to crack it

Anyhelp here is very much apprciated

Cisco Employee

The phone console logs are key to investigate this, if you have those we can take a look.

New Member

Ok let me look at the console log and come back here

New Member

good stuff!! 

Does anyone know if the phone Cert can also be leveraged by the ASA for VPN-Phone-trust?

or is it just Phone-VPN-trust using the ASA's cert on the phone (via CUCM), and then the ASA trusts the phone just from the Username/PW?

Also, has anyone used a CA to issue signed certs to the phones that the ASA could validate via the CA?

thanks for the great dialog!

New Member

Hi Joe,

The below is the LOG message from Phone console


1087: NOT 13:10:18.180262 VPNC: VPN cert chain trusted
1088: DBG 13:10:18.181643 VPNU: SM wakeup - chld=0 tmr=0 io=1 res=0
1089: NOT 13:10:18.183502 VPNC: Using URL addr = (https://x.x.x.x/abcd)
1090: NOT 13:10:18.184080 VPNC: Host name = (x.x.x.x)
1091: NOT 13:10:18.184840 VPNC: Parsing host name from certificate...
1092: NOT 13:10:18.185512 VPNC: hostID not found in subject name
1093: ERR 13:10:18.186303 VPNC: hostIDCheck failed!!!
1094: ERR 13:10:18.188052 VPNC: ssl_state_cb: TLSv1: write: alert: fatal:unknown CA
1095: ERR 13:10:18.188968 VPNC: alert_err: SSL write alert: code 48, unknown CA
1096: ERR 13:10:18.189991 VPNC: create_ssl_connection: SSL_connect ret -1 error 1
1097: ERR 13:10:18.191394 VPNC: SSL: SSL_connect: SSL_ERROR_SSL (error 1)
1098: ERR 13:10:18.192406 VPNC: SSL: SSL_connect: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
1099: ERR 13:10:18.193416 VPNC: create_ssl_connection: SSL setup failure
1100: ERR 13:10:18.195227 VPNC: do_login: create_ssl_connection failed
1101: NOT 13:10:18.196442 VPNC: vpn_stop: de-activating vpn
1102: NOT 13:10:18.197296 VPNC: vpn_set_auto: auto -> auto
1103: NOT 13:10:18.197904 VPNC: vpn_set_active: activated -> de-activated
1104: NOT 13:10:18.198711 VPNC: set_login_state: LOGIN: 1 (TRYING) --> 3 (FAILED)
1105: NOT 13:10:18.199577 VPNC: set_login_state: VPNC : 1 (LoggingIn) --> 3 (LoginFailed)
1106: NOT 13:10:18.200518 VPNC: vpnc_send_notify: notify type: 1 [LoginFailed]

It says Host ID check failed i have tried disabling the Host id check field in the VPN   configuration still the issue persists.

Any inputs here is very much apprciated

Thanks in Advance

Cisco Employee

Looks like the "Enable Host ID Check" checkbox needs to be unchecked under the VPN profile in CUCM, since the URL is configured as an IP address and the certificate likely contains a hostname (so they don't match).

New Member

" i have tried disabling the Host id check field in the VPN   configuration still the issue persists"

Cisco Employee

Was the phone internal when this change was made, so that it could download it's new configuration file with that change in it?

New Member

no will check connecting it internal and let you know tomorw

New Member

Each time you make a change in CCM configuration regarding VPN, you have to reset the IP phone to let him download new config

New Member


Do I need to download any certificate from the cucm and upload to the ASA too?

And if so, which one?

New Member

Can the ASA check a CRL list so that a phones access can be revoked?

New Member

jason , i followed the steps you menitoned and it worked very well. I had a question , in the ASA when i look at SSL VPN Cclient it shows me the MAC Address of the Phone as the username is there any way we can change it to some standard user id . We are using as Certificate only as the authentication.

Cisco Employee

Hi Team.....Can anyone help me with a process to prevent the lost phones from connecting to the ASA.

Cisco Employee

If you are using username and password based authentication you can keep the phone from authenticated by deleting the user from the ASA, however the phone will still connect.  If you are using certificate based authentication you could change the certificates used by the ASA and phones so that the lost phone can no longer authenticate, however it will still try and connect.  The only way to prevent the phone from connecting completely would be to change the address (IP address) of your ASA and/or URL.  The phone will remember the address for the ASA until it downloads a new configuration file or is cleared (factory reset).


while the ip phone is outside, it can't take the ring tones as the internal ip phones

when putting the tftp ip address manually to point to the cucm, it gives vpn authentication fail

Plz help how to get the ring tones for the ouside phones or what may prevent the phone from getting it

New Member


Could you please advise what is the format of the "VPN gatway url "we should configure on the CUCM? firstly, should we configure this url on the ASA? If yes, what are the procedures for doing this?

Thanks in advance

New Member


Is there any update regarding my above query?

Thanks in advance


Ala Raed Issa,

As mentioned in the article above you will need to configure a url on the ASA like the following:


You will need to do that under the tunnel-group.  After that in the CUCM you put the following the phone config file:

[Some Lines Omitted]
New Member

Hi Jay,

Really, many thanks for your response.

in addtion, could you please provide me with the part number of the required "premium license" ???

Really, thanks in advance for your repsonse.

Best Regards,

any one got all the ringtones downloaded while the phone is outside ??

New Member

Hi Jay and all,

Is there any update regarding the part number of the required "premium license" ???

Thanks in advance

Warmest Regards,

Ala'a Issa


Ala'a Issa,

The license FRU number is:  ASA5500-SSL-XXXX

Where XX could be: 10,25,50,100,250,500,750,1000,2500,5000,10K


New Member

we have 2 questions we wanted to ask you guys about this setup.

1. we currently use Cisco NAC and Cisco ISE for remediation control. Do we need to manually exclude the mac of the phone before sending it to the field, or will NAC/ISE recognize the MAC as a phone?

2. Does the PC Port on the phone ALSO get vpn access? Is the only way to "disable" the pc port is through UCM, then lock the settings so a user can not "piggy back" into the network through the phone?



1. NAC / ISE - I don't know the answer to this question.

2. Does the PC Port on the phone get VPN Access?

     No - the PC port does not have access to the VPN. Only the phone has SSL VPN access. The PC port will have access to the local network where the phone is plugged in.



I don't believe that the phones have a NAC agent installed on them nor CSD.  In addition since the connection is coming over a VPN the MACs of the phone will not be used when being sent out the inside of the ASA.

As a result:

NAC - don't have an agent so can't validate with the CAS.

ISE - The ASA doesn't have any of the endpoint attributes from the phone since CSD won't run.  As a result we can't make a policy decision on that info.

The solution for you is to setup another tunnel-group and group-policy specifically for the phones.  Setup a separate vlan to have them dumped into and on the CAS allow that vlan to pass.

Hope that helps.


Any one here tried to restore a call manager backup after sending the phone outside, Will the call manager retain the certificate using the restore ? or the outside phones will fail and need to come home again ??





The CUCM backup and restore should restore the VPN certificate and VPN Gateway and Group configuration as well during a DRS Restore.

Your outside phones wouldn't be affected and should register to the CUCM again once it was restored.

New Member

Is is possible to use a IOS router at the head end to terminate the phone VPN instead of the ASA ?

Say like a 29xx/39xx series ?

New Member

Are video calls supported on the 9971 with this method?


This is completely possible, but covered in another document for IOS SSL Phone VPN


Video calls over the VPN should work as long as you have enough bandwidth.

New Member

We did a lab recreation here and we confirmed the VPN phone can connect using AnyConnect Essential License. This is an option instead of use the Premium License.

New Member

hi everyone. is it work on CIUS? i want to connect my CIUS with anyconnect, and registered with my CUCM. I already buy the ASA license to enable AnyConnect for mobile. When i try connecting CIUS to ASA ,there's message from CIUS "phone service unavailable" and "telephone service is unavailable". Do i need to buy another license to enable AnyConnect for CISCO VPN Phone?