Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

L2TP/IPSEC Between IOS and Android

Introduction: This document describes the process of configuring L2TP over IPSEC between Cisco IOS router and Android.

Prerequesites:


1.       ASA with 7.x and Above

2.       Android Mobile Handset

Diagram: 

l2tp.jpg

Configuration:

Well no lets go ahead and look into actual Configuration. Please refer the following detailed Configuration.

vpdn enable
!
vpdn-group l2tpvpn
! Default L2TP VPDN group
accept-dialin
   protocol l2tp
   virtual-template 1
no l2tp tunnel authentication
!

username user privilege 15 password secret

!

crypto keyring l2tpvpn
   pre-shared-key address 0.0.0.0 0.0.0.0 key test
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
lifetime 3600

crypto isakmp key test address 0.0.0.0 0.0.0.0

crypto isakmp keepalive 10 periodic

!

!

crypto ipsec transform-set L2TP-TS esp-3des esp-sha-hmac

mode transport

!

crypto dynamic-map dynvpn 1

set nat demux

set transform-set L2TP-TS

crypto map CRYPTOMAP 20 ipsec-isakmp dynamic dynvpn

interface Virtual-Template1

ip unnumbered Ethernet0

peer default ip address pool VPN

keepalive 5

ppp authentication ms-chap-v2


interface BVI1
ip address 99.99.99.1 255.255.255.0
ip nat outside
ip virtual-reassembly
ipv6 address autoconfig default
ipv6 enable
crypto map CRYPTOMAP
!
ip local pool VPN 10.2.1.1 10.2.1.10

!---------------------------------------------------

Hope you  like this information, Please leave your inputs, comments and feedbacks.

Related Information:

 

https://supportforums.cisco.com/thread/2030266

Comments
New Member

what will happen if i didn't enable ipv6 

ipv6 address autoconfig default
ipv6 enable 

and what about cisco 800 series router

10418
Views
5
Helpful
1
Comments