Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

The PDM does not load properly and returns the "Your firewall image has a version number of 7.0(1). This requires a new version of PDM. Please upgrade your PDM image" error message

Core issue

The Your firewall image has a version number of 7.0(1). This requires a new version of PDM. Please upgrade your PDM image error message is generated due to an incorrect  browser or incompatible PIX Firewall and PIX Device Manager (PDM) versions.

In order for the PDM to run properly on a PC, it is necessary to run the correct version of either Netscape or Internet Explorer. In addition, it is also important that the PIX that has PDM installed is running the appropriate Operating System (OS) version.

Resolution

In order to resolve this issue, verify the current OS version running on the PIX:

Issue the show version command on the PIX.

The results appear in a form similar to this output, depending on the OS version:

Cisco PIX Firewall Version 6.2(1) 
Cisco PIX Device Manager Version 2.0(1)

!--- The rest of the output is omitted.

This is the output for a PIX that runs on OS 7.x:

Cisco PIX Security Appliance Software Version 7.0(1)
Device Manager Version 5.0(1)

!--- The rest of the output is omitted.

The first two lines of the show version output indicate the OS and PDM/Adaptive Security Device Manager (ASDM) running on the PIX. If there is no entry for the PDM/ASDM in the show version command, it is not loaded on the PIX and needs to be installed.


Then, verify that the version of PIX OS and PDM/ASDM software are compatible:

For information on which PIX OS to run on each version of PDM, refer to this list:

  • For PIX 6.0 and 6.1 software, the PDM version must be 1.0 or 1.1.

  • For PIX 6.2 software, the PDM version must be 2.0 or 2.1.

  • For PIX 6.3 software, the PDM version must be 3.0.

  • For PIX 7.x software, the ASDM version must be 5.x.

These are other PIX requirements:

  • The PIX must have Data Encryption Standard (DES) or 3DES enabled in order to install a PDM. Issue the show version command in order to determine if either is enabled.

  • The PIX must contain at least 8 MB of Flash memory. Issue the show version command in order to determine this information.

  • The current configuration on the PIX must be less than 100 KB (1500 lines).

These are the browser requirements:

  • JavaScript and Java enabled

  • Secure Socket Layer (SSL) enabled (SSL 2.0, SSL 3.0, Transport Layer Security (TLS) 1.0)

  • Either Internet Explorer 5.0 (SP1) or later (5.5 recommended), or Netscape 4.51 or later (4.76 recommended)

These are the Windows requirements in order to run PDM:

  • Windows 2000 SP1, Windows NT 4.0 SP4 or later, Windows 98 or Windows ME

Note: XP is only supported in PDM 2.0, and Windows 95 and Macintosh are not supported.

  • Pentium 350 MHz or later
           
  • 128 M RAM (192 M recommended)

  • 800x600 pixel display with 256 colors (1024x768 pixel display, high)

  • Color (16-bit recommended)

For more information on PIX command references, refer to Cisco Secure PIX Firewall Command References.

Note:  If you run the new software code on PIX 7.x and later, the corresponding web interface code version on the PIX is 5.x and later. This new web interface on the PIX is called ASDM, and it replaces the old naming convention for the PIX GUI interface (which was commonly referred to as the PDM).

If an error similar to the one described in this document is received, upgrade the PIX GUI interface to ASDM and not PDM. This is because ASDM is the corresponding version of the GUI interface that is compatible with 7.x code on the PIX.

For details related to the user system, including OS support, web browsers, and ASDM usage and installation, refer to the Cisco Adaptive Security Device Manager Version 5.0 Data Sheet.

Version history
Revision #:
1 of 1
Last update:
‎06-22-2009 04:05 PM
Updated by:
 
Labels (1)