Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to install the Linux VPN client on Kernel 2.6.18 and the "Failed to make module 'cisco_ipsec.ko'" error message appears

Core issue

This issue is due to presence of Cisco bug ID CSCsg66766.

Any Linux Kernel version later than 2.6.18 does not have a config.h file in the source files and does not go forward.

Resolution

For a workaround, complete these steps:

First, use the touch command in the Kernel source directory as given in this example, in order to create the config.h file:

[root@hostanme build]#touch config.h

Then install the script.

Note: During installation, this error message can possibly appear as well:

usr/src/vpn/vpnclient/interceptor.c:553: error: 'CHECKSUM_HW' undeclared (first use in this function)

In order to resolve this issue, download, compile and install the patch for Cisco VPN Client. Note: This is a third party link.

Version history
Revision #:
1 of 1
Last update:
‎06-22-2009 05:05 PM
Updated by:
 
Labels (1)