Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ASA 5510 - Can't access internet

I'm installing a new ASA 5510.  I tried to configure a simple setup and get that working before I deal with DMZ and VPN.  I can't even get our internal subnet to access the internet on the outside interface.  My internal subnet is 192.168.0.0/24 and my outside IP is 63.93.81.98 and gw is 63.93.81.97.  I'm not sure what I'm missing here.  Here is my config:

Result of the command: "show running-config"

: Saved
:
ASA Version 8.2(5)
!
hostname ciscoasa
domain-name doorcontrolsusa.com
enable password aqGwzrart3V.q/x2 encrypted
passwd 2KFQnbNIdI.2KYOu encrypted
names
!
interface Ethernet0/0
nameif outside
security-level 0
ip address 63.93.81.98 255.255.255.248
!
interface Ethernet0/1
nameif inside
security-level 100
ip address 192.168.0.252 255.255.255.0
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
management-only
!
ftp mode passive
dns domain-lookup outside
dns domain-lookup inside
dns server-group DefaultDNS
name-server 192.168.0.7
domain-name doorcontrolsusa.com
dns server-group Outside
name-server 198.6.100.38
name-server 198.6.1.5
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list inside_access_in extended permit ip 192.168.0.0 255.255.255.0 any
pager lines 24
logging enable
logging asdm informational
mtu management 1500
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 192.168.0.0 255.255.255.0
access-group inside_access_in in interface inside control-plane
route outside 0.0.0.0 0.0.0.0 63.93.81.97 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 management
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:a487a8689e1d63da2c6a4c8c50eda685
: end

I'm using ASDM and a little CLI as I'm very new to this.  Any help is much appreciated.                    

Thanks,

Keith Nations

Everyone's tags (7)
7 REPLIES
Cisco Employee

ASA 5510 - Can't access internet

The following command:

access-group inside_access_in in interface inside control-plane

should be:

access-group inside_access_in in interface inside

Also, are you able to ping the internet, try to ping 4.2.2.2, or even try to ping 63.93.81.97, from a PC and see if you have any replies.

Perhaps you have no DNS resolution?

I also assume that your PC default gateway is 192.168.0.252, and your PC is configured with ip address of 192.168.0.x and subnet mask of 255.255.255.0 ?

New Member

ASA 5510 - Can't access internet

Without changing anything, it seems to be working now.  My ISP could have been having issues.  I'm still testing to make sure it doesn't drop.  Then I'll dive into setting up DMZ and VPN.  Thanks for your help.

Cisco Employee

ASA 5510 - Can't access internet

Good to hear all is good now. All the best with the rest of the config.

New Member

ASA 5510 - Can't access internet

Hi Jennifer,

Sorry for crashing in this thread. I have a similar problem, actually.

I have just configured a site-to-site VPN between ASA5510-ASA5520 running ASA 8.4(3).

Site-to-site VPN is working and humming along. Thing is, I can't browse the internet.

I CAN however ping 4.2.2.2 but havent tried any other public IP address for that matter.

I have already configured nat with the following command:

object network inside-net

     nat (inside,outside) dynamic interface

Still, I cant browse the internet.

Hope to hear from you soon.

Thank you.

Regards,

Jemel

Cisco Employee

ASA 5510 - Can't access internet

no problem, Jemel.

If you can ping 4.2.2.2 that means you have internet connectivity.

Most probably your DNS resolution is not working, ie: try to see if cisco.com resolves to any ip address. If not, then check the DNS setting.

New Member

ASA 5510 - Can't access internet

Hi Jennifer,

Yes I think that solved the issue for me. Thank you. What I did was replace the DNS with th public DNS server of 4.2.2.2.

Our PCs get their IP Addresses from the ASA, IP Addresses are renewed, including DNS Servers.

Could it be that the issue is with the ISP DNS Server?

Regards,

Jemel

Cisco Employee

ASA 5510 - Can't access internet

Definitely sounds like an issue with the ISP DNS server. Otherwise, if you use 4.2.2.2, it won't work too if there is issue with the ASA.

I would check with your ISP for the DNS server, because if you use 4.2.2.2, depending on where you are, the DNS resolution might take longer time than using your ISP DNS server because it should be local/closer to where you are.

All the best.

3046
Views
8
Helpful
7
Replies
CreatePlease to create content