Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

ASA5505 telnet/ssh/web issue

I'm unable to access this ASA from anywhere except console.

I'm no ASA expert, but I've compared it to other ASA's I've configured, and I just can't find the error of my ways.

This is should be easy, I just need a different set of eyes looking at it now. I hope I didn't censor it too much, but I imagine if I'm able to SSH locally, that will fix all the other access issues I have.

:
ASA Version 7.2(4)
!
hostname X
domain-name X.local
enable password XXXXXXXXXXXXXXXXXXX encrypted
passwd XXXXXXXXXXXXXXXX encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.27.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!

banner motd OFFICIAL USE ONLY. Unauthorized use prohibited
banner motd Individuals using this computing system is subject to having all
banner motd of their activities on this system monitored and recorded without
banner motd further notice. Auditing of users may include keystroke monitoring.

boot system disk0:/asa821-k8.bin
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
name-server X.X.X.12
name-server 4.2.2.2
domain-name pain.local
same-security-traffic permit intra-interface
object-group service XX tcp-udp
port-object range 60000 64999
object-group network MySpace
network-object 67.134.143.0 255.255.255.0
network-object 204.16.32.0 255.255.255.0
network-object 216.178.32.0 255.255.224.0
object-group network Facebook
network-object 69.63.176.0 255.255.255.0
network-object 204.15.20.0 255.255.255.0
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
object-group network DM_INLINE_NETWORK_1
network-object 10.x.x.0 255.255.255.0
network-object 172.x.x.0 255.255.255.0
network-object 10.x.x.0 255.255.255.0
network-object 10.x.x.0 255.255.255.0
network-object 10.x.x.0 255.255.255.0
network-object 172.x.x.0 255.255.255.0
object-group network LocalLAN
description X Local Subnet 192.168.27.x
network-object 192.168.27.0 255.255.255.0
object-group network DM_INLINE_NETWORK_2
network-object 10.x.x.0 255.255.255.0
network-object 10.x.x.0 255.255.255.0
network-object 10.x.x.0 255.255.255.0
network-object 10.x.x.0 255.255.255.0
network-object 172.x.x.0 255.255.255.0
network-object 172.x.x.0 255.255.255.0
object-group network DM_INLINE_NETWORK_3
network-object host 64.x.x.x
network-object host 71.x.x.x
network-object host 74.x.x.x
network-object host 99.x.x.x
network-object host 173.x.x.x
network-object 192.168.27.0 255.255.255.0
network-object 192.168.1.0 255.255.255.0
access-list nonat extended permit ip 192.168.27.0 255.255.255.0 object-group DM_INLINE_NETWORK_1
access-list outbound extended deny ip any object-group MySpace inactive
access-list outbound extended deny ip any object-group Facebook inactive
access-list outbound extended permit icmp any any
access-list outbound extended permit ip any any
access-list extended extended permit ip object-group LocalLAN object-group DM_INLINE_NETWORK_1
access-list outside_access_in extended permit ip object-group DM_INLINE_NETWORK_3 any
access-list outside_cryptomap extended permit ip object-group LocalLAN object-group DM_INLINE_NETWORK_2
pager lines 24
logging enable
logging timestamp
logging list Crucial level emergencies
logging buffer-size 1048576
logging console emergencies
logging monitor debugging
logging trap debugging
logging asdm notifications
logging from-address X@X.com
logging recipient-address X@X.com level errors
logging recipient-address X@X.com level critical
logging facility 23
logging permit-hostdown
logging class auth trap emergencies
logging class config trap warnings
logging class ospf trap warnings
logging class vpn trap alerts
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-621.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.X.X 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa authentication enable console LOCAL
aaa authentication ssh console LOCAL
aaa authentication http console LOCAL
http server enable
http x.x.x.x 255.255.255.255 outside
http 0.0.0.0 0.0.0.0 outside
http 0.0.0.0 0.0.0.0 inside
http 192.168.1.0 255.255.255.0 inside
http 192.168.27.0 255.255.255.0 inside
http redirect outside 80
no snmp-server location
no snmp-server contact
snmp-server community *****
snmp-server enable traps snmp authentication linkup linkdown coldstart
sysopt connection tcpmss 1360
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec df-bit clear-df outside
crypto map outside_map 2 match address outside_cryptomap
crypto map outside_map 2 set pfs
crypto map outside_map 2 set peer x.x.x.x
crypto map outside_map 2 set transform-set ESP-AES-128-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption aes
hash sha
group 5
lifetime 86400
crypto isakmp policy 20
authentication pre-share
encryption 3des
hash md5
group 2
lifetime 86400
client-update enable
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
console timeout 0
management-access inside
dhcpd dns 10.x.x.x 4.2.2.2
dhcpd domain pain.local
dhcpd auto_config outside
dhcpd option 156 ascii ftpservers=10.x.x.x
dhcpd option 42 ip 208.66.175.36
!
dhcpd address 192.168.27.2-192.168.27.33 inside
dhcpd enable inside
!

ntp authentication-key 1 md5 *
ntp authenticate
ntp server 10.x.x.x source inside
username XXXXXXXXX password XXXXXXXXXXXXXX encrypted privilege 15
tunnel-group 64.X.X.X type ipsec-l2l
tunnel-group 64.X.X.X ipsec-attributes
pre-shared-key X
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
: end

2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Purple

Re: ASA5505 telnet/ssh/web issue

The relevant part to control from where you are allowed to SSH into the ASA are these lines:

ssh 0.0.0.0 0.0.0.0 inside

ssh 0.0.0.0 0.0.0.0 outside

But do you have public/private keys generated?

asa(config)# crypto key generate rsa general-keys modulus 2048

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni

VIP Purple

Re: ASA5505 telnet/ssh/web issue

do you have the file asdm-621.bin in flash?

Sent from Cisco Technical Support iPad App

5 REPLIES
VIP Purple

Re: ASA5505 telnet/ssh/web issue

The relevant part to control from where you are allowed to SSH into the ASA are these lines:

ssh 0.0.0.0 0.0.0.0 inside

ssh 0.0.0.0 0.0.0.0 outside

But do you have public/private keys generated?

asa(config)# crypto key generate rsa general-keys modulus 2048

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni

ASA5505 telnet/ssh/web issue

Great thanks. I guess all the other ASA's I've configured have been used before.

That fixed the SSH part, but not the access through ADSM or CCP.

The ADSM says 'Not IDM' in the Java window.

IE asks me if it's a trusted site, asks for login ID but then says webpage cannot be found.

xxASA# show run all ssl

ssl server-version any

ssl client-version any

ssl encryption aes256-sha1 aes128-sha1 3des-sha1 des-sha1 rc4-md5

xxASA# show run asdm

asdm image disk0:/asdm-621.bin

no asdm history enable

xxASA# show run http

http server enable

http X.X.X.X 255.255.255.255 outside

http 0.0.0.0 0.0.0.0 outside

http 0.0.0.0 0.0.0.0 inside

http 192.168.1.0 255.255.255.0 inside

http 192.168.27.0 255.255.255.0 inside

http redirect outside 80

VIP Purple

Re: ASA5505 telnet/ssh/web issue

do you have the file asdm-621.bin in flash?

Sent from Cisco Technical Support iPad App

ASA5505 telnet/ssh/web issue

I've verified that the asdm .bin is there, many times... but I guess it helps if you make sure you are refering to the same version that is stored in flash.

It's always the obvious that stumps me.

VIP Purple

Re: ASA5505 telnet/ssh/web issue

It's always the obvious that stumps me

These are always the hardest to find ...

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni

2019
Views
4
Helpful
5
Replies
CreatePlease to create content