Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Backup/Restore CSM 3.3.1 to brand new CSM 4.0 error

Hi

Cisco told me I can backup CSM 3.3.1 data and do a restore to CSM 4.0 . Restore these data to CSM 4.0.1 does not work .

I tried to restore 3.1.1 to a brand new Server with brand new 4.0 CSM and got a error

see attach

"Can´t locate CRM.pm" - nothing found in the Backup folder

9 REPLIES
Cisco Employee

Re: Backup/Restore CSM 3.3.1 to brand new CSM 4.0 error

Hello,

can you send me a screenshot of the backup folder (should be c:\temp) ?

Stefano

New Member

Re: Backup/Restore CSM 3.3.1 to brand new CSM 4.0 error

hi

see attach

Cisco Employee

Re: Backup/Restore CSM 3.3.1 to brand new CSM 4.0 error

Hi,

I am assuming the backup is taken on 3.3.1 not on 3.1.1

Can you please try the following:

1) Stop Demon Manager (DOS Prompt):
net stop crmdmgtd

2) Restore customer DB :
c:\Progra~1\CSCOpx\bin\perl c:\Progra~1\CSCOpx\bin\restorebackup.pl -d c:\test\1396

Also make sure that you have installed MCP on the server (as I see it was installed on the previous version)

Let me know how it goes


Stefano

New Member

Re: Backup/Restore CSM 3.3.1 to brand new CSM 4.0 error

Hi

THX for your help

state: no error message anymore but also no restore result

see attach

no restorebackup.log file created also no restore really executed

alfred

Cisco Employee

Re: Backup/Restore CSM 3.3.1 to brand new CSM 4.0 error

Alfred,


few questions:

1- are you able to restore it in 3.3.1 again?

2- is it the DB taken on 3.3.1 or 3.1.1 ?

3- are you able to correctly login in the server?

4- can you send me the install logs? (they should be in c:\ )


I might need to look at some more logs, but if you are concerned about posting it on community I would advise to open a TAC case to get this resolved.

Stefano

New Member

Re: Backup/Restore CSM 3.3.1 to brand new CSM 4.0 error

Hi Stefano

few questions:

1- are you able to restore it in 3.3.1 again?

>>> did not try, but I checked th 3.3.1 logs if the backup file is cirrput maybe , but it doesn´t

2- is it the DB taken on 3.3.1 or 3.1.1 ?

>>> 3.3.1 sp1

3- are you able to correctly login in the server?

>>> user has admin right but is not the administrator

4- can you send me the install logs? (they should be in c:\ )

>>> your email address ?


I  might need to look at some more logs, but if you are concerned about  posting it on community I would advise to open a TAC case to get this  resolved.

>>> already open

Sincerley Alfred

New Member

Re: Backup/Restore CSM 3.3.1 to brand new CSM 4.0 error

Hi Stefano

few questions:

1- are you able to restore it in 3.3.1 again?

>>> did not try, but I checked th 3.3.1 logs if the backup file is cirrput maybe , but it doesn´t

2- is it the DB taken on 3.3.1 or 3.1.1 ?

>>> 3.3.1 sp1

3- are you able to correctly login in the server?

>>> user has admin right but is not the administrator

4- can you send me the install logs? (they should be in c:\ )

>>> your email address ?


I  might need to look at some more logs, but if you are concerned about  posting it on community I would advise to open a TAC case to get this  resolved.

>>> already open

Sincerley Alfred

New Member

Re: Backup/Restore CSM 3.3.1 to brand new CSM 4.0 error

Hi Stefano

The reason for nothing happen is that the Perl script - restorebackup.pl is empty

I checked it with script from V 3.3.1

Ahhhhhhhhh

Cisco Employee

Re: Backup/Restore CSM 3.3.1 to brand new CSM 4.0 error

Hi Alfred

that's really funny/odd

Did you manage to get a valid script?

Let me know if I can help further

Stefano

632
Views
0
Helpful
9
Replies