Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

FTP Transfert Failed

Hi,

I Have a great problem with FTP connection.In fact, I have configured one VPN between one routeur cisco 837 and other.

I can connect via FTP in one machine 10.128.13.10 from the other site 192.168.1.0/24.

But when I made data transfert, this operation succed for the first file (Some time) but not for the remaining files.Also, when I close my FTP client (FileZilla) and I recommence again this operation , the same thing procure.

The FTP transfert is always failed.

PS : I have desactived mtu configuration.

I don't understand why?Could you help?

Many thanks in advance for all feedback.

3 REPLIES
Silver

Re: FTP Transfert Failed

Try to change MTU and MSS size on physical interfaces, using following command

Example:

ip mtu 1380

ip tcp adjust-mss 1340

Troubleshooting steps:>

Try to ip tcp adjust-mss on physical interface(eg. Fastethernet0/0)

Try no ip cef

-Try tunnel path-mtu-discovery on tunnel0

-Try crypto ipsec df-bit clear

-crypto ipsec fragmentation before-encryption

New Member

Re: FTP Transfert Failed

I have turn on the passive mode but without result.

Unexepected thing that occur, I could connect from all machines in my LAn but one (My machine) could make FTP transfert without any probl?me.

In fact I have one PIX 501,All machines can transfert toward the same FTP server without any prob and from any machines.When I migrate the same configuration to cisco 837, I this problem (Failed transfert FTP)occur.

If any one want cisco 837 for check,I could share It.

any idea?I am so stressed.

Thanks in advance.

New Member

Re: FTP Transfert Failed

Try the executable "SetMTU.exe" that came with the Cisco VPN Client, to set you MTU very low on both end node. If that doesn't solve the issue, you told that you have tried to turn on the passive mode, but have you tried to turn it on on both side ? (I mean that some ftp server doesn't permit to use passive mode.

To check if is a MTU issue, most of the time I do a ping (in DOS) with the option -l [size] and -f (Don't fragment). Then I change the size until the icmp packet is not fragmented. You will be able to see what's the maximum packet size that you can send.

132
Views
0
Helpful
3
Replies
CreatePlease login to create content