Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Integration of CSM with ACS

Dear,

   I am using csm 3.3.0 and ACS 4.2. I followed all of the procedure for integrating csm with ACS according to cisco document.But when i applying in CSM it is showing that AAA client is not configured.But actually i registered CSM Server as AAA client in ACS.Please provide me some way to trouble shoote this problem..

Thanks in advanse..

3 REPLIES
Cisco Employee

Re: Integration of CSM with ACS

Hello,

You could try and check few things

Is the CSM server contained within a Network Device Group in ACS?  
Which shared secret key are you specifying within Common Services' AAA Mode 
Setup?  ACS uses the shared secret defined at the GROUP level rather than the 
one defined at the device level.

Restart daemon manager 

Go to ACS' Shared Profile Components and check to see if the default 
user roles are registered for Ciscoworks Common Services and Cisco Security 
Manager.  Also click on one of the default user roles to see if the permissions 
display or you receive an error.  Check the ACS Reports and Log for TACACS+ 
Administration and Failed Attempts.

Hope this helps.

Thanks,

--Sunil

Community Member

Re: Integration of CSM with ACS

Dear Sunil.

               Thanks for your valuable reply.Accrding to your suggession i checked everything and still it is not solved.I am follwing the results

1.I am using same shared key foe NDG and CSM,I am using user csmadmin in CSM and i created this user  in ACS as administrator

2.I am not seen any Defualt user in ACS shared components.Only the following  options are there.

       1)Radius authorisation component

       2)Network Access Restrictions

       3)Shell Command Authorisation sets

      4)PIX/ASA Command authorisaion sets

Also i tried restating daemon service.

Based on this result plese help me to resolve this problem..

Thanks and Regards

Naisamuddin Pk

Community Member

Integration of CSM with ACS

Hi,

Just had the exact same problem with CSM 4.1 and ACS 4.2.1, problem was the Windows Firewall on the ACS server preventing the CSM server connecting fully to the HTTP/HTTPS interface of ACS.


Regards

Mike

605
Views
0
Helpful
3
Replies
CreatePlease to create content