Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

LMS25 / Common Services 3.0 problem (dbpasswd.pl doesn't work)

Hi.

During CS3.0 installation I got an error:

ERROR: Unable to Change password for DSN cmf

ERROR: After install you can change the database password

ERROR: by running /opt/CSCOpx/bin/dbpasswd.pl

I tried to run /opt/CSCOpx/bin/dbpasswd.pl script, but got error again:

bash-2.03# /opt/CSCOpx/bin/dbpasswd.pl all

Please enter the new password for database cmf:

Please enter the new password again for verification:

INFO: Start changing password for database 'cmf'...

Starting database engine cmfEng

ld.so.1: perl: fatal: relocation error: file /opt/CSCOpx/objects/db/lib/libdblib9.so.1: symbol UnixForkProtection_Init: referenced symbol not found

Killed

I tried to set up LD_LIBRARY_PATH, tried to remove .profile, tried even to install solaris 8 from the scratch. It doesn't work even on fresh installation with 8_Recommended and all required Solaris patches. I tried also different installation disks with May 05 patches and without.

ldd doesn't show anything strange:

bash-2.03# ldd /opt/CSCOpx/objects/db/lib/libdblib9.so.1

libdbtasks9.so.1 => /opt/CSCOpx/objects/db/lib/libdbtasks9.so.1

librt.so.1 => /usr/lib/librt.so.1

libnsl.so.1 => /usr/lib/libnsl.so.1

libdl.so.1 => /usr/lib/libdl.so.1

libc.so.1 => /usr/lib/libc.so.1

libxnet.so.1 => /usr/lib/libxnet.so.1

libm.so.1 => /usr/lib/libm.so.1

libaio.so.1 => /usr/lib/libaio.so.1

libmp.so.2 => /usr/lib/libmp.so.2

/usr/platform/SUNW,Sun-Fire-V440/lib/libc_psr.so.1

libsocket.so.1 => /usr/lib/libsocket.so.1

bash-2.03#

We have same LMS 2.5 on another server ( same model, same operating system, same patches) and it looks fine.

Could somebody explain how to debug and solve this issue?

2 REPLIES
New Member

Re: LMS25 / Common Services 3.0 problem (dbpasswd.pl doesn't wor

Hi.

Also /opt/CSCOpx/selftest/database.pl didn't work with same error message.

I found the cause of problem. I have reproduced this error in test environment. The problem was in 8_Recommended patch cluster for Solaris 8. Patch cluster downloaded in September doesn't cause any errors, but after new patch cluster installing ( late October) CiscoWorks stops working. The reason for it is 109147-39 patch ( linker patch for Solaris). Older version 109147-37 doesn't cause an error in database manipulation. It is enough to run roll back this patch and 2 patches depended on it ( 108652-92, 108773-19). So command "patchrm 108652-92;patchrm 108773-19;patchrm 109147-39" solves the problem.

New Member

Re: LMS25 / Common Services 3.0 problem (dbpasswd.pl doesn't wor

Hi Gtimonen,

I am in the process of installation of CiscoWorks 2000 LMS 2.5. Could you please let me know what are the patches required for successful installation on solaris 2.8. I am working in a environment where application installation team is different from OS installation. It will be greatly helpful. Also please let me know the 'Admin' user which is created while installating CiscoWorks can be changed to some other user name or not. Please help me out asap. I am having a tough time with ops team.

Thanks in advance and points will be awarded.

Regards

James

143
Views
4
Helpful
2
Replies
CreatePlease to create content