cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión

¿como puedo crear subinterfaces en un router cisco 887va para el modo trunk?

tengo un router 887va y quiero crear subinterfaces para poder ponerlo en modo trunk.

alguien me podria ayudar?

3 RESPUESTAS
Cisco Employee

Hola que tal Juan Carlos!

Hola que tal Juan Carlos!

Para crear subinterfaces en una interfaz lo único que tienes que utilizar es este comando.

Interface FastEthernet0/0.1

Encapsulation dot1q 10      (donde el 10 representa la VLAN 10 )

IP address 192.168.10.1 255.255.255.0

y así sucesivamente por cada vlan que desees que participe como subinterfaz.

Saludos cordiales.

Community Member

Re: ¿como puedo crear subinterfaces en un router cisco 887va para el modo trunk?

Hola

 

Para crear las sub interfaces puedes usar estos comandos.

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1.10

encapsulation dot1Q 10 (vlan id)

ip address 192.168.10.254 255.255.255.0

ip nat inside

!

interface GigabitEthernet0/1.20

encapsulation dot1Q 20 (vlan id)

ip address 192.168.20.254 255.255.255.0

ip nat inside

!

interface GigabitEthernet0/1.30

encapsulation dot1Q 30 (vlan id)

ip address 192.168.30.254 255.255.255.0

ip nat inside

 

 

Espero que te sirva.

Spotlight January 2018 Silver

Re: ¿como puedo crear subinterfaces en un router cisco 887va para el modo trunk?

Para complementar la informacion ya dada, el modo en el cual un router es configurado con subinterfaces para manejar diferentes Vlan se denomina Router on a stick. te dejo la siguiente informacion que espero ayude a aclarar tus dudas

 

El ROUTER ON A STICK, es una de las dos posibilidades más comunes de hacer el enrutamiento inter-VLAN.

Consiste en crear sub interfaces en una sola interface física de un router.

Tenemos con esta configuración la posibilidad de utilizar una sola interface para enrutar los paquetes de varias VLAN que viajan a través del puerto trunk de un switch conectado a esa interface.

No sabes que es un TRUNK? Clique acá.

Podemos así configurar varias IP de diferentes redes a varias interfaces virtuales (sub-interfaces) alojadas en una sola interface física.

Salimos un poco del enrutamiento básico, que es en general lo que aprendemos primero, y tiene una única red conectada a cada interface del router.

Ventajas del ROUTER ON A STICK

Fácil de implementar solo se requiere crear una subinterfaz por cada VLAN en el Router.

Mucho más económica que tener un Router por VLAN.

Mucha mejor latencia que tener un Router por VLAN.

Quieres entender lo que es una VLAN? Marca acá.

Desventajas del ROUTER ON A STICK

Los Routers son más lentos que los switches para ruteo inter-VLAN, lo ideal es tener un switch multicapa.

Si se necesita incrementar el número de puertos, entre más puertos requiera un Router más costoso resulta.

Estamos expuestos al buen funcionamiento de una sola interfaz física en el Router, esto es un único punto de fallo.

Ejemplo de ROUTER ON A STICK

Tenemos el siguiente rango de IP para cada VLAN:

VLAN 10 – 192.168.10.0/24

VLAN 20 – 192.168.20.0/24

VLAN 30 – 192.168.30.0/24

Abajo tenemos la un mapa de la infraestructura de red.

ROUTER ON A STICK

Primer paso:

Configuramos el puerto del SWITCH que se conecta al ROUTER lo habilitaremos como troncal.

En el SWITCH tenemos las siguientes líneas de comandos

SWITCH# configure Terminal

SWITCH (config)# interface fastEthernet 0/1

SWITCH (config-if)# switchport mode trunk

SWITCH (config-if)# no shutdown

Segundo paso:

Ahora tendremos que configurar las interfaces del ROUTER con las IP de cada VLAN asociadas a los puertos del SWITCH.

En el ROUTER tenemos las siguientes líneas de comandos:

ROUTER (config)# interface fastEthernet 0/0.10

ROUTER (config-if)#encapsutation dot1q 10

ROUTER (config-if)# ip address 192.168.10.1 255.255.255.0

ROUTER (config)# interface fastEthernet 0/0.20

ROUTER (config-if)#encapsutation dot1q 20

ROUTER (config-if)# ip address 192.168.20.1 255.255.255.0

ROUTER (config)# interface fastEthernet 0/0.30

ROUTER (config-if)# encapsutation dot1q 30

ROUTER (config-if)# ip address 192.168.30.1 255.255.255.0

Tercer paso.

Levantar la interfaz del ROUTER fastEthernet 0/0

ROUTER (config-)# interface fastEthernet 0/0

ROUTER (config-if)# no shutdown

ROUTER (config-if)# do write

Finalizada esta configuración las diferentes VLANS se podrán comunicar.

877
Visitas
0
ÚTIL
3
Respuestas
CrearPor favor para crear contenido