cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
New Member

Problemas_Regex_Bloqueando-extensiones

   Buenas queria solicitar ayuda con los comandos regex y MPF, revise el paper de cisco:

http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a0080940e04.shtml

Donde se explica como bloquear extensiones de archivos via http. Utilice el documento para intentar bloquear extensiones y me funciono, pero no solo bloqueo las extensiones solicitadas sino  cualquier pagina que tuviese link de descarga. Por favor podrían ayudarme a entender como bloquear extensiones especificas. Muchas gracias.

La configuracion del equipo es como sigue:

ASA Version 8.0(2)

!

hostname ciscoasa

enable password 8Ry2YjIyt7RRXU24 encrypted

names

!

interface Ethernet0/0

nameif outside

security-level 0

ip address dhcp setroute

!

interface Ethernet0/1

nameif inside

security-level 100

ip address 192.168.1.1 255.255.255.0

!

interface Ethernet0/2

shutdown

no nameif

no security-level

no ip address

!

interface Ethernet0/3

shutdown

no nameif

no security-level

no ip address

!

interface Ethernet0/4

shutdown

no nameif

no security-level

no ip address

!

interface Ethernet0/5

shutdown

no nameif

no security-level

no ip address

!

passwd 2KFQnbNIdI.2KYOU encrypted

regex urllist1 ".*\.([Dd][Oo][Cc]|[Tt][Oo][Rr][Rr][Ee][Nn][Tt])"

regex applicationheader "application/.*"

regex contenttype "Content-Type"

ftp mode passive

access-list palabras-bloqueadas extended permit ip 192.168.1.0 255.255.255.0 any

pager lines 24

logging console warnings

mtu outside 1500

mtu inside 1500

no failover

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 192.168.1.0 255.255.255.0

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout uauth 0:05:00 absolute

dynamic-access-policy-record DfltAccessPolicy

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

no crypto isakmp nat-traversal

telnet timeout 5

ssh timeout 5

console timeout 0

threat-detection basic-threat

threat-detection statistics access-list

!

class-map type regex match-any URLBlockList

match regex urllist1

class-map default

match default-inspection-traffic

class-map type inspect http match-all AppHeaderClass

match response header regex contenttype regex applicationheader

class-map httptraffic

match access-list palabras-bloqueadas

class-map type inspect http match-all BlockURLsClass

match request uri regex class URLBlockList

!

!

policy-map type inspect http http_inspection_policy

parameters

  protocol-violation action drop-connection

class AppHeaderClass

  drop-connection log

match request method connect

  drop-connection log

class BlockURLsClass

  reset log

policy-map global

class default

  inspect icmp

policy-map inside-policy

class httptraffic

  inspect http http_inspection_policy

!

service-policy global global

prompt hostname context

Cryptochecksum:3568848c71f3a4efc0d328007bda614c

: end

Etiquetas (2)
1 RESPUESTA
Cisco Employee

Problemas_Regex_Bloqueando-extensiones

Hola,

Quisiera saber si el bloqueo funciona correctamente despues de remover el class AppHeaderClass del

policy-map type inspect http http_inspection_policy .

Intenta esta prueba e informanos del resultado.

Saludos,

Itzcoatl Espinosa

582
Visitas
0
ÚTIL
1
Respuestas
CrearPor favor para crear contenido