Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Highlighted
New Member

Activation failed for B200 M4 7.0 board controller firmware with UCS Mini 3.0(2c)

The B200 M4 blades shipped with 7.0 board controller firmware and the UCS Mini shipped with the latest 3.0(2c) code.  Once a Service Profile is associated, the activation of the 7.0 board controller firmware fails.  The 3.0(2c) blade firmware package ships with 6.0 board controller firmware.  I uploaded the 2.2(5a) blade server firmware package in order for the UCS to "see" the 7.0 firmware.  I then modified a 3.0(2c) host firmware package to include the 7.0 board controller firmware for the B200 M4 but activation still fails after acknowledging the reboots.  Reacknowledging the blades doesn't change the outcome.  Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Michael,You have done the

Michael,

You have done the right thing by adding 2.2.5a firmware package.

Did you perform the activate from CLI?

#scope server X/Y (chassis X blade Y)
# scope boardcontroller
# show image (this will list all of the firmware versions)
# activate firmware version.0 force (Select a lower version than the one already running)
# commit-buffer

If the above is successful then reset CIMC

You may try --->

In the host firmware policy do not check board controller for this B200M4 leave it blank. Then manually activate it from installed firmware tab in server.

Regards,

Saurabh

10 REPLIES
Cisco Employee

Michael,You have done the

Michael,

You have done the right thing by adding 2.2.5a firmware package.

Did you perform the activate from CLI?

#scope server X/Y (chassis X blade Y)
# scope boardcontroller
# show image (this will list all of the firmware versions)
# activate firmware version.0 force (Select a lower version than the one already running)
# commit-buffer

If the above is successful then reset CIMC

You may try --->

In the host firmware policy do not check board controller for this B200M4 leave it blank. Then manually activate it from installed firmware tab in server.

Regards,

Saurabh

New Member

Hi -I have the same issue.

Hi -

I have the same issue. The UCMS and environment is running 2.23d. I put in a couple B-200 M4 blades and notice that the board controller failed. for activation.

 

I attempted the CLI commands above with the following results:

ucs-A /chassis/server/boardcontroller* # activate firmware ucs-b200-m4-brdprog.5.0.bin force
Warning: When committed this command will reset the end-point
ucs-A /chassis/server/boardcontroller* # commit-buffer
Error: Update failed: [Unable to find BoardController Image for vendor Cisco Systems Inc, Model UCSB-B200-M4 and version ucs-b200-m4-brdprog.5.0.bin]
ucs-A /chassis/server/boardcontroller* #

 

As you can see the image is there:

ucs-A /chassis/server/boardcontroller* # show image
Name                                          Type                 Version
--------------------------------------------- -------------------- -------
ucs-b200-m3-brdprog.13.0.bin                  Board Controller     13.0
ucs-b200-m3-brdprog.8.0.bin                   Board Controller     8.0
ucs-b200-m4-brdprog.5.0.bin                   Board Controller     5.0
ucs-b200-m4-brdprog.7.0.bin                   Board Controller     7.0
ucs-b22-m3-brdprog.14.0.bin                   Board Controller     14.0
ucs-b22-m3-brdprog.3.0.bin                    Board Controller     3.0
ucs-b230-m1-pld.B230100D.bin                  Board Controller     B230100D
ucs-b230-m2-pld.B230100D.bin                  Board Controller     B230100D
ucs-b250-m1-pld.111026-111026.bin             Board Controller     111026-111026
ucs-b420-m3-brdprog.10.0.bin                  Board Controller     10.0
ucs-b420-m3-brdprog.3.0.bin                   Board Controller     3.0
ucs-b440-m1-pld.B440100C-B4402006.bin         Board Controller     B440100C-B4402006
ucs-b440-m2-pld.B440100C-B4402008.bin         Board Controller     B440100C-B4402008
ucs-EXM4-1-brdprog.4.0.bin                    Board Controller     4.0
ucs-EXM4-1-brdprog.5.0.bin                    Board Controller     5.0

 

Thoughts? Hints or tips?

 

 

New Member

I am using 2.2(3c) and have

I am using 2.2(3c) and have same issue. This is confirmed by my TAC case engineer as no production impact so you can ignore this error messages although I personally hate to see this under major alarm in UCSM. I cannot upgrade UCSM due to third party compatibility list (storage vendor). Hope this info relieves you.

 

Robin

New Member

@robin99 -thanks for the note

@robin99 -

thanks for the note. Yes I hate having that error reporting as well. I went ahead and opened a case with a tac so will see what happens.

 

Also you mentioned you cant update at this time due to storage. What storage are you using that is holding you back?

New Member

I am using NetApp in this

I am using NetApp in this case but in my other project with EMC storage, there is also recommendation/ tested reference design so the best to to check with your storage vendor too for the UCS version compatibility. cheers

New Member

@robin.thanks for the note.My

@robin.

thanks for the note.

My issues was resolved! Here are the steps and perhaps this may help someone out there. (I think you had a tac that may have been lazy) :)

 

as for storage I too am using NetApp with no issues running Clustered Ontap.

 

Resolution:

 

UCSM: 2.2(3d)

 

server 2/1, 2/2 : Board Controller: 7

server 2/3, 2/4 : Board Controller: 9

 

+ All the board controller were in ""Failed"" mode

 

+ Force activate the BC Firmware on Server 2/1 and 2/2 (Error clears up)

 

+ On server 2/4 were unable to force active the BC (Since we don't have the firmware B-series bundle 2.2(5))

 

+ Downloaded the 2.2(5)-B bundle and upload it on UCSM

 

+ Force activate the firmware on server 2/4 and error got clear

 

+ SD cards on server 2/1, 2/2 (B200 M4) were showing foreign config.

 

+ Format the SD cards and that clears up the error

 

+ Created SP template "Windows_Service_Profile_B200M4"

 

+ Created Host Firmware Package "B200M4_2.2.3d" with Board Controller firmware unchecked

 

+ Change the binding of SP for server 2/3 and 2/4 with "Windows_Service_Profile_B200M4"

 

+ All the servers are up without any errors

 

+ We were also getting FlexFlash FFCH_ERROR_OLD_FIRMWARE_RUNNING

 

+ Reset the flex-flash controller clear the errors

 

New Member

@petelanzoneGood on you to

@petelanzone

Good on you to have firmware 2.2(5) which is not applicable to my case. With my client, I cannot do more server maintenance for next few months.

New Member

Thanks, Saurabh. The "force"

Thanks, Saurabh. The "force" option worked to activate the 7.0 firmware.  I tried via the CLI eariler but without the force option and it didn't work, so thanks for the tip. I also had to remove the firmware policy in order to commit the change.  Once activated, though, I could re-add the firmware policy.

Cisco Employee

Thanks a lot Michael.Happy to

Thanks a lot Michael.

Happy to help :)

Cisco Employee

Hello ,Board controller

Hello ,

In addition, board controller firmware can be running at higher level than other blade server firmware package.

It is fully supported to have higher version of board controller firmware i.e when new blades are shipped with higher version of board controller firmware but blade firmware has to be downgraded to match existing UCS Infra version.

These faults got generated as 3.0.2 package had 6.0 while blade had 7.0 version.

In upcoming release, UCSM fault will be removed in future release via CSCuu15465 as downgrade of board controller firmware is NOT supported.

[EDIT] After reading it again, the force option was used to activate to higher version.

Thanks

Padma

 

8345
Views
10
Helpful
10
Replies
CreatePlease login to create content