Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Connect Nexus 5548UP-L3 to Catalyst 3750G-24T-E Layer 3 Switch

Please help!

Could anyone out there please assist me with basic configuration between Nexus Switch and Catalyst Switch, so that devices connected on the catalyst switch can talk to devices connected on nexus switch and vice-versa? In my current setup all servers on VLAN 40 are connected on the Catalyst Switch A as shown in the diagram below, and all desktops and all other peripherals are connected on the Catalyst Switch B.  I am required to implement/add a new Nexus Switch 5548 that in the future will replace the Switch A. From now I just need to connect both switches together and start moving the server from Switch A to the Nexus Switch.

The current network setup is shown as per diagram below:

  1. SWITCH A – this is a layer 3 switch. All servers are connected to this switch on the VLAN 40.
  2. SWITCH B – all desktops, VoIP telephones, and printers are connected on tis switch. This switch is also a layer 3 switch.

design01.jpg

I have connected together the Nexus 5548UP and SWITCH A (3750G) using the GLC-T= 1000BASE-T SFP transceiver module for Category 5 copper wire. The new network is shown as per diagram below:

design02.jpg

Below is the configuration I have created in both Switches:

SWITCH A - 3750G

interface Vlan40

description ** Server VLAN **

ip address 10.144.40.2 255.255.255.128

ip helper-address 10.144.40.39

ip helper-address 10.144.40.40

!

interface Vlan122

description connection to N5K-C5548UP Switch mgmt0

ip address 172.16.0.1 255.255.255.128

no ip redirects

!

interface Port-channel1

description UpLink to N5K-C5548UP Switch e1/1-2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,30,40,100,101,122

switchport mode trunk

!

interface GigabitEthernet1/0/3

description **Connected to server A**

switchport access vlan 40

no mdix auto

spanning-tree portfast

!

interface GigabitEthernet1/0/20

description connection to N5K-C5548UP Switch mgmt0

switchport access vlan 122

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/23

description UpLink to N5K-C5548UP Switch e1/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,30,40,100,101,122

switchport mode trunk

channel-group 1 mode active

!

interface GigabitEthernet1/0/24

description UpLink to N5K-C5548UP Switch e1/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,30,40,100,101,122

switchport mode trunk

channel-group 1 mode active

N5K-C5548UP Switch

feature interface-vlan

feature lacp

feature dhcp

feature lldp

vrf context management

  ip route 0.0.0.0/0 172.16.0.1

vlan 1

vlan 100

service dhcp

ip dhcp relay

interface Vlan1

  no shutdown

interface Vlan40

  description ** Server VLAN **

  no shutdown

  ip address 10.144.40.3/25

  ip dhcp relay address 10.144.40.39

  ip dhcp relay address 10.144.40.40

interface port-channel1

  description ** Trunk Link to Switch A g1/0/23-24 **

  switchport mode trunk

  switchport trunk allowed vlan 1,30,40,100-101,122

  speed 1000

interface Ethernet1/1

  description ** Trunk Link to Switch A g1/0/23**

  switchport mode trunk

  switchport trunk allowed vlan 1,30,40,100-101,12

  speed 1000

  channel-group 1 mode active

interface Ethernet1/2

  description ** Trunk Link to Switch A g1/0/24**

  switchport mode trunk

  switchport trunk allowed vlan 1,30,40,100-101,122

  speed 1000

  channel-group 1 mode active

interface Ethernet1/3

  description **Connected to server B**

  switchport access vlan 40

  speed 1000

interface mgmt0

  description connection to Switch A g2/0/20

  no ip redirects

  ip address 172.16.0.2/25

I get a successful response from Server A when I ping the N5K-C5548UP Switch (VLAN 40 interface (10.144.40.3) .But if I try to ping from Server A to Server B or vice-versa the ping fails. From N5K-C5548UP I can ping successful either Server A or Server B. What am I doing wrong here? Is there any additional configuration that I need to add on the Nexus Switch? Please Help. Thank you.

  • Server Networking
Everyone's tags (2)
5 REPLIES
Bronze

Re: Connect Nexus 5548UP-L3 to Catalyst 3750G-24T-E Layer 3 Swit

Interesting ...

1) can you clear arp cache on the server A: arp -d

2) ping the server B (10.144.40.4)

3) is there a record of arp entry for the 10.144.40.4: arp -a

If no... Hmmm... It looks as if there any broadcast (arp) suppression on the Nexus?!

Is it possible to add a static arp entry 10.144.40.4 on the server A or switch A and try ping server B again from server A or switch A?

New Member

Connect Nexus 5548UP-L3 to Catalyst 3750G-24T-E Layer 3 Switch

Hi aukhadiev,

Sorry for my late reply. I have solved the problem. Thank you.

Bronze

Connect Nexus 5548UP-L3 to Catalyst 3750G-24T-E Layer 3 Switch

...if it is no secret what was wrong?

New Member

Connect Nexus 5548UP-L3 to Catalyst 3750G-24T-E Layer 3 Switch

no, no secret aukhadiev

I made a mistake without realising and the interface e1/3 was showing "Interface Ethernet1/3 is down (Inactive)". After spending sometime trying to figure out what was wrong with that interface or switch, it turned out to be that i forgot to add the vlan 40. Now the config looks like this:

N5K-C5548UP Switch

feature interface-vlan

feature lacp

feature dhcp

feature lldp

vrf context management

  ip route 0.0.0.0/0 172.16.0.1

vlan 1

vlan 40

vlan 100

service dhcp

ip dhcp relay

interface Vlan1

  no shutdown

interface Vlan40

  description ** Server VLAN **

  no shutdown

  ip address 10.144.40.3/25

  ip dhcp relay address 10.144.40.39

  ip dhcp relay address 10.144.40.40

interface port-channel1

  description ** Trunk Link to Switch A g1/0/23-24 **

  switchport mode trunk

  switchport trunk allowed vlan 1,30,40,100-101,122

  speed 1000

interface Ethernet1/1

  description ** Trunk Link to Switch A g1/0/23**

  switchport mode trunk

  switchport trunk allowed vlan 1,30,40,100-101,12

  speed 1000

  channel-group 1 mode active

interface Ethernet1/2

  description ** Trunk Link to Switch A g1/0/24**

  switchport mode trunk

  switchport trunk allowed vlan 1,30,40,100-101,122

  speed 1000

  channel-group 1 mode active

interface Ethernet1/3

  description **Connected to server B**

  switchport access vlan 40

  speed 1000

interface mgmt0

  description connection to Switch A g2/0/20

  no ip redirects

  ip address 172.16.0.2/25

Thank you,

JN

Bronze

Connect Nexus 5548UP-L3 to Catalyst 3750G-24T-E Layer 3 Switch

Thank you for the info... simple, when all explained

1806
Views
0
Helpful
5
Replies