Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Bronze

DHCP

i'm configuring the ip helper-address command in order for the remote site users get an IP address. The DHCP server is located at the HQ. Let us say that the WAN link down, and a new user wants to get an IP address, since the WAN link is down, this new PC will not get an IP address.

I'm thinking to have a local pool configured at this remote site gateway "router". Now my question is, can we make the first option is make this router as a relay "ip helper-address command", now if that DHCP server in unavailable let the IOS take the DHCP server responsibility "as a second option"? and i think it will be better if the IOS gets the DHCP server options locally while the server is alive, and take its responsibilites when the DHCP server is down.

Thanks in advance

Abd Alqader

3 REPLIES
New Member

Re: DHCP

if you can't find anything better, you could always try this.

set the dhcp pool up on the router as usual along with the ip-helper address for your dhcp server at HQ, but add something like this:

ip dhcp ping packets 10

ip dhcp ping timeout 1000

this should result in a 10 second delay before the router will assign any addresses from its pool, which is plenty of time for your server to respond, if it can.

New Member

Re: DHCP

Its a v good sujestion but what whould be the configuration at router regarding DHCP pool.....like what would be in ip helper command just the HQ server ot the router server if u can please put the conf....cheers

Bronze

Re: DHCP

Thank you. But i did the following but still get the IP from the pool.

===========

ip dhcp ping packets 10

ip dhcp ping timeout 1000

!

ip dhcp pool test22

import all

network 10.30.30.0 255.255.255.0

default-router 10.30.30.1

dns-server 1.1.1.1 2.2.2.2

domain-name Pool_IOS.com

!

!

interface FastEthernet0/0

ip address 10.30.30.1 255.255.255.0

ip helper-address 10.238.238.10

duplex auto

speed auto

!

==================

I have another question, i did the following before your input:

==================

!

ip dhcp pool test33

relay source 10.30.30.0 255.255.255.0

relay destination 10.238.238.10

!

!

interface FastEthernet0/0

ip address 10.30.30.1 255.255.255.0

ip helper-address 10.238.238.10

duplex auto

speed auto

!

What happened, the first time get the IP from the DHCP server "10.238.238.10", now i deactivated this scope at the server. i get an IP address "the server is down" with the required parameters "it seems that the IOS downloads the required parameters from the server". but the problem is when i repeat the test again "when the server is down", it is failed i don't know. it seems this is success for the first time!

Thanks

Abd Alqader

144
Views
4
Helpful
3
Replies