Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

DLSw Backup Problem with two connection to the IBM Host

Hello EveryOne,

I'm Mostafa Chakir from morroco, Project engineer for a DLSw Installation using four Cisco boxes.

In the central site, we are installing two cisco routers for IBM Host attachement with CPA Card, and the two others are used for WAN connection to remote sites.

********************************

# IBM Host #

********************************

| |

********* ***********

# CPA1# # CPA2 #

********* ***********

| |

----------------------------------------------

| |

********* ***********

# WAN1# # WAN2 #

********* ***********

The remotes sites are connected to the WAN1 and WAN2 (50%, 50%) via FR network, and backuped with ISDN links.

All the connections from the central site ( SNA LAN connection with software emulation) are connected to CPA1, trough the DLSw peer between WAN routers and CPA1.

The remotes SNA connection from the remotes sites are connected to the CPA2, trough the DLSw peer between each remote site router and CPA2 with backup peer to the CPA1.

The Problem is :

In the remote site, sometime the fr link and the backup link can have some problem at the same time, the router always try to open a DLSw peer to the CPA2, after the timeout coded in the configuration, the router try to open a DLSw peer to the CPA1 ( the backup peer), after 15 seconds it will try with the primary peer again, after that it will try to the backup peer, and so on.

When the fr link or ISDN link comes up exactly when the router try the backup peer (CPA1), the IBM host don't accept it, and the router stay trying openning the DLSw peer with the CPA1. The IBM Host don't have any information that the remote site are down, and when we look in the IBM host we find that the remote site is connected to the CPA2, so i think the CPA2 give no information about the remote site when it is disconnected to the IBM Host.

Here is the configuration of the routers :

CPA2 :

source-bridge ring-group 2200

dlsw local-peer peer-id 2.2.2.2 keepalive 0 promiscuous

dlsw icanreach mac-exclusive

dlsw icanreach mac-address 4000.0e02.7206 mask ffff.ffff.ffff

dlsw icanreach mac-address 4000.0e13.7206 mask ffff.ffff.ffff

!

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface FastEthernet0/0

ip address 192.168.6.2 255.255.255.248

duplex full

speed 100

!

interface Channel1/0

ip address 130.114.2.3 255.255.255.0 secondary

ip address 130.114.1.3 255.255.255.0

no ip redirects

no ip route-cache cef

no ip mroute-cache

no keepalive

llc2 dynwind

claw 0122 32 130.114.2.1 DEVL WCPA2 TCPIP TCPIP

claw 0111 22 130.114.1.1 PROD WCPA2 TCPIP TCPIP

csna 0111 20 maxpiu 65535 length-delay 0

csna 0122 30 maxpiu 65535 length-delay 0

max-llc2-sessions 1024

lan TokenRing 2

source-bridge 1100 1 2200

adapter 2 4000.0e02.7206

adapter 3 4000.0e13.7206

CPA1 :

source-bridge ring-group 2000

dlsw local-peer peer-id 1.1.1.1 keepalive 0 promiscuous

dlsw icanreach mac-exclusive

dlsw icanreach mac-address 4000.0e02.7206 mask ffff.ffff.ffff

dlsw icanreach mac-address 4000.0e13.7206 mask ffff.ffff.ffff

!

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet0/0

ip address 192.168.6.1 255.255.255.248

duplex full

speed 100

!

interface Channel1/0

ip address 130.114.2.2 255.255.255.0 secondary

ip address 130.114.1.2 255.255.255.0

no ip redirects

no ip mroute-cache

no keepalive

llc2 dynwind

claw 0122 12 130.114.2.1 DEVL WCPA1 TCPIP TCPIP

claw 0111 02 130.114.1.1 PROD WCPA1 TCPIP TCPIP

csna 0111 00 maxpiu 65535 length-delay 0

csna 0122 10 maxpiu 65535 length-delay 0

max-llc2-sessions 1024

lan TokenRing 1

source-bridge 1000 1 2000

adapter 0 4000.0e02.7206

adapter 1 4000.0e13.7206

WAN1 :

dlsw local-peer peer-id 3.3.3.3 keepalive 0

dlsw remote-peer 0 tcp 1.1.1.1 timeout 90

dlsw remote-peer 0 tcp 2.2.2.2 backup-peer 1.1.1.1 timeout 90 linger 5

dlsw cache-ignore-netbios-datagram

dlsw bridge-group 1

!

controller E1 2/0

pri-group timeslots 1-31

!

controller E1 2/1

framing NO-CRC4

pri-group timeslots 1-31

!

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

!

interface FastEthernet0/0

ip address 128.114.100.101 255.255.0.0

duplex full

speed 100

standby 1 timers 1 3

standby 1 priority 120

standby 1 mac-address 7206.7206.7206

standby 1 ip 128.114.100.100

bridge-group 1

bridge-group 1 input-lsap-list 200

!

interface FastEthernet0/1

ip address 192.168.6.3 255.255.255.248

duplex full

speed 100

WAN2 :

dlsw local-peer peer-id 4.4.4.4 keepalive 0

dlsw remote-peer 0 tcp 1.1.1.1 timeout 90

dlsw remote-peer 0 tcp 2.2.2.2 backup-peer 1.1.1.1 timeout 90 linger 5

dlsw cache-ignore-netbios-datagram

dlsw bridge-group 1

!

controller E1 2/0

pri-group timeslots 1-31

!

controller E1 2/1

framing NO-CRC4

pri-group timeslots 1-31

!

!

interface Loopback0

ip address 4.4.4.4 255.255.255.255

!

interface FastEthernet0/0

ip address 128.114.100.102 255.255.0.0

ip route-cache flow

duplex full

speed 100

standby 1 timers 1 3

standby 1 priority 110

standby 1 mac-address 7206.7206.7206

standby 1 ip 128.114.100.100

bridge-group 1

bridge-group 1 input-lsap-list 200

!

interface FastEthernet0/1

ip address 192.168.6.4 255.255.255.248

duplex full

speed 100

REMOTE SITE :

dlsw local-peer peer-id 192.1.171.100 keepalive 0

dlsw remote-peer 0 tcp 2.2.2.2 timeout 90

dlsw remote-peer 0 tcp 1.1.1.1 backup-peer 2.2.2.2 timeout 90 linger 5

dlsw bridge-group 1

!

!

interface Ethernet0/0

ip address 192.1.171.100 255.255.255.0

half-duplex

bridge-group 1

bridge-group 1 input-address-list 700

bridge-group 1 input-lsap-list 200

!

!

interface Serial0/0

no ip address

encapsulation frame-relay

!

interface Serial0/0.1 point-to-point

ip address 10.1.171.1 255.255.255.252

frame-relay interface-dlci 497

!

interface BRI0/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

!

interface Dialer1

ip address 172.16.0.171 255.255.0.0

encapsulation ppp

dialer pool 1

dialer string 022430016

dialer string 022262550

dialer-group 1

ppp authentication chap

ppp chap hostname OASIS171

ppp chap password 7 08234F43

!

router eigrp 2

network 10.0.0.0

network 172.16.0.0

network 192.1.171.0

auto-summary

no eigrp log-neighbor-changes

!

ip route 0.0.0.0 0.0.0.0 Dialer1 200

!

access-list 101 deny icmp any any

access-list 101 deny eigrp any any

access-list 101 permit tcp any any eq 2065

access-list 101 permit udp any any eq 2065

access-list 101 permit udp any any eq 2067

access-list 200 permit 0x0000 0x0D0D

access-list 200 deny 0x0000 0xFFFF

access-list 700 permit 0007.1823.e1d9 0000.0000.0000

access-list 700 permit 00e0.18c4.879b 0000.0000.0000

access-list 700 deny 0000.0000.0000 0000.0000.0000

dialer-list 1 protocol ip list 101

!

!

bridge 1 protocol ieee

!

!

Thank you for your ideas.

2 REPLIES
Bronze

Re: DLSw Backup Problem with two connection to the IBM Host

You can use the LINGER=0 parameter on the BACKUP peer to force it to tear down the backup peer and reestablish all the circuits with the primary peer as soon as it comes up. That might help you in this situation.

New Member

Re: DLSw Backup Problem with two connection to the IBM Host

Hallo,

Fist Thank you for your response.

In the remote site router, i can't use LINGER=0, cause the IBM host don't accept the demand of this remote site via the second link with the CPA1 router, it still see the IDNUM IDBLOCK active via the CPA2 router.

I think that i must change the Keepalive parameter in the CPA1 and CPA2 router to 10s or more, cause i coded keepalive0 in the remotes sites to stop the DLSw keepalive via ISDN if the primary link goes down, but the CPA2 router have no isdn connection.

My question stay : if the CPA2 router have no information from the remote site (after the keepalive expires), the IBM Host will clear the IDNUM IDBLOCK for this remote site or NOT??

I'm not a DLSw expert, for that raison i have some questions without response. Thank you for your response another time.

219
Views
0
Helpful
2
Replies
CreatePlease to create content