Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

DLSw problem whith two connection to the host

Hello every one,

My name's Mostafa CHAKIR,I am a technical ingeneer in the CBI Networks Morocco.

We have a dual connection to a IBM Host via two 7206 routers called CPA1 and CPA2 in the central site.

In the remote site we have a 2610 routers connected with Public Frame-Relay, and anohter link with ISDN as backup.

Two peers dlsw from the remote site are configured, the first with CPA2 and its backup with CPA1 ( as you will see in the configuration).

when the link go down (FR), the peers stay in stat connected in both site until there is a SNA trafic, and the ddr is made from the remote site.

The problem is when the two link go down, the Host always see that the remote site is connected, the router CPA2 don't breack the circuit, and when the ISDN link come UP first, it open a circuit with a CPA1 even if the CPA2 is active, the HOST don't accept the second circuit cause it says that there is another circuit opened in the CPA2 with the same IDNum IDBlock. I tried to resolve that with the "dlsw timer sna-cahe-timeout" command but it have no effect.

i search some solution to this problem.

******************CPA1 Configuration**************************

source-bridge ring-group 2000

dlsw timer sna-cache-timeout

dlsw local-peer peer-id 1.1.1.1 keepalive 0 promiscuous

dlsw icanreach mac-exclusive

dlsw icanreach mac-address 4000.0e02.7206 mask ffff.ffff.ffff

dlsw icanreach mac-address 4000.0e13.7206 mask ffff.ffff.ffff

!

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet0/0

ip address 192.168.6.1 255.255.255.248

duplex full

speed 100

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Channel1/0

ip address 130.114.2.2 255.255.255.0 secondary

ip address 130.114.1.2 255.255.255.0

no ip redirects

no ip mroute-cache

no keepalive

llc2 dynwind

claw 0122 12 130.114.2.1 DEVL WCPA1 TCPIP TCPIP

claw 0111 02 130.114.1.1 PROD WCPA1 TCPIP TCPIP

csna 0111 00 maxpiu 65535 length-delay 0

csna 0122 10 maxpiu 65535 length-delay 0

max-llc2-sessions 1024

lan TokenRing 1

source-bridge 1000 1 2000

adapter 0 4000.0e02.7206

adapter 1 4000.0e13.7206

*******************CPA2 configuration*****************************

source-bridge ring-group 2200

dlsw timer sna-cache-timeout

dlsw local-peer peer-id 2.2.2.2 keepalive 0 promiscuous

dlsw icanreach mac-exclusive

dlsw icanreach mac-address 4000.0e02.7206 mask ffff.ffff.ffff

dlsw icanreach mac-address 4000.0e13.7206 mask ffff.ffff.ffff

!

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface FastEthernet0/0

ip address 192.168.6.2 255.255.255.248

duplex full

speed 100

!

interface FastEthernet0/1

no ip address

shutdown

duplex full

speed 100

!

interface Channel1/0

ip address 130.114.2.3 255.255.255.0 secondary

ip address 130.114.1.3 255.255.255.0

no ip redirects

no ip route-cache cef

no ip mroute-cache

no keepalive

llc2 dynwind

claw 0122 32 130.114.2.1 DEVL WCPA2 TCPIP TCPIP

claw 0111 22 130.114.1.1 PROD WCPA2 TCPIP TCPIP

csna 0111 20 maxpiu 65535 length-delay 0

csna 0122 30 maxpiu 65535 length-delay 0

max-llc2-sessions 1024

lan TokenRing 2

source-bridge 1100 1 2200

adapter 2 4000.0e02.7206

adapter 3 4000.0e13.7206

*******************Remote Site Configuration************************

dlsw local-peer peer-id 192.1.120.100 keepalive 0

dlsw remote-peer 0 tcp 2.2.2.2 timeout 90

dlsw remote-peer 0 tcp 1.1.1.1 backup-peer 2.2.2.2 timeout 90 linger 5

dlsw bridge-group 1

Thank You for your response.

3 REPLIES
Bronze

Re: DLSw problem whith two connection to the host

I think you need to remove the keepalive 0 from all the configurations. That way the DLSW peer connections will crrectly reflect the state of the physical network.

Since you are using the backup peer option, your ISDN line will be brought up and will stay up only while the backup peer connection is up so you do not need to supress keepalives.

New Member

Re: DLSw problem whith two connection to the host

Hello,

Thank you for your response.

If i remove the keepalive 0 from the configuration of the remote site's router, the ddr will be made immediately after the primary link goes down (FR), it will stay active all time, because the dlsw is the intersting trafic for the ddr :access-

access-list 101 deny icmp any any

access-list 101 deny eigrp any any

access-list 101 permit tcp any any eq 2065

access-list 101 permit udp any any eq 2065

access-list 101 permit udp any any eq 2067

dialer-list 1 protocol ip list 101

I tested it before, and the only solution is to configure keepalive 0.

Thank you

Bronze

Re: DLSw problem whith two connection to the host

Providing you are using the LINGER parameter on the dlsw backup peer statement, the backup peer connection should be completely torn down once the primary peer has been up for the linger period so no DLSW traffic should be passed over the ISDN and it will time out.

If you have tested this and are not seeing this behaviour, I would raise it with the TAC as a bug.

203
Views
0
Helpful
3
Replies
CreatePlease to create content