Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DLSW - SNA issue

My client was using IBM router at remote and connecting to IBM router at HQ with WAN line speed of 64kbps. Running OSPF. The application is running on SNA protocol.Remote branch will access the "HOST - Mainframe" at HQ.

After the migration to Cisco routers the customer complain the accessing to the "HOST' became slower.

Iniatially when on IBM platform the network design was very straight forward. The remote branch directly connected to Frame-relay cloud to HQ with one PVC.

Now there is 2 units of 7206 Cisco routers at HQ for redundancy purpose.

Branch remain with frame-relay 64 kbps but using 2 logical sub interface with different PVC to connect to the 2 units of 7206 routers at HQ.

Since running on OSPF routing protocol, IP packets can loadbalance via the both PVC but how about the SNA protocol?

Will there be any issue on the amount of bandwidth being use for SNA application after the migration since the remote branch will only connect to one of the router at one point of time using DLSW to access the HOST.

Below is my remote config. Is there any issue with this config?

dlsw local-peer peer-id x.x.x.1

dlsw remote-peer 0 tcp 141.x.x.1 <hq router 7206_1 token ring interface>

dlsw remote-peer 0 tcp 141.1.243.3 backup-peer 141.1.243.1 linger 3

dlsw icanreach sap 0 4 8 C

dlsw bridge-group 1

!

interface FastEthernet0/0

ip address 141.x.x.x.255.255.0

no ip redirects

ip route-cache flow

ip ospf authentication-key xxxxx

speed 100

full-duplex

bridge-group 1

!

interface Serial0/0

no ip address

encapsulation frame-relay IETF

no ip mroute-cache

no fair-queue

cdp enable

frame-relay lmi-type ansi

!

!

interface Serial0/0.899 point-to-point

description PVC to HQ 7206_2

bandwidth 64

ip address 10.x.x.x.x.255.252

ip ospf authentication-key xxxx

ip ospf network point-to-point

frame-relay interface-dlci 899

!

interface Serial0/0.900 point-to-point

description PVC to HQ 7206_1

bandwidth 64

ip address 10.x.x.x.x.255.252

ip ospf authentication-key xxx

ip ospf network point-to-point

frame-relay interface-dlci 900

7 REPLIES
Cisco Employee

Re: DLSW - SNA issue

Based upon the information given, I would suspect what is occuring is that you do not have IP MTU path discovery turned on and since there is duplicate paths, there are out of order TCP packets between the DLSW peers. So, add this command to the DLSW routers: ip tcp path-mtu-discovery. Then, when you get an outage period, simply do a dlsw disable and then no dlsw disable on one of the dlsw routers to reset the session. I wrote a webpage to describe what this does at http://www.cisco.com/en/US/partner/tech/tk331/tk336/technologies_tech_note09186a00801d3a9d.shtml.

If you can, post a show tcp and show interface s0/0 from the routers and we can make sure. On top of doing this, we might need to implement frame-relay traffic shaping with TCP port 2065 high priority to ensure DLSW can get through. This would depend on the CIR and burst of the PVC's and how much is currently being utilized.

New Member

Re: DLSW - SNA issue

Hi,

Thanks for the information. Here show tcp command

sh tcp

Stand-alone TCP connection from host 141.1.243.1

Connection state is ESTAB, I/O status: 1, unread input bytes: 0

Local host: 141.1.209.1, Local port: 2065

Foreign host: 141.1.243.1, Foreign port: 22452

Enqueued packets for retransmit: 0, input: 0 mis-ordered: -1 (0 bytes)

TCP driver queue size 0, flow controlled FALSE

Event Timers (current time is 0x32FEC44):

Timer Starts Wakeups Next

Retrans 9338 380 0x0

TimeWait 0 0 0x0

AckHold 10783 0 0x0

SendWnd 0 0 0x0

KeepAlive 1407 0 0x0

GiveUp 8957 0 0x0

PmtuAger 0 0 0x0

DeadWait 0 0 0x0

iss: 3135737176 snduna: 3139076055 sndnxt: 3139076055 sndwnd: 20342

irs: 3287893903 rcvnxt: 3290222475 rcvwnd: 20022 delrcvwnd: 458

SRTT: 960 ms, RTTO: 4265 ms, RTV: 3305 ms, KRTT: 0 ms

minRTT: 20 ms, maxRTT: 3244 ms, ACK hold: 200 ms

Flags: passive open, higher precedence, retransmission timeout

Datagrams (max data segment is 536 bytes):

Rcvd: 22679 (out of order: 1258), with data: 11790, total data bytes: 2328571

Sent: 22348 (retransmit: 380, fastretransmit: 17), with data: 9722, total data b

ytes: 3347990

tty66, virtual tty from host 10.6.1.9

Connection state is ESTAB, I/O status: 1, unread input bytes: 0

Local host: 141.1.209.1, Local port: 23

Foreign host: 10.6.1.9, Foreign port: 54786

Enqueued packets for retransmit: 1, input: 0 mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x32FF01C):

Timer Starts Wakeups Next

Retrans 43 3 0x32FF21E

TimeWait 0 0 0x0

AckHold 34 5 0x0

SendWnd 0 0 0x0

KeepAlive 15 0 0x330D368

GiveUp 0 0 0x0

PmtuAger 0 0 0x0

DeadWait 0 0 0x0

iss: 556178450 snduna: 556185105 sndnxt: 556185105 sndwnd: 4114

irs: 28892121 rcvnxt: 28892229 rcvwnd: 4021 delrcvwnd: 107

SRTT: 330 ms, RTTO: 503 ms, RTV: 173 ms, KRTT: 1006 ms

minRTT: 88 ms, maxRTT: 860 ms, ACK hold: 200 ms

Flags: passive open, higher precedence, retransmission timeout

Datagrams (max data segment is 536 bytes):

Rcvd: 82 (out of order: 15), with data: 47, total data bytes: 107

Sent: 82 (retransmit: 4, fastretransmit: 0), with data: 60, total data bytes: 7190

New Member

Re: DLSW - SNA issue

Hi,

Here is the show interface command

2620#sh int s0/0

Serial0/0 is up, line protocol is up

Hardware is PowerQUICC Serial

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation FRAME-RELAY IETF, loopback not set

Keepalive set (10 sec)

LMI enq sent 1237, LMI stat recvd 1236, LMI upd recvd 0, DTE LMI up

LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0

LMI DLCI 0 LMI type is ANSI Annex D frame relay DTE

Broadcast queue 0/64, broadcasts sent/dropped 3737/2, interface broadcasts 330

5

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 14:54:37

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 1000 bits/sec, 2 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

26362 packets input, 3450007 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

17843 packets output, 3140527 bytes, 0 underruns

0 output errors, 0 collisions, 3 interface resets

0 output buffer failures, 0 output buffers swapped out

15 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

I've implemented traffic shaping at the routers as below but the frame-relay packets keep dropping.

interface Serial0/0

frame-relay class JPN_QOS_64K

frame-relay traffic-shaping

!

map-class frame-relay JPN_QOS_64K

frame-relay traffic-rate 32000 64000

no frame-relay adaptive-shaping

frame-relay custom-queue-list 1

logging trap warnings

logging 155.2.1.156

access-list 100 permit tcp any any eq 2065

access-list 101 permit ip 141.1.209.0 0.0.0.255 141.1.243.0 0.0.0.255

queue-list 1 protocol ip 1 list 100

queue-list 1 default 5

queue-list 1 queue 1 byte-count 3000

dialer-list 1 protocol ip permit

Cisco Employee

Re: DLSW - SNA issue

Ok, from your show tcp, the 141.1.209.1 to 141.1.243.1 show as extremely latent. In the show tcp, the Smooth round trip time is 960 ms or .96 sec and the maximum round trip time was 3244 ms or 3.244 secs. So there is an IP delay problem on this connection. I do advise to implement the path mtu discovery and reset the tcp links to pick up the new maximum segment size and this will help alot.

For the traffic shaping, do it like this:

interface s0

encapsulation frame-relay

interface s0.1 point

frame-relay class cisco

Then,

map-class frame-relay cisco

frame-relay mincir 32000

frame-relay cir 64000

frame-relay priority-group 1

Then,

priority-list 1 protocol ip high tcp 2065

All of this will help out on the router side but I think there could be something else occuring on the wan to make the delay that significant.

New Member

Re: DLSW - SNA issue

Hi,

Really appreciate your help.

Just to confirm,

Do i need to put the path mtu discovery only on the LAN interfaces which involve in DLSW or WAN interfaces as well?

By applying the traffic shaping on my 2 sub interfaces at my remote routers, will the bandwidth not being fully utilise since remote router will be only connecting to one of the HQ router at one point of time. Since the mincir is 32000 both subinterfaces, will it only use 32kbps bandwidth for the connection or it can burst to 64kbps?

Cisco Employee

Re: DLSW - SNA issue

The IP mtu path discovery is a global command.

You will shape to a 32K CIR and 64K burst with the config I did.

New Member

Re: DLSW - SNA issue

Hi,

Don't we need to enable "frame-relay traffic-shaping" on the the interface s0?

It's is missing from your sample config.

I need to enable traffic-shaping on both (HQ & remote) routers, right?

274
Views
0
Helpful
7
Replies
CreatePlease login to create content