Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

etherchannel in multihomed nx 2148?

Hi out there

I have setup a pair of nx5020 with a single "multihomed" nx2148 from where I wan't to add a number of 1Gig ports in a etherchannel to a cat 3750 - but I cannot get the etherchannel up - it claims that i cannot do this on a multichassis switch - can some out there guide me to a sample?

best regards /i

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: etherchannel in multihomed nx 2148?

tiwang wrote:

hi again

I am forced to do this because we need the redundance we get - and of course also wan't the benefits from the loadbalancing - from the design in chads post - hereby can I also update the nexus one by one without risc - but I am a bit in doubt how to define the ports on the 3750 - how should these be defined when they are the opposite of a host-mode etherchannel from the nexus ?

best regards /ti

Etherchannel from 3750 will be a standard LACP etherchannel (channel-protocol lacp / channel-group X mode active). From 3750s perspective the two N5Ks (via N2k) will appear as one logical switch. Please test this first before trying out in production.

Atif

18 REPLIES
Cisco Employee

Re: etherchannel in multihomed nx 2148?

This is correct, you cannot create host etherchannel from 2148.  Only VPCs are supported on 2148, so you would need 2 of them.  You could then configure something like this:

5k-----5k

|         |

2k      2k

\       / <-----VPC

  \    /

  Server

Cisco Employee

Re: etherchannel in multihomed nx 2148?

chapeter wrote:

This is correct, you cannot create host etherchannel from 2148.  Only VPCs are supported on 2148, so you would need 2 of them.  You could then configure something like this:

5k-----5k

|         |

2k      2k

\       / <-----VPC

  \    /

  Server

As Chad said this is not possible (host etherchannels) with a 2148, you need a 2248 which has host etherchannel support. That being said connecting switches directly to N2K is not a recommended configuration as host ports are hard coded with bpdu guard. If you really need to connect a switch to N2K then you will need to ensure that the switch does not send BPDUs to the N2K (configure flexlink or bpdu filter on the switch).

Atif

New Member

Re: etherchannel in multihomed nx 2148?

Hi Chad/atawan

My problem is - as shortly adressed in an other post - that we have a current environment which is running i default vlan (1) - pretty huge installation which during the next year is going to be migrated to a VMWare environment - to avoid to much "support" on the old environment we need a simple way to re-write the default vlan of 1 to that in our new environment - which I can do through 2 interconnected access-ports - and to give some redundance we allocate several interfaces for it. I'll now move the connections for the nx2148 (which I also have 2 of) so that I get 2 "single-homed" nx2148 - and hereby should it be possibly for me to open a etherchannel - or do I need a 2248 for this?

Cisco Employee

Re: etherchannel in multihomed nx 2148?

tiwang wrote:

Hi Chad/atawan

My problem is - as shortly adressed in an other post - that we have a current environment which is running i default vlan (1) - pretty huge installation which during the next year is going to be migrated to a VMWare environment - to avoid to much "support" on the old environment we need a simple way to re-write the default vlan of 1 to that in our new environment - which I can do through 2 interconnected access-ports - and to give some redundance we allocate several interfaces for it. I'll now move the connections for the nx2148 (which I also have 2 of) so that I get 2 "single-homed" nx2148 - and hereby should it be possibly for me to open a etherchannel - or do I need a 2248 for this?

Tiwang,

If you were to go with two single homed 2148s and run etherchannel across them it (one port to each 2148 as Chad explained in his earlier post) would theoretically work but keep in mind the issue I mentioned regarding a switch interconnect with N2K. There can also potentially be TAC support issues with this design.

Atif

New Member

Re: etherchannel in multihomed nx 2148?

hmmm "there could also potentially be TAC support issues with this design" ?? Besides of a quick and maybe a little bit dirty way to rewrite the default vlan which concerns do you have here?

best regards /ti

Cisco Employee

Re: etherchannel in multihomed nx 2148?

tiwang wrote:

hmmm "there could also potentially be TAC support issues with this design" ?? Besides of a quick and maybe a little bit dirty way to rewrite the default vlan which concerns do you have here?

best regards /ti

Support is provided for tested topologies and this does not appear to be one (3750 with Etherchannel across two N2Ks). My suggestion will be to use Flexlink for redundancy (3750 uplinks) and then dual home the Catalyst 3750 to the two 2148s.

Atif

New Member

Re: etherchannel in multihomed nx 2148?

hi again

sounds as if it is this I have to go for - in the meanwhile I have reconfigured the nx5020 so that they have a dual-uplink but single-homed nx2148 each

Then I'll define a new vpc which spans them all - I setup each fex like this:

nx5020-1 w. fex 100:

int et 1/39-40

channel-group 100

exit

int port-channel 100

switchport mode fex-fab

fex associate 100

nx5020-2 w fex 101:

int et 1/39-40

channel-group 100

exit

int port-channel 100

switchport mode fex-fab

fex associate 101

how must I then define the interfaces on the fex to define a dual port'et vpc in access mode? can you show me a short sample?

I found the note's for configuring flexlinks but I am not sure if I select the right options - If I connect the ports giga4/0/16-17-18 &19 to the 2 fex's - 100/1/1-2 & 101/1/1-2 then can I define f.ex 17 & 19 as backup but how must the vpc be defined for this?

best regards /ti

Cisco Employee

Re: etherchannel in multihomed nx 2148?

tiwang wrote:

hi again

sounds as if it is this I have to go for - in the meanwhile I have reconfigured the nx5020 so that they have a dual-uplink but single-homed nx2148 each

Then I'll define a new vpc which spans them all - I setup each fex like this:

nx5020-1 w. fex 100:

int et 1/39-40

channel-group 100

exit

int port-channel 100

switchport mode fex-fab

fex *** 100

nx5020-2 w fex 101:

int et 1/39-40

channel-group 100

exit

int port-channel 100

switchport mode fex-fab

fex *** 101

how must I then define the interfaces on the fex to define a dual port'et vpc in access mode? can you show me a short sample?

I found the note's for configuring flexlinks but I am not sure if I select the right options - If I connect the ports giga4/0/16-17-18 &19 to the 2 fex's - 100/1/1-2 & 101/1/1-2 then can I define f.ex 17 & 19 as backup but how must the vpc be defined for this?

best regards /ti

Lets keep it simple for starters. Your Gig 4/0/16 will connect to the first N2K and will be your primary interface. Your Gig 4/0/18 will connect to your second N2K and will be your backup interface. There will be no vPC configuration in this case. Sample config on N5K will be:

N5K01:

interface eth 100/1/1

switchport access vlan XXX

N5K02:

interface eth 101/1/1

switchport access vlan XXX

In short both your FEX interfaces (Active / Backup) will have the same configuration. Flexlink will dictate the path traffic will take as the Standby link will not be forwarding during normal operations. Do you want to use another pair of interfaces to carry different VLANs? I thought you have a single large VLAN and it will not be possible for you to split it. Do remember that you still cannot use host portchannels on the N2148.

Atif

New Member

Re: etherchannel in multihomed nx 2148?

hi again

yes we will need another i/f to carry other vlans but this - or these - can be defined as trunks because we just have to rewrite this one default vlan (or I hope so - shouldn't surprise me if there show some other small islands up behind a fw which is also running in default vlan but these a small and simple to change).

But how is the nx-side of the backup-i/f defined - just as an std acces port with bpdu turned off ? - eg: the 2 interfaces on the 2148 are configured identical - or more correctly the 2 x 2 pairs where I then define a new vPC which spans both 2148's -eg:

fex #1 - nx 5020-1:

int et 100/1/1-2

switchport mode acces

switchport access vlan 2001

spanning-tree bpdufilter enable

channel-group 10

fex #2 - nx 5020-2:

int et 101/1/1-2

switchport mode acces

switchport access vlan 2001

spanning-tree bpdufilter enable

channel-group 10

and then on both nx5020:

interface port-channel 10

vpc 10

no shut

could this work ?

best regards /ti

Cisco Employee

Re: etherchannel in multihomed nx 2148?

tiwang wrote:

hi again

yes we will need another i/f to carry other vlans but this - or these - can be defined as trunks because we just have to rewrite this one default vlan (or I hope so - shouldn't surprise me if there show some other small islands up behind a fw which is also running in default vlan but these a small and simple to change).

But how is the nx-side of the backup-i/f defined - just as an std acces port with bpdu turned off ? - eg: the 2 interfaces on the 2148 are configured identical - or more correctly the 2 x 2 pairs where I then define a new vPC which spans both 2148's -eg:

fex #1 - nx 5020-1:

int et 100/1/1-2

switchport mode acces

switchport access vlan 2001

spanning-tree bpdufilter enable

channel-group 10

fex #2 - nx 5020-2:

int et 101/1/1-2

switchport mode acces

switchport access vlan 2001

spanning-tree bpdufilter enable

channel-group 10

and then on both nx5020:

interface port-channel 10

vpc 10

no shut

could this work ?

best regards /ti


NX side of the backup interface is defined exactly the same as the Primary interface as I had mentioned in my previous post. There is no need to enable bpdu filter with a Flexlink configuration. I think there is some misunderstanding here as I have been trying to tell you that there will be no vPC configuration in this case. What is the confusion?

Atif

New Member

Re: etherchannel in multihomed nx 2148?

hi again

ok - I would just prefer to be able to aggregate n * 1gig ports - we are going to a rather huge number of interactive users (running RDP) through this single port so it would be nice to have load-balancing

Right now it is enough with a single 1G port with a backup i/f but I have to consider how I get load-balancing into it also - and since it is going to be running more or less non-stop it is not possibly for me to "play" with it.

And even though the nx2148 for some design reasons doesn't support etherchannels can't I through vPC & LACP aggregate more ports into a thick port-channel ?

best regards /ti

Cisco Employee

Re: etherchannel in multihomed nx 2148?

tiwang wrote:

hi again

ok - I would just prefer to be able to aggregate n * 1gig ports - we are going to a rather huge number of interactive users (running RDP) through this single port so it would be nice to have load-balancing

Right now it is enough with a single 1G port with a backup i/f but I have to consider how I get load-balancing into it also - and since it is going to be running more or less non-stop it is not possibly for me to "play" with it.

And even though the nx2148 for some design reasons doesn't support etherchannels can't I through vPC & LACP aggregate more ports into a thick port-channel ?

best regards /ti


When you bring port-channel back into the discussion we again move towards the supported/non-supported debate. While what you want to do is theoretically possible my personal opinion is to stay away from the port-channel based design. Had you been connecting the 3750s directly to the Nexus 5Ks I would not have any issues with an Etherchannel based design but N2K is not meant to have switch facing interconnects so a limited set of design options are supported.

If you want to stick with the 3750 to N2K connectivity you can achieve load balancing in two ways:

  1. Configure your flexlink pair such that one interface is Active for one set of VLANs and the other interface is Active for another set of VLANs.
  2. Configure two flexlink pairs and carry some VLANs on Pair-1 and others on Pair-2.

Atif

New Member

Re: etherchannel in multihomed nx 2148?

hi again

hmm - I have enough SFP ports on the nx5020's - but didn't have any copper sfp modules so I think I send a "we need this" list to my boss before we go to far with this little project - and move the ports directly to the NX5020 instead - right now I stick with our discussed setup - and I'll see if I can get the ports up in backup mode during the night - thanks.

best regards

New Member

Re: etherchannel in multihomed nx 2148?

Hi again

Last week I tried to define a flexlink backup interface on the Cat which is connecting the NX2148 to our core - this ran fine.

Afterwards I have moved this backup i/f to the second nx2148 and tried the setup as Chad suggested - this is the running setup right now and seems to be working fine - we have traffic on both interfaces and it is also balaced fine.

A few questions - I defined the port-channel pretty basic

interface Ethernet101/1/2

  switchport access vlan 2001

  spanning-tree bpdufilter enable

  channel-group 15

When I look at the port-channel 15 I can see that LACP isn't active - forgot the mode active switch:

SW5020-02# sh port-channel sum

Flags:  D - Down        P - Up in port-channel (members)

        I - Individual  H - Hot-standby (LACP only)

        s - Suspended   r - Module-removed

        S - Switched    R - Routed

        U - Up (port-channel)

--------------------------------------------------------------------------------

Group Port-       Type     Protocol  Member Ports

      Channel

--------------------------------------------------------------------------------

10    Po10(SU)    Eth      LACP      Eth1/1(P)    Eth1/2(P)   

15    Po15(SU)    Eth      NONE      Eth101/1/2(P) 

SW5020-02#

Can I change this on a running system or will it interrupt the traffic?

Cisco Employee

Re: etherchannel in multihomed nx 2148?

So you are taking the risk with the etherchannel design :-). It is better you do the change during a maintenance window as you will need to make the change on both N5Ks (vPC scenario). I believe there will be traffic disruption but if you plan it correctly you can minimize the disruption.

Atif

New Member

Re: etherchannel in multihomed nx 2148?

hi again

I am forced to do this because we need the redundance we get - and of course also wan't the benefits from the loadbalancing - from the design in chads post - hereby can I also update the nexus one by one without risc - but I am a bit in doubt how to define the ports on the 3750 - how should these be defined when they are the opposite of a host-mode etherchannel from the nexus ?

best regards /ti

Cisco Employee

Re: etherchannel in multihomed nx 2148?

tiwang wrote:

hi again

I am forced to do this because we need the redundance we get - and of course also wan't the benefits from the loadbalancing - from the design in chads post - hereby can I also update the nexus one by one without risc - but I am a bit in doubt how to define the ports on the 3750 - how should these be defined when they are the opposite of a host-mode etherchannel from the nexus ?

best regards /ti

Etherchannel from 3750 will be a standard LACP etherchannel (channel-protocol lacp / channel-group X mode active). From 3750s perspective the two N5Ks (via N2k) will appear as one logical switch. Please test this first before trying out in production.

Atif

New Member

Re: etherchannel in multihomed nx 2148?

This is very similar to a scenario I have. (Sorry for the horrible drawing below) I'm under the impression that I should be able to connect in the fashion below with VPC's made on the N5K side and a regular etherchannel configured on the catalyst side.  When I mocked it up quickly in the lab I found that the Po on the Cat side went active but one member went into the "suspended" state.  On the N5K side the channel went with one member in the (H)ot Standby state.  Should I be able to get both members of this Po into a "P" state?

Cat4900  ----------  Cat4900

   |  vpc1\               / vpc2 |

   |          \           /          |

   |             \      /            |

   |               \  /              |

   |              /  \               |

   |          /         \            |

   |       /              \          |

N5K-1 ----vPC------ N5K-2

Thanks!

1014
Views
0
Helpful
18
Replies
CreatePlease login to create content