Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Nexus 1000v Layer3 Control not coming up

For info, I run 4.2(1)SV1(4) as a VM and not the appliance.

I tried this morning to migrate a small environment to the Nexus L3 control instead of L2 for a certain requirement. We have two ESX in the with the Nexus 1000v running sucessfully for months on L2.

I tried to follow the procedure that is in this document. I followed this script:

Created a layer3 control0 interface with an IP in vlan951.

So I had my VMWare guy move a VMKernel interface of each ESX host to this profile:

port-profile type vethernet VLAN951

  vmware port-group VLAN951

  capability l3control

  switchport mode access

  switchport access vlan 951

  system vlan 951

  no shutdown

  state enabled

Then modified the svs domain like such:

svs-domain

no control vlan

no packet vlan

svs mode 13 interface control0

I made sure that I have layer-2 connectivity between the VSM host and the rest ESX hosts is OK, but I am not certain how you actually assign a layer 2 vlan to the control0 interface... Is it supposed to broadcast on all the VLANs? Or is it a correlation of the port-profile config and svs-domain that does that?

In any case, my two VEM go down and do not come back up once I am in l3 mode. I had to revert back to L2.

Any help would be appreciated.

Regards,

Simon T.

1 REPLY
Cisco Employee

Nexus 1000v Layer3 Control not coming up

Hi Simon,

Since you are using ctrl0 as the layer 3 interface, you need to assign the IP address under the ctrl0 interface (interface ctrl0). This IP address should be able to communicate with the vmk interface's IP address.

Regards,

Shankar

673
Views
0
Helpful
1
Replies