Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Nexus 1000V

Hello

I am need of some help to get Nexus 1000V working in my lab. Lab is made out of (see attached diagram) and also included screenshot of DVS within vCenter server.

Physical server runing VMware ESXi 4.1 - this is standalon server. runinng following

Nexus 1000V VMS (Virutal Machine)

vCenter Server (Virtual Machine)

Connected to Cisco 3560 switch - connected mode are in trunk mode allowed VLAN 51,53,10

Physical PC with VMware Workstation software running:

ESXi version 5

Physical PC Network adapter connected to cisco 3560 switch in Trunk mode alled VLAN 51,53,10

Using Network driver I have created a logical VLAN for all three VLAN so that ESXi host is able to tag right VLAN within its interfaces.

I am able to ping all devices on the network and different vlans. However, I have two issues:

1. VEM is not displayed within VSM or not registering it self.

2. When I create System-uplink on VLAN 51 and assing right ESXi NIC tagged for this VLAN which does green but when I create second  data-Uplink VM traffic for VLAN10 within vCenter it show port disabled and say access VLAN set to 1. Do not understand this bit.

Cisco 3560 switch config

This to physical ESXi 4.1 Server

interface FastEthernet0/47

description Physical Dell VM UPlinks

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,51,53

switchport mode trunk

switchport nonegotiate

This to physical PC with VMWare Workstation software running (ESXi version 5 is running on there as virtual machine)

interface FastEthernet0/2

description PC to Core sw for ESXi hosts

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,51,53

switchport mode trunk

switchport nonegotiate

VLANs

10   VM-Data                          active

51   Control                          active

53   Management                       active

interface Vlan1

ip address 192.168.1.100 255.255.255.0

!

interface Vlan10

ip address 192.168.3.1 255.255.255.0

!

interface Vlan51

ip address 192.168.51.1 255.255.255.0

!

interface Vlan53

ip address 192.168.2.100 255.255.255.0

On Nexus VSM END

config attached

N1K-VSM001# show svs connections

connection vcenter:

    ip address: 192.168.2.45

    remote port: 80

    protocol: vmware-vim https

    certificate: default

    datacenter name: Taunton

    admin:

    max-ports: 8192

    DVS uuid: f2 6d 0b 50 79 97 8e 22-bb 3c c0 aa 79 6e cb 06

    config status: Enabled

    operational status: Connected

    sync status: Complete

    version: VMware vCenter Server 5.0.0 build-455964

N1K-VSM001# show svs domain

SVS domain config:

  Domain id:    5

  Control vlan: 51

  Packet vlan:  51

  L2/L3 Control mode: L2

  L3 control interface:  NA

  Status: Config push to VC successful.

On ESXi 5 end

ignore the vSwith0 to 2

vmnic6 is tag for VLAN 51 (system-uplink)

vmnic8 is tag for VLAN 10 (data-uplink)

~ # vem status

VEM modules are loaded

Switch Name      Num Ports   Used Ports  Configured Ports  MTU     Uplinks

vSwitch0         128         4           128               1500    vmnic0,vmnic1

vSwitch1         128         5           128               1500    vmnic2,vmnic3

vSwitch2         128         4           128               1500    vmnic4,vmnic5

DVS Name         Num Ports   Used Ports  Configured Ports  MTU     Uplinks

N1K-VSM001       256         13          256               1500    vmnic8,vmnic6

VEM Agent (vemdpa) is running

~ # vemcmd show port

  LTL   VSM Port  Admin Link  State  PC-LTL  SGID  Vem Port

   23                UP   UP    F/B*      0        vmnic6

   25              DOWN   UP    BLK       0        vmnic8

* F/B: Port is BLOCKED on some of the vlans.

Please run "vemcmd show port vlans" to see the details.

~ # vemcmd show trunk

Trunk port 6 native_vlan 1 CBL 1

vlan(1) cbl 1, vlan(51) cbl 1, vlan(3968) cbl 1, vlan(3969) cbl 1, vlan(3970) cbl 1, vlan(3971) cbl 1,

Trunk port 16 native_vlan 1 CBL 1

vlan(1) cbl 1, vlan(51) cbl 1, vlan(3968) cbl 1, vlan(3969) cbl 1, vlan(3970) cbl 1, vlan(3971) cbl 1,

Trunk port 23 native_vlan 1 CBL 0

vlan(51) cbl 1,

~ # vemcmd show bd

Number of valid BDS: 6

BD 1, vdc 1, vlan 1, 0 ports

Portlist:

BD 51, vdc 1, vlan 51, 3 ports

Portlist:

     10

     12

     23  vmnic6

BD 3968, vdc 1, vlan 3968, 3 ports

Portlist:

      1  inband

      5  inband port security

     11

BD 3969, vdc 1, vlan 3969, 2 ports

Portlist:

      8

      9

BD 3970, vdc 1, vlan 3970, 0 ports

Portlist:

BD 3971, vdc 1, vlan 3971, 2 ports

Portlist:

     14

     15

~ # vemcmd show dr

Number of valid BDS: 6

BD 1, vdc 1, vlan 1, 0 ports, DR 0, multi_uplinks FALSE

Portlist:

BD 51, vdc 1, vlan 51, 3 ports, DR 23, multi_uplinks FALSE

Portlist:

     10

     12

     23  DR vmnic6

BD 3968, vdc 1, vlan 3968, 3 ports, DR 0, multi_uplinks FALSE

Portlist:

      1     inband

      5     inband port security

     11

BD 3969, vdc 1, vlan 3969, 2 ports, DR 0, multi_uplinks FALSE

Portlist:

      8

      9

BD 3970, vdc 1, vlan 3970, 0 ports, DR 0, multi_uplinks FALSE

Portlist:

BD 3971, vdc 1, vlan 3971, 2 ports, DR 0, multi_uplinks FALSE

Portlist:

     14

     15

any help would be great.

Thanks

Sultan

Everyone's tags (3)
1 REPLY
New Member

Nexus 1000V

Found the problem - VEM is now listed within VSM along with ESXi host names.

root of the problem was - ESXi 5 host (running as virtual machine) server vmnic cannot be in trunk mode and has to be in access mode. Due to the limitation of the my lab setup. Each VMNIC in ESXi host is tag for specific VLAN using PC physical network adapter driver it can only see that VLAN.

for testing this will do the job understand in real world it be likely to be in trunk mode.

Last question is it possible to port-channel access interfaces on same vlan?

Cheers

Sultan

1745
Views
0
Helpful
1
Replies
CreatePlease login to create content