Cisco Support Community
Community Member

Nexus 5k - vfc interface down

i have a server with a qlogic CNA card connected to the nexus 5k.. The physical ethernet port seems to come up but the vfc interface refuses to come up

I have tried many suggestions like cconfiguring the interface as trunk, making sure the fcoe vlan is allowed on the trunk etc  but still the vfc interface doesnt come up

the relevant configurations are attached ...

I also tried to disable fcoe negotiation mode using the command fcoe mode on but this command seems to be unavailable under the interface though feature fcoe has been enabled

version 4.1(3)N2(1)

feature fcoe

feature telnet

feature interface-vlan

feature fex

role name default-role

  description This is a system defined role and applies to all users.

  rule 5 permit show feature environment

  rule 4 permit show feature hardware

  rule 3 permit show feature module

  rule 2 permit show feature snmp

  rule 1 permit show feature system

no password strength-check

ip host N5K

hostname N5K

snmp-server enable traps entity fru

vrf context management

  ip route

vlan 1

vlan 201


vsan database

  vsan 201

interface Vlan1

  no shutdown

interface Vlan201

  no shutdown

interface Vlan300

interface vfc9

  bind interface Ethernet1/9

  no shutdown

interface vfc10

  bind interface Ethernet1/10

  no shutdown

vsan database

  vsan 201 interface vfc9

  vsan 201 interface vfc10

  vsan 201 interface fc2/1

  vsan 201 interface fc2/2

  vsan 201 interface fc2/3

feature npv

npv enable

npv auto-load-balance disruptive

interface fc2/1

  no shutdown

interface fc2/2

  no shutdown

interface fc2/3

  no shutdown

interface fc2/4

  no shutdown

interface fc2/5

interface fc2/6

interface Ethernet1/1

interface Ethernet1/2

interface Ethernet1/3

interface Ethernet1/4

interface Ethernet1/5

interface Ethernet1/6

interface Ethernet1/7

interface Ethernet1/8

interface Ethernet1/9

  switchport mode trunk

  switchport trunk allowed vlan 1,201

  spanning-tree port type edge trunk

interface Ethernet1/10

interface Ethernet1/11

interface Ethernet1/12

interface Ethernet1/13

interface Ethernet1/14

interface Ethernet1/15

interface Ethernet1/16

interface Ethernet1/17

interface Ethernet1/18

interface Ethernet1/19

interface Ethernet1/20

interface mgmt0

  ip address

line console

boot kickstart bootflash:/n5000-uk9-kickstart.4.1.3.N2.1.bin

boot system bootflash:/n5000-uk9.4.1.3.N2.1.bin

cfs ipv4 distribute

interface fc2/1

  switchport mode F

interface fc2/2

  switchport mode F

interface fc2/3

interface fc2/4

interface fc2/5

interface fc2/6

any ideas ??


Everyone's tags (1)

Re: Nexus 5k - vfc interface down

Is feature LLDP enabled? You need that for the CNA to discover the FCOE vlan, and a Storage Protocols Services License. Please post "show lldp nei" and "show npv flog" and let's see what that shows.

Do you have storage targets in fc2/1 - 3 or an upstream SAN switch? If SAN switch is upstream, then VLAN 201 needs to match your upstream VSAN on fc2/1-3, and the ports are configured a F port, they should be NP.

Also if you upgrade to 4.2 you could setup a san-port-channel to your upstream SAN switch (NP-F or TNP-TF), which I think is a better solution than disruptive load balancing, but may need a MDS on the other end.

Is this connects both your host and your storage target, then maybe you need fabric mode (FC switch) instead of NPV mode, for your zoning as well.

Please rate helpful posts.


Community Member

Re: Nexus 5k - vfc interface down

yes the switch will be connected to both the storage and the servers

can you let me know how to enable fabric mode on the switch

In the mean time i will enable lldp and try to post the outputs


Re: Nexus 5k - vfc interface down

I don't recall exactly, but it seems like you can't have targets connected in NPV mode. You need a switch to handle the fabric logins ("show flogi dat").

You can run the 5K as a FC switch with "no feature npv" or the default out of the box.  Backup your config as it might delete it. Going from a FC switch to NPV mode deletes the config and forces a reboot, and the reverse might do the same. You should verify all this as we run the 5K in NPV mode and connect them upstream to MDS.

Community Member

Re: Nexus 5k - vfc interface down

Have you gotten this working? I have a very similar problem and opened a new thread as to not hijack this one-


Community Member

Re: Nexus 5k - vfc interface down

Yes .. the issue was the twin-ax cable connecting the Dell servers and the N5K

We replaced the same with a fiber cable and it worked fine


CreatePlease to create content