Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Nexus 7k - vPC - downstream port-channels

I have a pair of Nexus 7k configured for virtual port-channel (with domain, peer-links, pkal, etc.)

I have three Nexus 5k switches dowstream, that I want to connect to both 7k using vPC.

From the documentation I understand that I must use port-channels on both 7k to attach downsream

switches. But it is not clear to me whether I must use separate port-channel for each downstream

switch, or I may bundle all downsream links into a common port-channel on 7k?

E.g., with separate port-channels on N7k-1:

interface ethernet 7/1-2
description to N5k-1
switchport mode trunk
allowed vlan 1-50
channel-group 51 mode active
!
interface port-channel 51
vpc 50
!
interface ethernet 7/9-10
description to N5k-2
switchport mode trunk
allowed vlan 1-50
channel-group 52 mode active
!
interface port-channel 52
vpc 50
Or, with a common port-channel:
interface ethernet 7/1-2
description to N5k-1
switchport mode trunk
allowed vlan 1-50
channel-group 50 mode active
!
interface ethernet 7/9-10
description to N5k-2
switchport mode trunk
allowed vlan 1-50
channel-group 50 mode active
!
interface port-channel 51
vpc 50
--------------------------------

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Nexus 7k - vPC - downstream port-channels

As this post is now a couple of days ago you may have already discovered the answer.  However, the vPC requires a unique Port-Channel group for each downstream device between the vPC peer devices, the two N7Ks in this case.  Essentially you need to configure three port-channels, one for each of your downstream N5Ks on both your N7K vPC peer devices:-

For example:-

N7K-1

interface ethernet 7/1-2
description to N5k-1
switchport mode trunk
switchport trunk allowed vlan 1-50
channel-group 100 mode active
!
interface port-channel 100
vpc 100
!

N7K-2

interface ethernet 7/1-2
description to N5k-1
switchport mode trunk
switchport trunk allowed vlan 1-50
channel-group 100 mode active
!
interface port-channel 100
vpc 100
!
N7K-1
interface ethernet 7/9-10
description to N5k-2
switchport mode trunk
switchport trunk allowed vlan 1-50
channel-group 101 mode active
!
interface port-channel 101
vpc 101
N7K-2
interface ethernet 7/9-10
description to N5k-2
switchport mode trunk
switchport trunk allowed vlan 1-50
channel-group 101 mode active
!
interface port-channel 101
vpc 101

.

.

.

.

etc.

Hope this helps

Allan.

2 REPLIES

Re: Nexus 7k - vPC - downstream port-channels

As this post is now a couple of days ago you may have already discovered the answer.  However, the vPC requires a unique Port-Channel group for each downstream device between the vPC peer devices, the two N7Ks in this case.  Essentially you need to configure three port-channels, one for each of your downstream N5Ks on both your N7K vPC peer devices:-

For example:-

N7K-1

interface ethernet 7/1-2
description to N5k-1
switchport mode trunk
switchport trunk allowed vlan 1-50
channel-group 100 mode active
!
interface port-channel 100
vpc 100
!

N7K-2

interface ethernet 7/1-2
description to N5k-1
switchport mode trunk
switchport trunk allowed vlan 1-50
channel-group 100 mode active
!
interface port-channel 100
vpc 100
!
N7K-1
interface ethernet 7/9-10
description to N5k-2
switchport mode trunk
switchport trunk allowed vlan 1-50
channel-group 101 mode active
!
interface port-channel 101
vpc 101
N7K-2
interface ethernet 7/9-10
description to N5k-2
switchport mode trunk
switchport trunk allowed vlan 1-50
channel-group 101 mode active
!
interface port-channel 101
vpc 101

.

.

.

.

etc.

Hope this helps

Allan.

New Member

Re: Nexus 7k - vPC - downstream port-channels

Thank you Allan.

In fact the answer to my question is: Both possible.

-- Separate downstream port-channel (and vpc) per each attached device (as you propose).

-- And common downstream port-channel (and vpc) for a pair of attached N5k on condition

this pair is also configured for vPC. The latter topo is called Double-sided vPC or sometimes

back-to-back vPC, and it uses common vpc id and common Po's between all 4 devices.

The Double-sided vPC has an important advantage (over the topo with separate port-channels)

of permitting port-channel teaming for the hosts dual-homed to n5k's (i.e.load-balancing).

alex

==================

2956
Views
0
Helpful
2
Replies
CreatePlease to create content