Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Bronze

Packet Drops/slow file transfer N5k/N7k

N5k on 4.2(1)N1(1) and N7k on 5.0(2) [build 5.0(0.66)]

A pair of N5k on active-active mode with Vlan 211 and 207 up to the N7k redundant cores. I checked the following for N7k Core1:

ospf DR master

hsrp primary

vpc primary

stp root

Below is an example of a vlan config:


interface Vlan207
  no shutdown
  no ip redirects
  ip address 10.100.207.2/24
  ip ospf passive-interface
  ip router ospf 1 area 0.0.0.200
  ip pim sparse-mode
  ip igmp version 2
  hsrp 207
    preempt delay minimum 180
    priority 90
    timers  1  3
    ip 10.100.207.1
  ip dhcp relay address 10.100.211.71

Both N7k and N5k has the same config below:

interface port-channel13
  description TO-N5K-DC-EDGE3and4 PORTS 3/9 and 3/10****
  switchport
  switchport mode trunk
  vpc 13
  switchport trunk allowed vlan 203-204,207-208,211,223-224
  logging event port link-status
  logging event port trunk-status

On the N5k, the switchport is basic:

interface Ethernet141/1/11
  switchport access vlan 207
  spanning-tree port type edge

. When server (2003 SP3 or 2008) on vlan 211 copies files from 207, it takes a long time. Wireshark trace shows dropped packets meaning I get a lot of "tcp previous segment loss" For example, a 1.5G files which normally take less than a minute, takes 15 minute to copy.

I tried different servers and it doesn't appear to be server related but network. I tried to turn off "checksum offload" and "large send offload" on the NIC but still a problem...there is no nic-teaming - just one nic on each server

From 10.100.211.X server, I tried a "ping 10.100.207.X -t -l 1514" and there was only a few packet drops  as oppose to the ethereal trace so I am not sure if I am actually getting packet loss from the network or if it is still a server issues. I tried copy from servers on diff OS (ie 2003 versus 2008) and same problem

I also looked at perfmon during a file transfer and it looks fine.

On non-active/actvie setups, like single switch user-IDF (ie 4500, 3750., 6500) or a single N5k, which has a vpc up to the N7k cores, file transfers are fine...so it just seems to be related to my redundant N5k (active-active) topology. I tried with turning Jumbo on and off as well as setting up QoS on and off but no work. Currently Jumbo and QoS is set back to default.

I also tried file transfer btwn n5k pairs meaning N5k(active-active) pair #1 to/from N5k(active-active) pair #2 and slow file transfers....so issue seems to related only to n5k active-active topology:

Any ideas

799
Views
0
Helpful
0
Replies
CreatePlease to create content