Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

"CIP microcode not found" error message during bootup on C7507

On Cisco 7507 router during installation of new CIP microcode (CIP-27-21.bin) we have encountered a problem. During router restart we received information on the console "CIP microcode not found" (unfortunatelly we do not have logs from that day). After that we had problems with channel interfaces (it didn't go up). Then we downgraded CIP microcode (to previous ver. 27-7), but there still was the error message (the same as before). But we were able to bring up channel interfaces. We're not sure if the error message during start of Cisco 7507 router is a normal behaviour (?). Maybe the router first must load IOS to properly load CIP microcode - but then what for is the error message?

6 REPLIES
New Member

Re: "CIP microcode not found" error message during bootup on C75

Hi Maciej,

I think what you are seeing is the attempt to load the default CIP code that is defined for and within the version of IOS that is loading. It is normal, when you store the image on flash and load later version of CIP code, to see this message when IOS loads. I generally suggest that you code explicit instructions in the configuration -

!

microcode CIP flash cip27-21

microcode reload

!

to ensure that you are loading the desired image.

Rgds, Dan

New Member

Re: "CIP microcode not found" error message during bootup on C75

Hi,

Thank you for info. We use these commands, and the microcode loads, but before that we get the error message... Our customer is afraid that something goes wrong - we explain that everything works, and there is no need to worry (error message). But the customer wants us to explain why there is such a message and how it can be "removed".

Maciej

New Member

Re: "CIP microcode not found" error message during bootup on C75

Don't worry.It's normal.I don't know why it is displayed,but it is.

Our cips is like this,too.And I think you ignored the message before the upgrade.

New Member

Re: "CIP microcode not found" error message during bootup on C75

Thanks for help. We think this is "normal" (if an error message can be normal :)), but our customer does not... Now we're waiting for official Cisco's response.

New Member

Re: "CIP microcode not found" error message during bootup on C75

Hi Maciej,

Yes, it is normal. For a specific release of IOS, there is a specific release of CIP microcode. The identity of the CIP microcode release is built in to the IOS code, so that IOS can attempt to load a useful set of code onto the CIP at start up. To eliminate the message, you can simply make the CIP microcode available, and IOS will load it, rather than putting out a message that it can not be found. Of course, if you have decided that you wish to run a different release of CIP microcode, this initial CIP code load step will be redundant, since you will be loading a different code set when the configuration is processed.

Rgds, Dan

New Member

Re: "CIP microcode not found" error message during bootup on C75

Hi,

this is correct because during a reboot the first image the router loads is the boot image that is different from "standard" IOS and this boot image has no support for CIP -

So, the "CIP microcode not found" during reboot is a message that you MUST get

Remember to put "microcode cip ...." and "microcode reload" in the config

bye

315
Views
0
Helpful
6
Replies