Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

"Simple" DLSW install not working

We have been doing DLSW (RFC 1434) on Nortel in our shop for years. We now have a remote site that installed a Cisco router so we have been trying to get DLSW+ working. We have installed a 4500 as our DLSW host and another 4500 as DLSW remote in our MAN environment for testing using a MS SNA Server. If we enable a nortel box with DLSW on the 10.109.16.x segment-SNA comes up fine. Still no luck with the Cisco. As you can see from the config we don't want to do anything special here-no redundant, etc.-we just want to get the basics working.

With a show llc2 on host router we see that the LLC2 state returns an status of:

TokenRing0 DTE: 4000.3745.0004 0003.f219.e97f 04 04 state ADM

In ADM state for 8472 msec, reason: LLC_LC_BOGUS ev: ZERO EVENT

We've had no luck with that message! 0003.f219.e97f is the bitswapped address of the SNA server.

We have determined that the SNA server is sending out both a bit-swapped and a non bit-swapped test request to the network - we finally determined this after many uncessful attempts at bitwapping the address ourselves. The router receives the bit-swapped version, does a bit-swap on the source and destination addresses then establishes a circuit. The circuit never stays connected, after a minute or two it drops the circuit. The show dlsw reach command shows that the address 4000.3745.0004 (tic) is reachable and is set for 'lf 1500'. When the circuit is dropped the reachability cache entry for 4000.3745.0004 is also dropped. The SNA server will then cycle to perform it's status test and the process repeats.

BTW: the 10.109.16.2 router has access lists because it acts as a simple firewall for a RAS box in the 10.109.109.x subnet

Appreciate any help, we have no idea at this point if its code, bitswapping issue, etc. Thanks!

---------------------------------------------------

Router#show ver

Cisco Internetwork Operating System Software

IOS (tm) 4500 Software (C4500-IS-M), Version 11.3(11c), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Sun 10-Feb-02 18:43 by pwade

Image text-base: 0x60008930, data-base: 0x60780000

ROM: System Bootstrap, Version 5.3(16) [richardd 16], RELEASE SOFTWARE (fc1)

BOOTFLASH: 4500 Software (C4500-BOOT-M), Version 11.1(7), RELEASE SOFTWARE (fc2)

Router uptime is 1 hour, 0 minutes

System restarted by reload

System image file is "flash:c4500-is-mz.113-11c.bin", booted via flash

cisco 4500 (R4K) processor (revision E) with 16384K/4096K bytes of memory.

Processor board ID 06443813

R4700 processor, Implementation 33, Revision 1.0

G.703/E1 software, Version 1.0.

Bridging software.

X.25 software, Version 3.0.0.

2 Ethernet/IEEE 802.3 interface(s)

2 Token Ring/IEEE 802.5 interface(s)

128K bytes of non-volatile configuration memory.

4096K bytes of processor board System flash (Read/Write)

4096K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2102

Router#show config

Using 1345 out of 129016 bytes

!

version 11.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

enable secret 5 $1$VDJl$MhCfKtXov.FsZBHvTkLle0

enable password pass

!

dlsw local-peer peer-id 10.109.16.2

dlsw remote-peer 0 tcp 10.100.2.1 lf 1500

dlsw bridge-group 1

!

!

interface Ethernet0

ip address 10.109.16.2 255.255.240.0

media-type auto-select

bridge-group 1

!

interface Ethernet1

ip address 10.109.109.1 255.255.255.0

ip access-group raslist in

media-type auto-select

!

interface TokenRing0

no ip address

shutdown

!

interface TokenRing1

no ip address

shutdown

!

router rip

version 2

network 10.0.0.0

!

no ip classless

ip route 10.106.2.0 255.255.255.0 10.109.16.1

ip route 10.106.11.0 255.255.255.0 10.109.16.1

ip http server

!

!

ip access-list extended raslist

permit ip 10.109.109.0 0.0.0.255 10.109.16.0 0.0.15.255

permit ip 10.109.109.0 0.0.0.255 host 10.81.1.90

permit ip 10.109.109.0 0.0.0.255 host 10.80.2.72

permit ip 10.109.109.0 0.0.0.255 host 10.80.2.70

permit ip 10.109.109.0 0.0.0.255 host 10.81.1.91

permit ip 10.109.109.0 0.0.0.255 host 10.106.11.2

permit ip 10.109.109.0 0.0.0.255 host 10.80.2.233

permit ip 10.109.109.0 0.0.0.255 host 10.106.2.1

snmp-server community pass RO

bridge 1 protocol ieee

!

line con 0

line aux 0

line vty 0 4

password pass

login

!

end

--------------------------------------------------

Cisco Internetwork Operating System Software

IOS (tm) 4500 Software (C4500-IS-M), Version 11.3(11c), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Sun 10-Feb-02 18:43 by pwade

Image text-base: 0x60008930, data-base: 0x60780000

ROM: System Bootstrap, Version 5.3(16) [richardd 16], RELEASE SOFTWARE (fc1)

BOOTFLASH: 4500 Software (C4500-BOOT-M), Version 11.1(7), RELEASE SOFTWARE (fc2)

CiscoDLSW uptime is 1 day, 7 hours, 10 minutes

System restarted by reload

System image file is "flash:c4500-is-mz.113-11c.bin", booted via flash

cisco 4500 (R4K) processor (revision E) with 16384K/4096K bytes of memory.

Processor board ID 06443651

R4700 processor, Implementation 33, Revision 1.0

G.703/E1 software, Version 1.0.

Bridging software.

X.25 software, Version 3.0.0.

2 Ethernet/IEEE 802.3 interface(s)

2 Token Ring/IEEE 802.5 interface(s)

128K bytes of non-volatile configuration memory.

4096K bytes of processor board System flash (Read/Write)

4096K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2102

CiscoDLSW#show config

Using 882 out of 129016 bytes

!

version 11.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname CiscoDLSW

!

enable secret 5 $1$qRFq$BDvKKnSRlrmTP9dmXJpMk0

enable password pass

!

source-bridge ring-group 2000

dlsw local-peer peer-id 10.100.2.1

dlsw remote-peer 0 tcp 10.109.16.2 lf 1500

!

!

interface Loopback0

ip address 10.100.2.1 255.255.255.0

!

interface Ethernet0

no ip address

shutdown

media-type auto-select

!

interface Ethernet1

no ip address

shutdown

media-type auto-select

!

interface TokenRing0

ip address 10.81.1.110 255.255.0.0

ring-speed 16

source-bridge 256 1 2000

source-bridge spanning

!

interface TokenRing1

no ip address

shutdown

!

router rip

version 2

network 10.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.81.1.1

!

snmp-server community pass RO

!

line con 0

line aux 0

line vty 0 4

password pass

login

!

end

1 REPLY
Bronze

Re: "Simple" DLSW install not working

Going from ethernet to token ring, the server needs to send out the bit swapped version of the destination address on the token ring.

In this case it would be 0200.ECA2.0020. This will be bit swapped by the router before populating the reachability cache so you will only ever see non canonical, ie token ring format addresses, in DLSW.

It sounds like the circuit is not finishing the XID exchange. If a 'sh dlsw cir' shows it getting to a status of Circuit Established but never getting to Connected, this is the problem. Usually because the Switched major node is inactive or is already in use.

You migh want to take a look at the following URL on troubleshooting DLSW circuit connectivity -

http://www.cisco.com/warp/customer/697/dlswts4.html

527
Views
0
Helpful
1
Replies
CreatePlease to create content