Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

try to add the ESX to n1kv it give the below error got (vim.fault.PlatformConfigFault) exception

Hello i m sharing to the forum the discussion we had in fb about my issue with a host see below:

Guys anyone saw this error when u try to add the ESX to n1kv it give the below error

vDS operation failed on host esxXX, An error occurred during host configuration. got (vim.fault.PlatformConfigFault) exception

on the esx it shows correct version of vem version

/var/log # esxcli software vib list | grep cisco

cisco-vem-v162-esx 4.2.1.2.2.1a.0-3.0.1 Cisco PartnerSupported 2013-10-29

I did try with the version Nexus1000v.4.2.1.SV2.1.1 and then with this is the latest version of cisco Nexus1000v.4.2.1.SV2.2.1a but shows same error

maybe u guys saw it before

- Robert Burns - Usually means the VSM doesn't have the appropriate VIB file for that version of ESX. You can simply manually install it using ESX CLI. You can pull down the appropriate VIB from VMware's site. Which version of ESX (Build) are you running?

- ME - i think maybe is related to old config of old n1kv i tried add another host and it works but it doesn t show the same dvs switch name

cannot add this host to n1kv

/var/log # net-dvs -l

switch 38 51 17 50 5d df 21 d0-29 b5 8c a7 df e8 e0 1b (cisco_nexus_1000v)

working ifne

~ # net-dvs -l

switch 09 72 17 50 f3 d5 87 8f-71 5b 8c 57 f5 fe b8 6a (cisco_nexus_1000v)

- ME - by the way both esxi have same build

~ # vmware -vl

VMware ESXi 5.0.0 build-1117897

VMware ESXi 5.0.0 Update 2

/var/log # vmware -vl

VMware ESXi 5.0.0 build-1117897

VMware ESXi 5.0.0 Update 2

- Robert Burns - Are the two N1K's different versions? Likely yes. In that case your VSMs have the appropriate VIB for ONE version of VSM, but not the other.

- ME - both have the same version

~ # esxcli software vib list | grep cisco

cisco-vem-v162-esx 4.2.1.2.2.1a.0-3.0.1 Cisco PartnerSupported 2013-10-29

/var/log # esxcli software vib list | grep cisco

cisco-vem-v162-esx 4.2.1.2.2.1a.0-3.0.1 Cisco PartnerSupported 2013-10-29

- ME - but one is already now part of n1kv and the other doesnt want to be added

- Robert Burns - Have you tried doing a hotswap -u - reboot - then try to re-add the host.

- ME - the command vemcmd show card shows that he still think he s part of the old n1kv switch  i will try the reload maybe that will help

- ME - /var/log # hotswap.sh -u - reboot

The following switch is of type cisco_nexus_1000v: DvsPortset-0

Starting time: Tue Oct 29 17:22:18 UTC 2013

Errors:

Sysinfo error on operation returned status : Not found. Please see the VMkernel log for detailed error information

stopDpa

VEM SwISCSI PID is

Warn: DPA running host/vim/vimuser/cisco/vem/vemdpa.80389

Warn: DPA running host/vim/vimuser/cisco/vem/vemdpa.80389

watchdog-vemdpa: Terminating watchdog process with PID 80382

Unload N1k switch modules

stop stun

Module vem-v162-stun being unloaded..

Module vem-v162-stun unloaded..

Module vem-v162-vssnet being unloaded..

Module vem-v162-vssnet unloaded..

Module vem-v162-n1kv being unloaded..

Module vem-v162-n1kv unloaded..

Module vem-v162-l2device being unloaded..

Module vem-v162-l2device unloaded..

Unload of N1k modules done.

did it and tried to re-add and it shows the same error...

the net-dvs still shows another switch name

/var/log # net-dvs -l

switch 38 51 17 50 5d df 21 d0-29 b5 8c a7 df e8 e0 1b (cisco_nexus_1000v)

- ME - i m trying a reboot of the host ...crossing fingers

- Robert Burns - Let's take the issue over to support forums and save the group of the spam

- ME - it s working after a reboot of the esxi host  , it was showing a warning out of sync and i did re-sync in vsphere and it removed the warning.

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

try to add the ESX to n1kv it give the below error got (vim.fau

So just to be clear - your issue is resolved?

Robert

1 REPLY
Cisco Employee

try to add the ESX to n1kv it give the below error got (vim.fau

So just to be clear - your issue is resolved?

Robert

853
Views
0
Helpful
1
Replies
CreatePlease to create content