Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Very strange!! i got the old web?

I have a very strange thing that happened and iam trying to figureout what is going on after i tried modifying tens or maybe hundreds of setting trying to solve it.

I have a motorola sbg6580 for my home perimeter i have forwared port 80 to my webserver and it works fine jst like always.

Now i also have an ASA 5505 which i configured for the webserver, after i put the webserver behind it the topology config was like this:

motorola sbg6580>ASA>switch>webserver1+webserver2+laptop. (forworded port 80 from the moto to the ASA external interface).

strangely, from the outside internet i can access only the old version of the website (i did updated the website the night before and it worked fine when connected directlly to the moto with out the ASA).

Then i found out that the old version of the website (website contects before update) also exist on the other web server so i figured OK i forgot to stop the other server's website, but when i stopped the other server'ways website the same thing keeps happening..i get the old website.

By the way (when i type the address of the intended website (ip address http://x.x.x.x) from a computer on the VLAN or the LAN I Get the updated view of the website and everything is fine, but when i access it from the internet i get the old unupdated view!!!

After that i got the webserver off the ASA's network and connected it directly to the moto like before when it was working fine (and i did the port forwarding to the server again) i got the same problem again..i get the old view of the website not the updated when i try to open it from the internet,but when i open it locally from the LAN i get the new updated website with no problem.

This got me thinking of three possibilities:(which are impossible to even think about):

1-Is there some caching function of the webserver it self for the old website or some where on the network? (if yes then how come i can open it just fine and view the updated website from the LAN or from the webserver host it self?) so this might be impossible which brings the thought of the second and most likely possibility which is:

2-The Motorolla router somehow have a malfunction wth it's forwarding capability (which is also not possible because when i send http request from the internet i do get the website but not the updated one but the old version which does not even exist on the server.


3-The ASA firewall is somehow contagious!!!

The question is (where exactly is this old website is view or layout is coming from after i tookout it's files from the server it self and replaced it with new files when are for the new updated website) , and how to fix it?

This is the first time i see such a thing and i have been trying for hours and hors to solve it or see where the problem is (i suspect problem in the moto router)


Everyone's tags (4)
580
Views
0
Helpful
0
Replies
CreatePlease login to create content