Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Bronze

vPC & NX-OS software versions

All,

- In a vPC configuration of 2x N5000 switches,do both N5000 switches need to run the same NX-OS software version for the vPC functionality

to work ? Or can they run different versions (to some extend) ?

- Does the "install all" command check for compatibility issues regarding vPC by default ?

For example: can i upgrade one N5000, leave it running for one week, and then upgrade the other one, without bringing down my vPC portchannels ?

regards,

Geert

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: vPC & NX-OS software versions

Hey Geert,

Both Nexus 5020 do not need to be running the same version.  However, there are limitations in terms of how different your versions may be.  Generally speaking if you are upgrading within the same train (4.1.3.N2.1 to 4.1.3.N2.1a for example) you should be fine.

Yes the install all command will check for compatibility with the current vPC configuration.

Yes again.  I have just finished going through this exact process in a proof of concept lab on a deployment with 3 Nexus 5K vPC pairs connected to a distribution block pair of Nexus 7K vPC (back to back vPC - 5K to 7K).

Hope this helps.

1 REPLY
New Member

Re: vPC & NX-OS software versions

Hey Geert,

Both Nexus 5020 do not need to be running the same version.  However, there are limitations in terms of how different your versions may be.  Generally speaking if you are upgrading within the same train (4.1.3.N2.1 to 4.1.3.N2.1a for example) you should be fine.

Yes the install all command will check for compatibility with the current vPC configuration.

Yes again.  I have just finished going through this exact process in a proof of concept lab on a deployment with 3 Nexus 5K vPC pairs connected to a distribution block pair of Nexus 7K vPC (back to back vPC - 5K to 7K).

Hope this helps.

1079
Views
0
Helpful
1
Replies
CreatePlease to create content