Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Configuration Example:AToM(Any Transport Over MPLS) for like to like Circuit

 

Introduction:

In this document you will learn to configure L2VPN using AToM (Any transport over MPLS) technology for like to like circuit. This document will cover both configuration steps required on IOS and IOS-XR.

 

AToM Configuration steps on IOS XR:

 

1) Configure interface to provide L2 transport

Conf t

interface <interface-type>  l2transport

 

2) Configure point to point cross connect:

Conf t

L2vpn

xconnect group <group-name>

p2p <xconnect-name>

interface <interface no>

Neighbor <ip-address> pw-id <pseudowire-id>

 

AToM Configuration steps on IOS:

 

1) Create pseudowire class:

Psedowire-class <class-name>

encapsulation mpls

 

2) Configure Cross connect on point to point interface:

Int <interface no>

Xconnect neighbor <ip-address> pw-id pseudowire-class <Class-name>

 

Configuration example:

 

In this example CE1 and CE2 don’t want to share their routing table with service provider so they prefer to go for L2VPN services. SP network is already MPLS enabled. We are configuring EoMPLS on PE1 running IOS XR and PE2 running classic IOS. Below are the basic configurations.

 

L2vpn.jpg

 

CE1CE2PE1PE2P1

hostname CE1

!

interface Loopback0

ip address 192.168.1.1 255.255.255.255

ip ospf 100 area 0

!

interface Ethernet1/0

ip address 172.16.1.1 255.255.255.0

ip ospf 100 area 0

hostname CE2

!

interface Loopback0

ip address 192.168.1.2 255.255.255.255

ip ospf 100 area 0

!

interface Ethernet1/0

ip address 172.16.1.2 255.255.255.0

ip ospf 100 area 0

interface Loopback0

ipv4 address 1.1.1.1 255.255.255.255

!

interface GigabitEthernet0/0/0/1

ipv4 address 10.1.1.1 255.255.255.252

!

router ospf 100

router-id 1.1.1.1

area 0

interface Loopback0

  !

  interface GigabitEthernet0/0/0/1

  !

!

!

mpls ldp

router-id 1.1.1.1

interface GigabitEthernet0/0/0/1

!

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

!

interface Ethernet0/1

ip address 10.1.1.6 255.255.255.252

mpls ip

!

router ospf 100

route-id 3.3.3.3

net 3.3.3.3 0.0.0.0 ar 0

net 10.1.1.6 0.0.0.0 ar 0

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface Ethernet0/0

ip address 10.1.1.2 255.255.255.252

mpls ip

interface Ethernet0/1

ip address 10.1.1.5 255.255.255.252

mpls ip

!

router ospf 100

router-id 2.2.2.2

network 2.2.2.2 0.0.0.0 area 0

network 10.1.1.2 0.0.0.0 area 0

network 10.1.1.5 0.0.0.0 area 0

!

 

Now let’s begin L2VPN configurationon PE1 and PE2:

 

Configuring AToM on PE1:

 

Step1: Configure interface to provide L2 transport

RP/0/0/CPU0:PE1(config)#int gig0/0/0/4 l2transport

RP/0/0/CPU0:PE1(config-if-l2)#commit

 

Step2: Configure point to point cross connect

RP/0/0/CPU0:PE1(config)#l2vpn

RP/0/0/CPU0:PE1(config-l2vpn)#xconnect group TEST

RP/0/0/CPU0:PE1(config-l2vpn-xc)#p2p wire1

RP/0/0/CPU0:PE1(config-l2vpn-xc-p2p)#interface GigabitEthernet0/0/0/4

RP/0/0/CPU0:PE1(config-l2vpn-xc-p2p)#neighbor 3.3.3.3 pw-id 101

RP/0/0/CPU0:PE1(config-l2vpn-xc-p2p-pw)#commit

 

Configuring L2VPN on PE2:

 

Step1: Create pseudowire class:

PE2#conf t

Enter configuration commands, one per line. End with CNTL/Z.

PE2(config)#pseudowire-class TEST

PE2(config-pw-class)# encapsulation mpls

PE2(config-pw-class)#exit

 

Step2: Configure Cross connect on point to point interface

PE2(config-if)#int e1/0

PE2(config-if)# xconnect 1.1.1.1 101 encapsulation mpls pw-class TEST

PE2(config-if)#exit

 

Verification:

 

After you configure L2VPN on both PE devices, you should see cross connect states are UP both PE.

 

Verification on PE1:

RP/0/0/CPU0:PE1#sh l2vpn xconnect detail

Tue Feb 18 20:46:30.248 TLT

 

Group TEST, XC wire1, state is up; Interworking none

  AC: GigabitEthernet0/0/0/4, state is up

    Type Ethernet

    MTU 1500; XC ID 0x1; interworking none

    Statistics:

      packets: received 0, sent 0

      bytes: received 0, sent 0

  PW: neighbor 3.3.3.3, PW ID 101, state is up ( established )

    PW class not set, XC ID 0x1

    Encapsulation MPLS, protocol LDP

    PW type Ethernet, control word disabled, interworking none

    PW backup disable delay 0 sec

    Sequencing not set

 

      MPLS         Local                          Remote

      ------------ ------------------------------ -----------------------------

      Label        16003                          26

      Group ID     0x200000a0                     0x0

      Interface    GigabitEthernet0/0/0/4         unknown

      MTU          1500                           1500

      Control word disabled                       disabled

      PW type      Ethernet                       Ethernet

      VCCV CV type 0x2                            0x12

                   (LSP ping verification)        (LSP ping verification)

      VCCV CC type 0x6                            0x6

                   (router alert label)           (router alert label)

                   (TTL expiry)                   (TTL expiry)

      ------------ ------------------------------ -----------------------------

    MIB cpwVcIndex: 4278194081

    Create time: 18/02/2014 19:37:50 (01:08:40 ago)

    Last time status changed: 18/02/2014 20:43:20 (00:03:10 ago)

    Statistics:

      packets: received 0, sent 0

      bytes: received 0, sent 0

RP/0/0/CPU0:PE1# 

 

Verification PE2:

PE2#sh mpls l2transport vc 101 detail

Local interface: Et1/0 up, line protocol up, Ethernet up

  Destination address: 1.1.1.1, VC ID: 101, VC status: up

    Output interface: Et0/1, imposed label stack {16 16003}

    Preferred path: not configured

    Default path: active

    Next hop: 10.1.1.5

  Create time: 00:06:19, last status change time: 00:06:10

  Signaling protocol: LDP, peer 1.1.1.1:0 up

    Targeted Hello: 3.3.3.3(LDP Id) -> 1.1.1.1, LDP is UP

    Status TLV support (local/remote)   : enabled/not supported

      LDP route watch                   : enabled

      Label/status state machine        : established, LruRru

      Last local dataplane   status rcvd: No fault

      Last BFD dataplane     status rcvd: Not sent

      Last BFD peer monitor  status rcvd: No fault

      Last local AC  circuit status rcvd: No fault

      Last local AC  circuit status sent: No fault

      Last local LDP TLV     status sent: No fault

      Last remote LDP TLV    status rcvd: Not sent

      Last remote LDP ADJ    status rcvd: No fault

    MPLS VC labels: local 26, remote 16003

    PWID: 8212

    Group ID: local 0, remote 536871072

    MTU: local 1500, remote 1500

    Remote interface description: GigabitEthernet0_0_0_4

  Sequencing: receive disabled, send disabled

  Control Word: Off (configured: autosense)

  VC statistics:

    transit packet totals: receive 0, send 81

    transit byte totals:   receive 0, send 9630

    transit packet drops:  receive 0, seq error 0, send 0

 

3) You can also test pseudowire using MPLS OAM feature. You just need to enable “mpls oam” in configuration mode.

PE2#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

PE2(config)#mpls oam

 

RP/0/0/CPU0:PE1#conf t

Tue Feb 18 20:52:59.288 TLT

RP/0/0/CPU0:PE1(config)#mpls oam

RP/0/0/CPU0:PE1(config-oam)#commit

 

Verification:

PE2#ping mpls pseudowire 1.1.1.1 101 so 3.3.3.3

Sending 5, 100-byte MPLS Echos to 1.1.1.1,

     timeout is 2 seconds, send interval is 0 msec:

 

Codes: '!' - success, 'Q' - request not sent, '.' - timeout,

  'L' - labeled output interface, 'B' - unlabeled output interface,

  'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,

  'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,

  'P' - no rx intf label prot, 'p' - premature termination of LSP,

  'R' - transit router, 'I' - unknown upstream index,

  'l' - Label switched with FEC change, 'd' - see DDMAP for return code,

  'X' - unknown return code, 'x' - return code 0

 

Type escape sequence to abort.

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/3 ms

Total Time Elapsed 14 ms

 

RP/0/0/CPU0:PE1#ping pseudowire 3.3.3.3 101 so 1.1.1.1

Tue Feb 18 20:54:47.531 TLT

 

Sending 5, 100-byte MPLS Echos to 3.3.3.3 VC: 101,

      timeout is 2 seconds, send interval is 0 msec:

 

Codes: '!' - success, 'Q' - request not sent, '.' - timeout,

  'L' - labeled output interface, 'B' - unlabeled output interface,

  'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,

  'M' - malformed request, 'm' - unsupported tlvs, 'N' - no rx label,

  'P' - no rx intf label prot, 'p' - premature termination of LSP,

  'R' - transit router, 'I' - unknown upstream index,

  'X' - unknown return code, 'x' - return code 0

 

Type escape sequence to abort.

 

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/3 ms

RP/0/0/CPU0:PE1#

 

Finally check end to end connectivity that CE devices can ping and exchange routing information with each other.

CE1#ping 172.16.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

 

CE2#ping 172.16.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

 

RP/0/0/CPU0:PE1#sh l2vpn xconnect detail

Tue Feb 18 20:46:30.248 TLT

 

Group TEST, XC wire1, state is up; Interworking none

  AC: GigabitEthernet0/0/0/4, state is up

    Type Ethernet

    MTU 1500; XC ID 0x1; interworking none

    Statistics:

      packets: received 0, sent 0

      bytes: received 0, sent 0

  PW: neighbor 3.3.3.3, PW ID 101, state is up ( established )

    PW class not set, XC ID 0x1

    Encapsulation MPLS, protocol LDP

    PW type Ethernet, control word disabled, interworking none

    PW backup disable delay 0 sec

    Sequencing not set

 

      MPLS         Local                          Remote

      ------------ ------------------------------ -----------------------------

      Label        16003                          26

      Group ID     0x200000a0                     0x0

      Interface    GigabitEthernet0/0/0/4         unknown

      MTU          1500                           1500

      Control word disabled                       disabled

      PW type      Ethernet                       Ethernet

      VCCV CV type 0x2                            0x12

                   (LSP ping verification)        (LSP ping verification)

      VCCV CC type 0x6                            0x6

                   (router alert label)           (router alert label)

                   (TTL expiry)                   (TTL expiry)

      ------------ ------------------------------ -----------------------------

    MIB cpwVcIndex: 4278194081

    Create time: 18/02/2014 19:37:50 (01:08:40 ago)

    Last time status changed: 18/02/2014 20:43:20 (00:03:10 ago)

    Statistics:

      packets: received 0, sent 0

      bytes: received 0, sent 0

RP/0/0/CPU0:PE1# 

Related Information:

1033
Views
0
Helpful
0
Comments