Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Firmware Upgrade hangs...

Hello,

I'm attempting to upgrade my NSS from 1.3.0 firmware to 1.5.0 firmware...when I go to the firmware upgrade page, select the file, and then click upgrade it gives me the neverending uploading firmware box, until the system times out after 30 min.  The file is 100mb...I'm connected to a gigabit connection to the same network that the NSS is on...what gives?  No errors in the log...anyway to troubleshoot this?

Also any benefit to upgrading to the QNAP firmware?  I haven't done any searching but it looks like cisco is dumping this product...

john

8 REPLIES
Cisco Employee

Firmware Upgrade hangs...

Hi John -- Try clearing your cache and cookies, open a fresh browser, and go to:

http://www.cisco.com/cisco/software/type.html?mdfid=282984441&i=rs. If the issue persists, please contact the Small Business Support Center. You'll find international contact numbers at www.cisco.com/go/sbsc.

Thanks for participating in the community.

Stephanie Reaves

Cisco Small Business

Gold

Firmware Upgrade hangs...

John,

It is recommended to "step" the firmware on the NSS series. Try upgrading to 1.4 first, then 1.5.

Community Member

Firmware Upgrade hangs...

I am having the same problem.  I have a NSS322 with firmware version 1.4 trying to upgrade to 1.5.  The upgrade page just hangs.  I can open another page and log onto the NAS no problem.

Can you just skip the 1.5 upgrade and move to QNAP?

Kriss

Community Member

Firmware Upgrade hangs...

The concept of firmware upgrade are as follow:

1. Using the GUI, select the firmware and click update firmware.

2. The GUI screen will displayed "Uploading....".  During this time system will check hardware by sending the MD5 file to validated correct hardware before uploading the firmware. When MD5 is matched, user would received the confirmation of correct hardware with display of the MD5 value.

3. Click OK on the MD5 confirmation window. Then you observed the upload status bar from your local machine to the NSS. This is when 100MB file sent from PC to NSS temporary directory.  Firmware will be running only system is reboot or power OFF/ON.

4. After the firmware completed sent to a directory, user will be asked to reboot in order the system run on latest firmware. Click OK means, NSS will be running new a firmware after reboot. If click Cancel, NSS is keep running current FW until next reboot.

--> During the reboot and bring NSS to operation, the GUI screen on local PC is actually keep running until NSS will be sent a login screen to the machine user. For any reason if the machine did not receive the signal from NSS, the GUI keep running. In reality, the upgrade process was successfully done within approximately 3-4 minutes from MD5 checksum to full operational.  I think this is what you observed, so by refresh from the browser or open a new one and access to NSS GUI, you would see it is done already.

For John Wildes's issue: His NSS did not complete the confirmation of MD5 checksum, therefore the GUI is keep waiting by spinning the "Uploading...".  The issue could be the data route, in some case a PC with two NIC interfaces or firmware file on the WAN or different VLAN or PC is using wireless device to upgrade firmware.  Packet loss during the upgrade can create the spinning GUI.

The QNAP's firmware only upgrade the NSS that running firmware 1.5.0.  The MD5 file is checking this, if NSS is not load with 1.5.0. The upgrade will be failed. Cisco only recommend the upgrade from 1.5.0 to QNAP firmware.

Community Member

Firmware Upgrade hangs...

My issue also does not complete the checksum, so what could be the problem?

Silver

Firmware Upgrade hangs...

Kriss,

Try pushing the firmware via discovery tool.

Also give us a call @ 1-866-606-1866 and open a support case if you still having trouble.

Jasbryan

Community Member

Firmware Upgrade hangs...

Dear Jasbryan

Just tried that but the software asks for an img file and does not recognise the file which I downloaded.

What next???

Kriss

Community Member

Firmware Upgrade hangs...

Solved!

You were right Jasbryan, but I had to change the file type from img to All Files *.* I then chose the downloaded upgrade file and it worked.

Thanks for your help.

I just thought I would post this to give any other people who may come up against the same problem.

Cheers

Merry Xmas

Kriss Cringle

2844
Views
5
Helpful
8
Replies
CreatePlease to create content