Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

NSS 326 Loading Drivers Please Wait

Hello,

Our NAS was unable to start up today and is perpetually stuck display "Loading Drivers Please Wait"

The console is continually giving the error "mdadm: Cannot open /dev/sdb1: No such device or address"

Everyone's tags (6)
3 REPLIES
New Member

NSS 326 Loading Drivers Please Wait

The NSS326 consist of 6 disks (/sdXY where X is a,b,c,d,e,f represented a=1, b=2, c=3, d=4, e=5, f=6 and Y is 1,2,3,4). The Y value is the partitions in a disk. The error "mdadm: Cannot open /dev/sdb1: No such device or address", is pointing to disk#2 on partition #1 which is boot partition.  This is telling me the boot partition is bad and it is stucked in the recovering mode but failed to recover to restore the media for this partition. It is not looking good if boot partition is bad.

Can you describe what happened originally? What does the web admin show the status of your drives and volumes as? Is disk #2 LED keeps flashing ?  Was the disk bought with the chassis ?  Type of the disk ?

A workaround for this to continue to boot is temporary remove disk #2 (unplug and pull out only). DO NOT remove any other disk while system is powering.

When you have the access to SSH or CLI from the console, can you please post the print out from some of the commands below:

# cat /proc/mdstat

# cat /etc/raidtab

# cat /etc/storage.conf

# mdadm -D /dev/md0

# mdadm -E /dev/sda3

# df -h

New Member

NSS 326 Loading Drivers Please Wait

Hello clindoan,

Thank you for this very helpful post.

We have had issues with disk #2 since purchase of the NAS. We are not able to login to the web admin or detect that it is on the domain since it does not get past the loading drivers. Disk #2 is the only one that flashs very often in green.

Before we perform the workaround you recommended, I would like to be on the safe side and back up our HDDs in case the raid is created and data loss. Is there a safe method you recommend for back up?

After we backup I would like to remove the disk in question and post the output for the commands you mentionded.

Thank you in advance for your help.

New Member

NSS 326 Loading Drivers Please Wait

TN,

   There is no possible way to backup the data without system is in operational state. The operational status could be degarded or normal mode. The degraded mode is usually with a bad disk.  So to trouble shoot your unit:

1) When disk # 2 's LED is flashing, you can eject it out for the process continue with the boot process. If there is only one bad disk (assuming disk# 2), your unit will come up in degraded mode. When it is operational (you can access to the GUI), you then can backup your data.

Note: PLEASE DO NOT remove more than 1 disk when your unit is powered. Doing so will corrupted the boot partition.

2)  If when you remove your disk#2, and your system cannot operate in degraded mode.I would recommend to call Cisco Technical Support so they can help you out.

Note: You stated that disk#2 was bad when you bought it. I am a little suprised that you let this disk to be in your unit. That disk should be replaced before you built your unit.

  Please try step 1 out and let me know.

1630
Views
0
Helpful
3
Replies