Cisco Support Community
Community Member

NSS324 - Apache re-launch process error


Since today morning my web server isn't working. My firmware is up to date(1.5.0).

I try to reboot it and i use the firmware upgrade process. I turn the web server on and off many times.

Actually, there's only 3 persons using the webserver  and i don't use any mysql database. I only use a simple web pdf creator  on the web server for creating quotation.

My system log:

2012-06-2012:43:41System127.0.0.1localhostRe-launch process [apache].
2012-06-2012:43:11System127.0.0.1localhostRe-launch process [apache].
2012-06-2012:42:41System127.0.0.1localhostRe-launch process [apache].
2012-06-2012:42:11System127.0.0.1localhostRe-launch process [apache].

The errors have been going on this morning and no parameters has been changed.

Everything else is ok ! I can access to the administration web interface in https..

Thanks in advance,


Community Member

NSS324 - Apache re-launch process error


Problem is not fix.

Anyone know if it's possible to reinstall apache without using the "Restore to Factory Default" option.



Community Member

NSS324 - Apache re-launch process error

Hi Arnaud,

   The apache configuration file is messed up which created a restart for the process as indicated in the log. To fix this issue, you would need to re-update the same version of firmware currently operate on your unit.  The process will be recreated based from your current database.


Community Member

NSS324 - Apache re-launch process error

Hi Clindoan,

Thanks for your answer.

I already try to update the firmware and i try it today too.

My log :

2012-06-2709:38:34System127.0.0.1localhostRe-launch process [apache].
2012-06-2709:38:04System127.0.0.1localhostRe-launch process [apache].
2012-06-2709:37:34admin10.224.127.44---[Web Server] Started successfully.
2012-06-2709:35:58System127.0.0.1localhostphpMyAdmin 3.2.0 has been installed in /share/Web/phpMyAdmin.
2012-06-2709:35:54System127.0.0.1localhostWordPress 2.8 has been installed in /share/Web/wordpress.
2012-06-2709:34:16System127.0.0.1localhostSystem started.
2012-06-2709:31:32System127.0.0.1localhostSystem was shut down on Wed Jun 27 09:31:32 CEST 2012.
2012-06-2709:27:02System127.0.0.1localhostSystem updated successfully from 1.5.0 to 1.5.0.

It's possible to reinstall apache separetly ? I'm not sure that something is done with apache



Community Member

NSS324 - Apache re-launch process error


  The root cause for the restarted of the apache is the configuration file messed up. Whatever in the apache.conf file made the process restarted, this could be the database component(s) or PKG application that is using the apache process-- something that are not automatically set correctly between process and application.  I 've done in the past to fix this issue was (1) re-upgrade the same firmware version or (2) Upgrade to the newer version.  Now, we have tried (1) but did not helped. Since Cisco is no longer in the Small Business for NAS, I would recommend you to upgrade to QNAP firmware. You can have much more software support in the community forums and other rich feature sets that QNAP maintain and added for each major FW release.  Many of our NSS customers had done this route and found much more flexible to find the answers they need.

Follow are two options that I think is a path to fix your NSS issue.

1) Update NSS to use QNAP firmware:

  a- Upgrade from Cisco firmware 1.5.0 => QNAP (Model: TS-459 Pro + (Plus)) FW 3.5.0

  b- Upgrade from 3.5.0 to the latest 3.7.0 firmware

Note: Upgrade from 1.5.0 to QNAP 3.5.0 has been tested so this works for sure. I also tried to upgrade from 1.5.0=> 3.6.x. This also worked. QNAP just released FW 3.7.0, you can try upgrade direct from 1.5.0 => 3.7.0. The important for the upgrade is NSS must running 1.5.0 in order to upgrade to QNAP 's FW 3.5.x or higher.

  Link to download QNAP firmware:

2) If you know what to do with the apache.conf file, you can edit manually to make sure the file 's content are correctly written.  Here is a link from QNAP and you may need to do some more research to understand before do this step.


Please let me know how it goes, I am interesting to make sure your unit is operational without any issue.


Community Member

Re: NSS324 - Apache re-launch process error

Hi Clindoan,

Wow, what a nice answer. Thanks so much.

I've fix my problem, not entirely but now my apache server is working.

I find a topic on the QNAP community forum :


It's not that difficult.

Ensure SSH access is enabled on the NAS, so you can login from your computer (Windows:


,  OS X Terminal app: ä ssh admin@[NAS-IP-address]) using the admin  credentials. Then you can enter the commands (the [~] shows just the  currecnt directory, the # is the prompt.

Please post the output - just copy and paste the text from the terminal:

[~] # /etc/init.d/ restart


Suspect the apache.conf is broken:

[~] # /etc/init.d/ stop


[~] # cp /etc/default_config/apache.conf /etc/config/apache/apache.conf

[~] # /etc/init.d/ start


Now retry please.

If you are not comftable with that, contact QNAP support.

That answer helped me fixing the problem except index.htm files doesn't work on the server now... This is a problem but it work with php files..

And now, it's really a good new for me that QNAP firmware are compatible. I don't find QNAP 3.5.0 firmware on your link but i found it here :

Like you say, the community seems to be really powerfull.

I'm going to upgrade to QNAP because it'll maybe fix the html file problem.. Every config parameters are keep on QNAP ? Services like : web file manager are working with the same installed permission accounts ?

I'll do a feedback of my transition to QNAP later cause i'm not very confident with that.

Thanks you so much again for your help,

Best regards,



QNAP Firmware 3.5.0 has been installed with success and it fix the problem ! I'm waiting for updating to 3.7.1.

Thanks again

Ce message a été modifié par: Arnaud Grimaldi

Community Member

Re: NSS324 - Apache re-launch process error


  I am glad that worked out for you.  For any firmware/software related issue, you can use QNAP forum for answer. For hardware/chassis, you have 5 years warranty from Cisco counted on the date you purchased. So you are in the win-win situation.

Thank you for your business!! 

Best Regards.

CreatePlease to create content