Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

NSS4000 not working properly


Successfully upgraded firmware on our NSS4000 Serial: 7PI00G402034 to the version 1.14-20 (Thu, 18 Dec 2008 11:11:03 +0000)

Everything working fine in WORKGROUP. Time is synchronized correctly with our NTP server. I am able to connect device to Active Directory Domain indicating Status: Join is OK. See all Domain accounts and groups in the list.

But when create CIFS share and start copy job using defined domain account, the device start rebooting itself after random time (approximately 30 minutes).

Find attached the complete log file right after first restart. We will appreciate any help on this.


Everyone's tags (4)
Cisco Employee

Re: NSS4000 not working properly

Hello Tomas --

Thanks for posting. I have discussed your issue with the engineering team. Seems the likely issue is that, since the NSS is synchronized to the NTP server, your Active Directory server has a time mismatch with your NTP time server.  Please check if there is a > 5 minute time difference between the two.  If so, be sure to synchronize the time between the NSS and the ADS server, and see if the problem goes away.

Let us know the outcome.



New Member

Re: NSS4000 not working properly

Thank you for replying Stephanie.

NTP time server used is also domain controller. Also tried different NTP servers but got the same behavior.

Used batch file to check time on both, NSS and NTP time server, finally the difference was not bigger than few seconds between them.

Find attached the logs after many unexpected reboots.



New Member

Re: NSS4000 not working properly


  I could not get the tar file to unzip to find out what might cause the NSS behave that way.  Anyway, I 've seen this issue before and to fix it, the NTP Sever field form the GUI needs to have the IP address of ADS server. Make sure you enter these 3 fields with ADS Server IP address, also un-checked the box "Assign automatically via DHCP". Also, making sure the W32Time service is running on server. If this service is not running, the NTP time for NAS is not getting its time.

Hope that will fixed your problem.


New Member

Re: NSS4000 not working properly

Hello Clint,

Filled all three fields and check W32 Time as you wrote but unexpected power cycle occurred again. I’m also tried, as written in NSS4000 v1.14 Release Notes, open caveat CSCsw86138, to set time manually. After do this and join NSS to Active Directory domain the unexpected power cycles occurred more often, even checked that time difference was again not bigger than few seconds. Therefore, I suggest that this is not time synchronization issue, since it works well.

Anyone has any idea where to look for the cause of this behavior? I tried to capture packets using Wireshark and everything looks all right.

Find attached the log in text file.


New Member

Re: NSS4000 not working properly


Unfortunately we find out that unexpected power cycle occurrs even there is no copy job.

Here is the exact steps when connecting to Active Directory Domain:

    1. Reset to factory defaults
    2. Create RAID5 and new Volume (no Share created)
    3. Set Home Directory Location as created in step 2.
    4. Configure Static IP
             - No VLANs defined
             - Only LAN1 interface connected
             - Bonding Mode - Active Backup (Failover)
    5. Set NTP servers and check that time is within 5 minutes of the time on our ADS Domain Controller
    6. Configute DNS Search Domain and DNS Server
    7. Create new computer in ADS
    8. Connect to Active Directory Domain
             - Hostname: as created in step 7.
             - Enable support for large ADS Domains
             - System Volume Location: as created in step 2.
    9. See the message "Join is OK"  next to Status, it is possible to list all domain users and groups

After this close configuration interface and wait.
    1st unexpected power cycle came in 56 minutes (See attached: Wireshark_log.txt - Packet No.: 543)
             - Nss becomes inacessible (no responses for ICMP ping) so i must manualy disconnect LAN1 and plug it back
             - Then a was able to log and download log file (See attached: log[1].09.16.09-13.27.tar)
    2nd in 71 minutes after last boot
             - RAID becomes Stopped starus (SATA1 drive LED not lights)

             - Join to domain Status shows "Join to domain is not valid: Undetermined error" as System Volume Location is not present anymore.
             - Downloaded log file also after this power cycle (See attached: log[1].09.16.09-14.38.tar)

I was tested this again and saw that at some cases there is more power cycles until RAID becomes Stopped status > NSS lost connection with Active Directory > unexpected power cycles stops.

Only thing I find strange is that there is no responses to the NBNS Name queries. Anyone know what this could be, or whether it's normal?

Appreciate any suggestions.


Possible protocol explanation in Wireshark_log.txt:

BROWSE     To be visible in Network Places
SSDP          Standard multicast address for UPnP aware listeners (Should be turned off uner Network > Options)
MDNS          As it have broadcast destination, it should be DNS service for Zeroconf
NBNS          When there is <1b> it shoul be query for master browser

New Member

Re: NSS4000 not working properly


We have looked through your issue, and at this point, my suggestion would be to have you call in to the small business support center so that we can create a case for your NSS4000, and the issue that you are having.  At that point, we would most likely decide to escalate your issue to the engineers to have them look farther into this issue.

US SBSC: 1-866-606-1866

Thank you,


CreatePlease to create content